Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Graphicproblems since Ubuntu 10.04

  1. #1
    Join Date
    Jun 2010
    Posts
    9

    Default Graphicproblems since Ubuntu 10.04

    Hello!

    I have a problem with my graphics card in combination with the proprietary linux driver Catalyst 10.6. The problem looks like this:



    I didn't had this problem with Ubuntu 9.10 and haven't changed anything on my systems hardware.

    My system:

    Ubuntu 10.4
    Board: MSI 785GM-E51
    Graphic card: Radeon HD 4200 (onBoard)
    Driver: Catalyst 10.6

    I have posted this problem in 3 different linux boards, noone could help me. I tried installing Catalyst 10.4, 10.5 and 10.6 with the ATI-installer. I also tried the driver that is shipped with Ubuntu. I tried changing the resolution in the CCC and with "sudo aticonfig --resolution=0,1024x768,800x600". I tried adding a modeline from the xorg.log. Nothing seems to help.

  2. #2
    Join Date
    May 2010
    Posts
    29

    Default

    If you started by installing from the ATI installer, I would try to completely obliterate all installed files from that, and then try the fglrx installer from the X-Swat PPA. I had similar issues until I did so.

  3. #3
    Join Date
    Jan 2009
    Posts
    303

    Default

    if you use the open source driver no xorg.conf is required

    for the fglrx driver you must generate a default configuration with the command which should at least get 2d/3d acelleration working

    sudo ati-config --initial

    If you have manually deleted or copied files save yourself the trouble (read hours of confusion vs an hour reinstall) and reinstall you whole system and use the package manager for such things.

  4. #4
    Join Date
    Jun 2010
    Posts
    9

    Default

    Quote Originally Posted by noobish View Post
    If you started by installing from the ATI installer, I would try to completely obliterate all installed files from that, and then try the fglrx installer from the X-Swat PPA. I had similar issues until I did so.
    This sounds good. But in the X-Swat PPA there is no package named fglrx-installer. Can you tell me how to install the driver from the X-Swat PPA? Thanks.

  5. #5
    Join Date
    Jun 2010
    Posts
    9

    Default

    Ok, fglrx-installer is the name of a group that contains the following packages: fglrx fglrx-amdcccle fglrx-dev fglrx-kernel-source fglrx-modaliases xorg-driver-fglrx

    I just installed all these packages. But what now?

    I tried to generate a xorg.conf with sudo aticonfig --initial but it says "command not found". What am i doing wrong?

  6. #6
    Join Date
    Jun 2010
    Posts
    9

    Default

    Why does "sudo aticonfig --initial" not work after installing the fglrx-packages?

  7. #7
    Join Date
    Jul 2010
    Location
    http://quasimal.com
    Posts
    13

    Default

    Quote Originally Posted by muvo View Post
    Why does "sudo aticonfig --initial" not work after installing the fglrx-packages?
    Try "sudo ati-config --initial" instead of "sudo aticonfig --initial" like the person above said.

  8. #8
    Join Date
    Jun 2010
    Posts
    9

    Default

    Quote Originally Posted by mikeplus64 View Post
    Try "sudo ati-config --initial" instead of "sudo aticonfig --initial" like the person above said.
    The manual says "sudo aticonfig --initial" is the correct command.

  9. #9
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,567

    Default

    If your xorg.conf has been hand-edited you might want to add -f as well. That gives aticonfig more freedom to change your xorg.conf as required.

    If you're getting "command not found" though that may just mean you're not in the right directory. The install instructions at amd.com (navigate to the driver download page) tell you which directory to run the command from.

    If that's not it then maybe the driver just didn't get installed. Anyways, check the install instructions to find out which directory the command should be in. I guess this could be over-ridden by something distro-specific but I don't think aticonfig moves between distros.

  10. #10
    Join Date
    Jun 2010
    Posts
    9

    Default

    The install instructions say that it is not required to run the command from a specific directory.

    I now created the xorg.conf by hand. When i start Ubuntu it says fglrx not found. So i guess the driver just isn't installed. But what else is to do but installing the packages?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •