Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 44

Thread: How An Old Pentium 4 System Runs With Ubuntu 10.04, 10.10

  1. #21
    Join Date
    Aug 2009
    Posts
    1

    Default

    i have fought with radeon cards and linux for some time now. so i am glad to see this article. i'm running a pentium 4 2Ghz, 1.5GB pc333 ram with a sapphire radeon 9600. dual sata 500GB drives handle disk i/o fairly well even at half their i/o at 1.5 GB/sec on an adaptec pci card. the radeon r250, r300 and r350 cards have been an up and down performers in linux for some time and i vacillated between debian and ubuntu, since they sometimes run different versions of xorg.

    ubuntu 9.04 performed very well with compiz and flash. 9.10 wasn't as stellar, but was acceptable. 10.04 compiz seems sluggish and flash is a jerky mess. 10.10 runs things fair, compiz is smooth and flash is playable, but not at full screen. i expected better support from an lts release. and i could run an older ubuntu, but why do that, it's all about the up to date software right. might as well run debian.

    this system has excellent specs, but the video performance has me making os decisions i am not fond of and i have several opinions on the matter, but i best leave them to myself. i'm saving my money for an intel i3! - thanks

  2. #22
    Join Date
    Oct 2007
    Posts
    45

    Default

    What's it with Himeno? SMP optimizations? Looks scary

  3. #23
    Join Date
    Jun 2010
    Location
    Poland
    Posts
    24

    Default

    Tests are good and shows some of the features of Pentium 4 architecture. However I think, you should do test on AMD64 platform with Athlon64 3000+ Venice and laters with this amd's architecture.

  4. #24

    Default

    Quote Originally Posted by pmorph View Post
    What's it with Himeno? SMP optimizations? Looks scary
    On a single core CPU?

  5. #25
    Join Date
    May 2010
    Posts
    4

    Default

    interesting tests. until very recently, i was running lucid on a an athlon xp 2500+ (@1.8GHz)-based setup with an nvidia 6800. The only thing it couldn't do well was HD video. otherwise, it worked fine, even games -- at least, i don't see a significant improvement in games and i'm running 2 9800 GTX+ in SLI now...

    wish i thought to try to benchmarking before the upgrade -- it would have been interesting to see my own results.

  6. #26
    Join Date
    Aug 2009
    Location
    O'Fallon, MO
    Posts
    44

    Default

    I don't really understand the usefulness of this test. A P4 2.8ghz with 512mb of RAM isn't an "antiquated" machine. While clearly not the newest thing out there, I certainly wouldn't think it relevant for testing an OS's performance on older hardware.

    If we really want to get some interesting results, do the tests on a P3 800mhz machine with 256mb of RAM and onboard video with 8mb of video RAM. There are still many, many people running such machines with Windows 98 or even XP.

  7. #27
    Join Date
    Oct 2007
    Posts
    45

    Default

    Quote Originally Posted by kraftman View Post
    On a single core CPU?
    Could SMP optimized kernel bring that big penalty when running single core? No idea really, it just amazes me it got so much slower with a pure CPU/memory test.

  8. #28
    Join Date
    Jan 2009
    Posts
    291

    Default

    Well I recently installed Lucid on an 800Mhz PIII 390ish Mb ram .... it runs like crap but it does run.


    The X11 proformance is very bad as in most of these machines you end up having a cheap mach64 based card (8 mb vram if you have 4mb don't even thing about it X.x)

    by the way the mach64 driver and a few others are *greatly* in need of maintainace they aren't bad cards and work fine for 2D and very basic 3D acelleration but the developers of these cards seem to be short on time to work on keeping them working.

  9. #29
    Join Date
    Feb 2009
    Posts
    7

    Default

    GCC has changed between 4.2.4 and 4.4.3, and I suspect the march and mtune flags Ubuntu uses have changed too (or gcc's defaults). That would affect cpu-bound performance a lot, if it used to optimize for netburst and now optimizes for atom or old athlon.

    I have a Pentium III 733 with that video card and 1GB ram. It runs Ubuntu 10.04 but the performance is worse than it was a few years ago (subjectively). I'd start with compiling everything for the right processor, using ramzswap as already recommended and maybe disabling some fancy stuff that became fashionable with faster computers (background indexing for example). A comparison of gcc 4.2.4 vs. 4.4.4 vs. 4.5.1 (4.5 branch from svn) with -march=pentium4 on that machine for cpu-bound code would be interesting. Also, try disabling HyperThreading and making sure kernel and glibc are not SMP or try playing with the HT-aware scheduler in the kernel. Benchmarks of those could be interesting.

    The chipset is suspect. Maybe there was a driver regression and nobody noticed? Try another motherboard.

  10. #30
    Join Date
    Aug 2009
    Location
    south east
    Posts
    342

    Default

    Stickies would be nice for these types of forums.

    Basics:
    Five major points
    1. Compile the kernel for Pentium 4
    2. Set the scheduler for deadline
    3. Drop the kernel option for ram down to less than 1 Gigabyte
    4. Recompile GLibc to i686 and march=pentium4
    5. Choose the Ext3 filesystem

    You will notice a difference even if only you just set the kernel processor type to Pentium 4 and set 1 Gigabyte or lower ram.

    I'm not up here to argue the Force hokey stuff or any of that galactic imperialism that those jerks over in the nothing wrong here camp does. We have to take a lesson from the GenT0o.

    I have two of the P4's, a celeron and a full fledged. Speaking on behalf of my experiences with Nvidia and the 10.04 version of Ubuntu I can say at the moment I've been unable to enable compiz.

    Lot's of people are still running these on XP. That is P4's.

    I noticed not long ago that Ubuntu complains about the intel_gart=blacklist parameters which are the only ways I get one of my P4's to boot other than pulling the pci card out to let the intel one nurse the installations.

    I think Canonical should just release a statement that older hardware may need to stay with an older branch of Ubuntu....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •