Results 1 to 10 of 14

Thread: ATI CrossFire Does Not Support On This Platform When Enabling (Ubuntu Lucid)

Hybrid View

  1. #1

    Default ATI CrossFire Does Not Support On This Platform When Enabling (Ubuntu Lucid)

    I recently installed the ATI Catalyst Driver 8.74 and Catalyst Control Center 10.6 in Ubuntu Lucid, everything works fine so far except the CrossFire. After setting up and then enabling the CrossFire (all in sudo): "aticonfig --cf=on --adapter=0" I received this message in the terminal:
    CrossFire chain(s) enabled
    CrossFire does not support on this platform

    When I run the command: "aticonfig --lsch" I get:
    CrossFire chain for adapter 0, status: enabled
    and then it lists my adapters in the CrossFire chain.

    But "aticonfig --lscs" list the CrossFire status as disabled on the current device". I guess this is apparently different than the chain status “aticonfig –lsch”??

    I'm confused at this point because although the terminal says my platform does not support CrossFire, I know it does. I am using an MSI K9A2 Platinum MB and two Sapphire HD3870 cards. The cards are installed in the correct slots (EX1 and EX4 with two ribbon cables joining them). According to the MB manual this is how the CrossFire is enabled as there are no settings in the BIOS to enable it. Any help will be greatly appreciated!

  2. #2

    Default

    Bump

    bump

  3. #3

    Default

    Quote Originally Posted by alteredstate View Post
    I recently installed the ATI Catalyst Driver 8.74 and Catalyst Control Center 10.6 in Ubuntu Lucid, everything works fine so far except the CrossFire. After setting up and then enabling the CrossFire (all in sudo): "aticonfig --cf=on --adapter=0" I received this message in the terminal:
    CrossFire chain(s) enabled
    CrossFire does not support on this platform

    When I run the command: "aticonfig --lsch" I get:
    CrossFire chain for adapter 0, status: enabled
    and then it lists my adapters in the CrossFire chain.

    But "aticonfig --lscs" list the CrossFire status as disabled on the current device". I guess this is apparently different than the chain status “aticonfig –lsch”??

    I'm confused at this point because although the terminal says my platform does not support CrossFire, I know it does. I am using an MSI K9A2 Platinum MB and two Sapphire HD3870 cards. The cards are installed in the correct slots (EX1 and EX4 with two ribbon cables joining them). According to the MB manual this is how the CrossFire is enabled as there are no settings in the BIOS to enable it. Any help will be greatly appreciated!
    Also stumbled across this in terminal:


    user@desktop:~$ sudo aticonfig --lsa
    * 0. 01:00.0 ATI Radeon HD 3870
    1. 04:00.0 ATI Radeon HD 3870

    * - Default adapter
    user@desktop:~$ aticonfig --lscc

    Master adapter: 0. 01:00.0 ATI Radeon HD 3870
    Candidates: none
    user@desktop:~$ aticonfig --odgt

    Default Adapter - ATI Radeon HD 3870
    Sensor 0: Temperature - 43.00 C
    user@desktop:~$ aticonfig --odgc

    Default Adapter - ATI Radeon HD 3870
    Core (MHz) Memory (MHz)
    Current Clocks : 300 1126
    Current Peak : 776 1126
    Configurable Peak Range : [300-885] [1126-1387]
    GPU load : 0%
    user@desktop:~$ aticonfig --odgc --adapter=1
    ERROR - Get clocks failed for Adapter 1 - ATI Radeon HD 3870
    user@desktop:~$ aticonfig --odgt --adapter=1
    ERROR - Get temperature failed for Adapter 1 - ATI Radeon HD 3870



    Is this a good indication that something is wrong with adapter 1 graphics card since the "aticonfig --odgt and --odgc" commands work for adapter 0 but not adapter 1? I cannot get a response from adapter 1 but yet the "aticonfig --lsa" command recognizes it as a working adapter. Has anyone had this sort of problem before? Again, I'm just trying to enable CrossFire.

  4. #4
    Join Date
    Oct 2007
    Posts
    321

    Default

    Crossfire does not always work... What is the contents of the command lspci? Also, can you mention the model of motherboard, and cpu?

  5. #5

    Default

    Quote Originally Posted by Dandel View Post
    Crossfire does not always work... What is the contents of the command lspci? Also, can you mention the model of motherboard, and cpu?
    Thank you for your reply!

    Also wanted to add that I am using Ubuntu Lucid x64.

    Here is the information you requested:


    Mainboard= MSI K9A2 Platinum AM2+/AM2 AMD 790FX ATX AMD

    CPU= AMD Phenom II X4 940 Black Edition Deneb 3.0GHz 4 x 512KB L2 Cache 6MB L3 Cache Socket AM2+ 125W Quad-Core Processor

    Video Cards= SAPPHIRE 100225L Radeon HD 3870 512MB 256-bit GDDR4PCI Express 2.0 x16 HDCP Ready CrossFireX Support

    user@desktop:~$ lspci
    00:00.0 Host bridge: ATI Technologies Inc RD790 Northbridge only dual slot PCI-e_GFX and HT3 K8 part
    00:02.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (external gfx0 port A)
    00:05.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port B)
    00:09.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port E)
    00:0b.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (external gfx1 port A)
    00:12.0 RAID bus controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
    00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
    00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
    00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
    00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
    00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
    00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
    00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
    00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
    00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
    00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
    00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
    00:18.0 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration
    00:18.1 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map
    00:18.2 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control
    00:18.4 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control
    01:00.0 VGA compatible controller: ATI Technologies Inc Radeon HD 3870
    01:00.1 Audio device: ATI Technologies Inc Radeon HD 3870 Audio device
    02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
    03:00.0 RAID bus controller: Promise Technology, Inc. PDC42819 [FastTrak TX2650/TX4650]
    04:00.0 VGA compatible controller: ATI Technologies Inc Radeon HD 3870
    04:00.1 Audio device: ATI Technologies Inc Radeon HD 3870 Audio device
    05:00.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev c0)
    05:02.0 Multimedia audio controller: Creative Labs SB X-Fi
    05:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

  6. #6
    Join Date
    Oct 2007
    Posts
    321

    Default

    try this command:
    Code:
    aticonfig --adapter=0,1 --cfa
    Then Reboot and run this command:
    Code:
    aticonfig --lsch
    if that command does not say that crossfire is not enabled, run this command:
    Code:
    aticonfig --adapter=0,1 --crossfire=on
    reboot again, and then run the previous step's command to verify that crossfire is working.

  7. #7

    Default

    Quote Originally Posted by Dandel View Post
    try this command:
    Code:
    aticonfig --adapter=0,1 --cfa
    Then Reboot and run this command:
    Code:
    aticonfig --lsch
    if that command does not say that crossfire is not enabled, run this command:
    Code:
    aticonfig --adapter=0,1 --crossfire=on
    reboot again, and then run the previous step's command to verify that crossfire is working.
    Here's what I got:

    user@desktop:~$ aticonfig --adapter=0,1 --cfa
    CrossFire chain added
    Warning: X needs to be restarted before CrossFire changes take effect.

    Reboot

    user@desktop:~$ aticonfig --lsch
    CrossFire chain for adapter 0, status: disabled
    0. 01:00.0 ATI Radeon HD 3870
    1. 04:00.0 ATI Radeon HD 3870

    user@userdesktop:~$ aticonfig --adapter=0,1 --crossfire=on
    Warning: No CrossFire chain defined for master adapter 1
    CrossFire chain(s) enabled
    CrossFire does not support on this platform
    Warning: X needs to be restarted before CrossFire changes take effect.

    Reboot

    user@desktop:~$ aticonfig --lsch
    CrossFire chain for adapter 0, status: enabled
    0. 01:00.0 ATI Radeon HD 3870
    1. 04:00.0 ATI Radeon HD 3870

    However when I run the CrossFire status command I get this:

    user@desktop:~$ aticonfig --lscs
    Candidate Combination:
    Master: 0:0:0
    Slave: 0:0:0
    CrossFire is disabled on current device
    CrossFire Diagnostics:
    CrossFire can work with P2P mapping through GART


    So I'm assuming that just because the CrossFire chain is enabled doesn't mean the CrossFire is working? This is where I'm stuck as I don't understand why aticonfig would allow the chain to be enabled but not allow me to “flip the switch on” for the CrossFire. Any ideas?

  8. #8

    Default

    I think I've exhausted all possible problems. I swapped the video cards and still have the same issue. I've also tried loading Ubuntu Karmic x86 & x64 versions and then installing the Catalyst 10.6 but still no luck. I also installed Lucid x86 and...yes you guessed it, no success. This is sucking up a lot of my freetime, why is this so difficult? I didn't have these sort of problems with Windows...I'm half tempted to go back to Windows even though I don't want to but I miss that functionality of certain programs and my hardware.

  9. #9
    Join Date
    Jul 2011
    Posts
    21

    Default

    xD i have the same problem! i think its related to true pcie-express speed of the motherboards pcie slots... or support of p35 chipset... im stuck too and wasted a lot of free time!

    BUT!

    it can work in windows, so it can work in linux, too!

    i think xorg and kms mix up and get confused...

    seems to be a problem with 1 monitor / screen...

  10. #10
    Join Date
    Jun 2012
    Posts
    1

    Question

    I have the very same problem as alteredstate. I have Radeon HD 5850 in first x16 PCIe slot of my motherboard(ASUS Crosshair V Formula) and Radeon HD 5870 in the third x16 PCIe slot(based on motherboard manual recommendations): http://i.imgur.com/OKQpS.png

    Short system summary can be seen here:

    Code:
    root@debian64:~# uname -a
    Linux debian64 2.6.32-5-amd64 #1 SMP Sun May 6 04:00:17 UTC 2012 x86_64 GNU/Linux
    root@debian64:~# cat /etc/issue
    Debian GNU/Linux 6.0 \n \l
    
    root@debian64:~# lspci | grep -i VGA
    01:00.0 VGA compatible controller: ATI Technologies Inc Cypress [Radeon HD 5800 Series]
    07:00.0 VGA compatible controller: ATI Technologies Inc Radeon HD 5870 (Cypress)
    root@debian64:~# cat /proc/cpuinfo | grep -i model
    model		: 1
    model name	: AMD FX(tm)-4100 Quad-Core Processor            
    model		: 1
    model name	: AMD FX(tm)-4100 Quad-Core Processor            
    model		: 1
    model name	: AMD FX(tm)-4100 Quad-Core Processor            
    model		: 1
    model name	: AMD FX(tm)-4100 Quad-Core Processor            
    root@debian64:~#
    As you can see from lspci(8) output, both graphics cards are detected. Same can be confirmed with aticonfig(I installed the latest AMD proprietary driver for x86-64 architecture with the amd-driver-installer-12-4-x86.x86_64.run package):
    Code:
    root@debian64:~# aticonfig --list-adapters
    * 0. 01:00.0 ATI Radeon HD 5800 Series 
      1. 07:00.0 ATI Radeon HD 5800 Series
    
    * - Default adapter
    root@debian64:~#
    I created a new CrossFire chain:

    Code:
    root@debian64:~# aticonfig -v --adapter=0,1 --add-crossfire-chain
    CrossFire chain added
    Warning: X needs to be restarted before CrossFire changes take effect.
    root@debian64:~#
    Then rebooted my machine and if I check the status of the CrossFire chain, it is disabled:

    Code:
    root@debian64:~# aticonfig -v --list-crossfire-status
        Candidate Combination: 
        Master: 0:0:0 
        Slave: 0:0:0 
        CrossFire is disabled on current device
        CrossFire Diagnostics:
        CrossFire can work with P2P mapping through GART
    
    root@debian64:~#
    Well I should be easily able to turn this on using following command:

    Code:
    root@debian64:~# aticonfig --adapter=0,1 --crossfire=on
    Warning: No CrossFire chain defined for master adapter 1
    CrossFire chain(s) enabled
    CrossFire does not support on this platform
    Warning: X needs to be restarted before CrossFire changes take effect.
    root@debian64:~#
    I quite don't understand the error complaining about no CrossFire chain defined for adapter 1- this was done with the "aticonfig -v --adapter=0,1 --add-crossfire-chain" command, wasn't it? I reloaded the machine once again and checked back for CrossFire status, but it's still disabled:

    Code:
    root@debian64:~# aticonfig -v --list-crossfire-status
        Candidate Combination: 
        Master: 0:0:0 
        Slave: 0:0:0 
        CrossFire is disabled on current device
        CrossFire Diagnostics:
        CrossFire can work with P2P mapping through GART
    
    root@debian64:~#
    Any suggestions/ideas what might be wrong? If there is any additional information needed feel free to ask

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •