Page 4 of 4 FirstFirst ... 234
Results 31 to 34 of 34

Thread: Intel Can't Ship Their Own Driver With Their MeeGo OS

  1. #31
    Join Date
    Jun 2009
    Location
    Paris
    Posts
    432

    Default

    Quote Originally Posted by vgrade View Post
    I've been paying with the new EMGD driver on my Joggler there may be some hope for all the GMA500 users !

    http://www.youtube.com/watch?v=vnwfVtHuhoI
    EMGD now uses the whole OpenGL stack from PowerVR. The drivers also contain OpenGL ES 2.x & OpenVG support. X.org 1.8 and DRI2 are supported and this can also work with Maverick's 2.6.35 kernel. The driver is in GOLD state, so public builds should happen in less than one month, IMHO.

  2. #32
    Join Date
    Oct 2009
    Posts
    2,109

    Default

    Quote Originally Posted by gbeauche View Post
    EMGD now uses the whole OpenGL stack from PowerVR. The drivers also contain OpenGL ES 2.x & OpenVG support. X.org 1.8 and DRI2 are supported and this can also work with Maverick's 2.6.35 kernel. The driver is in GOLD state, so public builds should happen in less than one month, IMHO.
    And yet without at least a LITTLE bit of source for the xorg driver, it is almost completely worthless.

    At least the old PSB driver is working now with 1.8/2.6.34

  3. #33
    Join Date
    Jul 2010
    Posts
    6

    Default

    Get ready for another load of work.

    Xorg will be at 1.9 in a couple of weeks and 2.6.35 has changed interfaces again in this area

  4. #34
    Join Date
    Oct 2009
    Posts
    2,109

    Default

    Quote Originally Posted by vgrade View Post
    Get ready for another load of work.

    Xorg will be at 1.9 in a couple of weeks and 2.6.35 has changed interfaces again in this area
    The point is that with psb, this is POSSIBLE since we have enough of the source to be able to update it.

    Not that it particularly matters though. The problem is that the newest distros that supported xserver 1.6 did NOT support the majority of the hardware available on psb devices -- this level of support arrived at the same time as xserver 1.7, so there isn't/won't_be any particularly pressing need to upgrade a psb device to 1.9/2.6.35.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •