Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: ATI dropped the ball again

  1. #1
    Join Date
    Sep 2007
    Posts
    976

    Default ATI dropped the ball again

    I installed Lubuntu on my laptop that has an ATI RV250 card. But, there's video driver issues. I now understand that I need to disable KMS. I don't know how to do this so now I need to research/google. Thanks.

    Once again, the problem is related to OSS drivers and some version of *Ubuntu. Yeah, so great that the ATI OSS and Ubuntu (oh, it's just fglrx that they care about working?) is on top of things.

  2. #2
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,762

    Default

    Well, Ubuntu claims to "just work", so they should have disabled KMS by default on chips that don't work with it. I guess that means you should report it to the Ubuntu bug tracker.

    But since you're using a laptop, I'd say your best bet is fglrx for increased battery life; the OSS drivers lack good power management.

    As for the actual question, KMS is disabled by passing the "modeset=0" option to the radeon kernel module. I've built my own kernel with the radeon driver built-in and have it disabled by default, but I guess you're using the distro kernel. In that case, try looking in /etc/modprobe.d/ for a file called "options". In that file, add this:

    options radeon modeset=0

    and either just reboot or shutdown X and try:

    sudo modprobe -d radeon
    sudo modprobe radeon

    and then start X again.

  3. #3
    Join Date
    Aug 2007
    Posts
    6,598

    Default

    Well when you add a file to /etc/modprobe.d (you don't need to change an existing file!) you need a .conf ending for it and run

    update-initramfs -u

    later. as kernel command line it is also possible to add

    radeon.modeset=0

  4. #4
    Join Date
    Sep 2007
    Location
    Connecticut,USA
    Posts
    941

    Default

    You'd also need to add nomodeset on the grub kernel commandline. That will really suppress KMS at boot

  5. #5
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,762

    Default

    I thought using grub for that is only for when the driver is compiled-in into the kernel.

  6. #6
    Join Date
    Aug 2007
    Posts
    6,598

    Default

    @DeepDayze

    With the kernel i tested that option does nothing. For nouveau the option is similar:

    nouveau.modeset=0

    nomodeset does not help at all.

    @RealNC

    Test it, it works like that.

  7. #7
    Join Date
    Dec 2008
    Location
    Creve Coeur, Missouri
    Posts
    394

    Default

    ATI dropped the ball? It sounds like Ubuntu's problem, not ATI's.

  8. #8
    Join Date
    Dec 2007
    Location
    Merida
    Posts
    1,098

    Default

    ATI is guilty of everything.

  9. #9
    Join Date
    Dec 2008
    Location
    Creve Coeur, Missouri
    Posts
    394

    Default

    Quote Originally Posted by Melcar View Post
    ATI is guilty of everything.
    Darn right!
    Here is a list of things they are guilty of:
    • Making blazing fast GPUs
    • Using less power than the comparable Nvidia card
    • Providing driver updates every month
    • Creating sub-egg-cooking temperatures
    • Beating everyone to the OGL 4/DX 11 market by a mile
    • Being able to drive more than 2 monitors with a single video card
    • General amazingness

  10. #10
    Join Date
    Dec 2008
    Location
    Creve Coeur, Missouri
    Posts
    394

    Default

    Oh, I forgot their open source efforts. Too bad Nvidia doesn't have ANY. It is just sooooo uncool to release video card programming specifications, don't you think so?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •