Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Need some X help - 2 cards, 4 screens

  1. #11
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,574

    Default

    My understanding was that Xinerama only affected acceleration with the open drivers, but AFAIK even that is no longer the case with the latest open stack. That is only vague recollection though, don't take it as fact.

  2. #12
    Join Date
    Nov 2008
    Posts
    784

    Default

    not sure if it's related, but there are problems with multiple cards and vga_arbiter which lead to segfaults inside X. Did you disable the arbiter?

  3. #13
    Join Date
    Aug 2010
    Posts
    3

    Default

    I finally got all 4 screens to light up, but couldn't convince the two monitors on the second card not to be clones. Where is the 'clone'/multiple desktop setting kept?


    Also, there is a known issue with xinerama in xorg below 1.8.1 which causes it to lock up when the mouse pointer traverses screen boundaries in certain circumstances. I tried to update to xorg 1.8.99.905 (aka 1.9.0 RC5), but fglrx fails to load due to undefined symbol 'savedScreenInfo'. Any news on that?

  4. #14
    Join Date
    Jul 2010
    Location
    Gothenburg
    Posts
    60

    Default

    Quote Originally Posted by vickthom View Post
    I tried to update to xorg 1.8.99.905 (aka 1.9.0 RC5), but fglrx fails to load due to undefined symbol 'savedScreenInfo'. Any news on that?
    The xorg 1.9 uses ABI 8 (I think) and that breaks current fglrx. Ubuntu switched from 1.8 to 1.8.99.905 in maverick alpha 3. Oh joy!

    Catalyst usually follow Ubuntu release cycles, so it will probably support xorg 1.9 in cat 10.10.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •