Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Debian Squeeze machine slower with KMS

  1. #1
    Join Date
    Jul 2010
    Posts
    5

    Default Debian Squeeze machine slower with KMS

    My machine is substantially slower with KMS than with the old UMS. 3D games are simply not playable. Video stalls while audio keeps going. Opening terminal windows is slower. Without KMS, everything works smoothly. Any idea where to start troubleshooting this?

    Details:
    Debian Squeeze
    Ati X1550
    Sempron CPU 2800
    ASUS K8V-MX mobo

    Code:
    ~$ dmesg | grep drm
    [    5.542584] [drm] Initialized drm 1.1.0 20060810
    [    5.682532] [drm] radeon kernel modesetting enabled.
    [    5.687694] [drm] radeon: Initializing kernel modesetting.
    [    5.687770] [drm] register mmio base: 0xFBE00000
    [    5.687772] [drm] register mmio size: 65536
    [    5.693032] [drm] GPU reset succeed (RBBM_STATUS=0x10000140)
    [    5.693058] [drm] Generation 2 PCI interface, using max accessible memory
    [    5.693168] [drm] radeon: VRAM 256M
    [    5.693170] [drm] radeon: VRAM from 0x00000000 to 0x0FFFFFFF
    [    5.693173] [drm] radeon: GTT 64M
    [    5.693175] [drm] radeon: GTT from 0xDC000000 to 0xDFFFFFFF
    [    5.693245] [drm] radeon: using MSI.
    [    5.693276] [drm] radeon: irq initialized.
    [    5.693361] [drm] Detected VRAM RAM=256M, BAR=256M
    [    5.693365] [drm] RAM width 128bits DDR
    [    5.693472] [drm] radeon: 256M of VRAM memory ready
    [    5.693475] [drm] radeon: 64M of GTT memory ready.
    [    5.693503] [drm] GART: num cpu pages 16384, num gpu pages 16384
    [    5.696036] [drm] RB2D reset succeed (RBBM_STATUS=0x10000140)
    [    5.696056] [drm] radeon: 1 quad pipes, 1 z pipes initialized.
    [    5.696084] [drm] radeon: cp idle (0x10000C03)
    [    5.696141] [drm] Loading R500 Microcode
    [    5.933550] [drm] radeon: ring at 0x00000000DC000000
    [    5.933584] [drm] ring test succeeded in 6 usecs
    [    5.935651] [drm] radeon: ib pool ready.
    [    7.932018] [drm] ib test succeeded in 0 usecs
    [    7.932177] [drm] Default TV standard: PAL
    [    7.932263] [drm] Radeon Display Connectors
    [    7.932266] [drm] Connector 0:
    [    7.932268] [drm]   VGA
    [    7.932271] [drm]   DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c
    [    7.932273] [drm]   Encoders:
    [    7.932275] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
    [    7.932278] [drm] Connector 1:
    [    7.932279] [drm]   S-video
    [    7.932281] [drm]   Encoders:
    [    7.932283] [drm]     TV1: INTERNAL_KLDSCP_DAC2
    [    7.932285] [drm] Connector 2:
    [    7.932287] [drm]   DVI-I
    [    7.932289] [drm]   HPD2
    [    7.932292] [drm]   DDC: 0x7e50 0x7e50 0x7e54 0x7e54 0x7e58 0x7e58 0x7e5c 0x7e5c
    [    7.932294] [drm]   Encoders:
    [    7.932296] [drm]     CRT2: INTERNAL_KLDSCP_DAC2
    [    7.932298] [drm]     DFP3: INTERNAL_LVTM1
    [    8.127672] [drm] fb mappable at 0xE0050000
    [    8.127675] [drm] vram apper at 0xE0000000
    [    8.127677] [drm] size 3145728
    [    8.127679] [drm] fb depth is 24
    [    8.127681] [drm]    pitch is 4096
    [    8.244201] fb0: radeondrmfb frame buffer device
    [    8.244211] [drm] Initialized radeon 2.0.0 20080528 for 0000:01:00.0 on minor 0

  2. #2
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    i think you need mesa 7.9 (not released) and r300g

    i think debian do not have not released software ;-)

    only "xorg crack pushers" can help you .-..

    "Packages for those who think development versions, experimental and unstable are for old ladies. We want our crack straight from upstream git! Well, straight, we want it built and packaged so we don't need to know what we're doing, except that we will break our X and put our computers on fire."

    https://launchpad.net/~xorg-edgers

    get your lastest openGL2.1 mesa7.9 R300g shit now ;-)

  3. #3
    Join Date
    Jul 2010
    Posts
    5

    Default

    Is that what it is? Mesa isn't ready yet? I was wondering if it was a kernel problem. I have 2.6.32-5.

  4. #4
    Join Date
    Oct 2007
    Posts
    1,290

    Default

    If everything works with UMS, just use UMS for now. Power saving isn't as good as with KMS + latest kernel, but since you're not using a laptop, this shouldn't matter (as long as your card has decent cooling).

  5. #5
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by Bulkley View Post
    Is that what it is? Mesa isn't ready yet? I was wondering if it was a kernel problem. I have 2.6.32-5.
    in my point of view you need kernel 2.6.35+mesa7.9 for the full potential of your hardware.

    means KMS+OpenGL2.1

  6. #6
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,196

    Default

    Oh an AGP card. It seems to be expected that KMS ain't exactly good on it currently.

  7. #7
    Join Date
    Jul 2010
    Posts
    5

    Default

    Quote Originally Posted by curaga View Post
    Oh an AGP card. It seems to be expected that KMS ain't exactly good on it currently.
    Yes, but adding radeon.agpmode=-1 to /etc/modprobe.d/radeon-kms.conf makes things run even slower.

    I know that glxgears is a poor benchmark but UMS it reports over 2500 fps but with KMS less than 250 fps. That's only 10%. A better benchmark is PPRacer which runs well with UMS but with KMS I cannot get past the opening screen, the falling snow doesn't fall and the curser/pointer lags the mouse movement by more than five seconds. KMS definitely does not use my video card properly.

    Thanks for your replies. I guess I have to decide whether to just use UMS, wait for better software to work its way down the Debian pipe or to git the experimental software.

    Thanks for the replies.

    As an afterthought, is it possible that older configurations could be interfering with performance? This system has been upgraded for several years and out-dated configs might be lurking.

  8. #8
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,516

    Default

    AFAIK when you run with KMS you get mostly tear-free 3D rendering which prevents insanely high frame rates. Shouldn't have much impact on real world apps, just things like glxgears which would otherwise generate frames 10-100x as quickly as the display can show them.

  9. #9
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,196

    Default

    Quote Originally Posted by Bulkley View Post
    Yes, but adding radeon.agpmode=-1 to /etc/modprobe.d/radeon-kms.conf makes things run even slower.
    Isn't that param supposed to work like that? PCI mode on an AGP card being slower than any of the AGP modes (1x, 2x, 4x, 8x).

  10. #10
    Join Date
    Jul 2010
    Posts
    5

    Default

    Quote Originally Posted by Qaridarium View Post
    in my point of view you need kernel 2.6.35+mesa7.9 for the full potential of your hardware.
    Okay, I installed the 2.6.35 liquorix kernel. Now, where can I find mesa 7.9?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •