Page 14 of 20 FirstFirst ... 41213141516 ... LastLast
Results 131 to 140 of 200

Thread: ATI R600g Gains Mip-Map, Face Culling Support

  1. #131
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,578

    Default

    Actually it looks a bit odd with Software Rasterizer as well. Could someone check whether or not geartrain polygons are valid? (edges not allowed to intersect, region must be convex) If some are invalid, it would explain strange rendering. I'm not experienced enough to just see validity by scanning through the code.

  2. #132
    Join Date
    Jan 2009
    Posts
    621

    Default

    Quote Originally Posted by netkas View Post
    Well, found a bug, hope Glisse reads this thread sometimes
    This is most probably not a driver bug. swrast, llvmpipe, softpipe, r300c, and r300g render it the same as is on your screenshot.

  3. #133
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,578

    Default

    Quote Originally Posted by marek View Post
    This is most probably not a driver bug. swrast, llvmpipe, softpipe, r300c, and r300g render it the same as is on your screenshot.
    My eyes claimed swrast rendering differed a bit but was still incorrect. Hence why I started wondering about invalid polygons since rendering is undefined there and might even be unexpected in a different way in all drivers.

  4. #134
    Join Date
    Jan 2009
    Posts
    621

    Default

    Yeah, we are damned lucky that the hardware doesn't lock up (that's what usually "undefined" means).

  5. #135
    Join Date
    Aug 2009
    Posts
    122

    Default

    somebody need to check it on nvidia linux drivers.

  6. #136
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,578

    Default

    Quote Originally Posted by netkas View Post
    somebody need to check it on nvidia linux drivers.
    This would prove nothing. Someone (more competent in OpenGL than I) needs to read geartrain.c and check the vertices.

  7. #137
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,578

    Default

    (and otherwise too, vertices were just my first guess)
    ps. I hate the one-minute edit window.

  8. #138
    Join Date
    Aug 2009
    Posts
    122

    Default

    btw, latest mesa borked q3

  9. #139
    Join Date
    Nov 2008
    Posts
    766

    Default

    geartrain with nvidia (mobile, Quadro NVS 145M, basically a 8xxxM):


    I demand that this bug gets fixed in r300g!

  10. #140
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,578

    Default

    Quote Originally Posted by rohcQaH View Post
    I demand that this bug gets fixed in r300g!
    *cough* There's a bug in that screenshot too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •