Results 1 to 10 of 10

Thread: r600_cp: Failed to load firmware "radeon/REDWOOD_pfp.bin"

  1. #1
    Join Date
    Aug 2010
    Location
    Italy
    Posts
    12

    Default r600_cp: Failed to load firmware "radeon/REDWOOD_pfp.bin"

    hello,

    i've just bought a radeon hd5670 and i'm trying to get it up running as best as possible.
    I'm currently running kernel 2.6.35, xorg 1.7.7 and xserver-xorg-video-radeon 6.13.1

    KMS works fine but i get this error message:
    r600_cp: Failed to load firmware "radeon/REDWOOD_pfp.bin"

    the file exists, of course:
    -rw-r--r-- 1 root root 4480 Jul 6 01:37 REDWOOD_pfp.bin

    any idea on how to solve it?

    p.s. on a different note: is it possible to have the fan slow down? i've set dynpm=1 but the fan is still going at fullf speed.

  2. #2
    Join Date
    Aug 2007
    Posts
    6,631

    Default

    When you copied that file later to that position do:

    update-initramfs -u

  3. #3
    Join Date
    Jun 2009
    Posts
    2,929

    Default

    Which distribution?

    Did you compile the kernel yourself?

    Is "radeon" a module or compiled into the kernel?

    Where is the file REDWOOD_pfp.bin located?

  4. #4
    Join Date
    Aug 2010
    Location
    Italy
    Posts
    12

    Default

    Quote Originally Posted by pingufunkybeat View Post
    Which distribution?

    Did you compile the kernel yourself?

    Is "radeon" a module or compiled into the kernel?

    Where is the file REDWOOD_pfp.bin located?
    thanks to both of you for the quick replies.

    I'm using debian unstable with a vanilla kernel. the radeon driver is compiled statically so i don't use initramfs.
    The file is located in /lib/firmware/radeon/

    I also have to add that before installing this card i was using the integrated HD3200 from my motherboard with the same exact configuration (except that it was loding the R600 firmware, of course) and it didn't give me any problem.

  5. #5
    Join Date
    Jun 2009
    Posts
    2,929

    Default

    If your kernel is compiled statically, it will try to load the firmware before it mounts /lib/firmware. This cannot work.

    You need to compile firmware into the kernel itself. I'm not at home right now to dig out the exact kernel options, but there is an option to specify external firmware (and the directory) to be compiled directly into the kernel.

    I had the same problem some time ago, but with rlc_bin, not pfp_bin. Compiling it into the kernel solved it.

  6. #6
    Join Date
    Aug 2010
    Location
    Italy
    Posts
    12

    Default

    actually the firmware put in /lib/firmware is compiled inside the kernel, with the option you are referring to.
    As i said, this exact configuration was working with no errors with the hd3200 i used before.

  7. #7
    Join Date
    Mar 2008
    Posts
    20

  8. #8
    Join Date
    Aug 2010
    Location
    Italy
    Posts
    12

    Default

    Quote Originally Posted by dm0rais View Post
    nope. as i already wrote i was using r600 and it worked fine, doing the exact same steps listed in the link you posted, i'm having the problem with redwood only for the REDWOOD_pfp.bin file and KMS already works

  9. #9
    Join Date
    May 2007
    Posts
    352

    Default

    Just to be sure, please grep for CONFIG_EXTRA_FIRMWARE on your kernel config file.

    Adam

  10. #10
    Join Date
    Jul 2008
    Location
    Berlin, Germany
    Posts
    822

    Default

    If you compile a kernel yourself with radeon drm built-in, you need to set CONFIG_EXTRA_FIRMWARE as described in the wiki:
    http://wiki.x.org/wiki/radeonBuildHo...BAC8-Evergreen

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •