Results 1 to 5 of 5

Thread: catalyst 10.7 bugs collection

  1. #1
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    642

    Default catalyst 10.7 bugs collection

    Hi guys,

    I just stumbled over a little bug with 10.7: when trying to run xrestop the X-server just restarts - dmesg showing the following:

    [16454.490200] BUG: scheduling while atomic: X/6680/0x00000002
    [16454.490201] Modules linked in: ums_cypress it87 hwmon_vid hwmon xt_owner xt_iprange fglrx(P) e1000e i2c_i801 wmi libphy e1000 scsi_wait_scan sl811_hcd ohci_hcd ssb usb_storage ehci_hcd [last unloaded: ramzswap]
    [16454.490210] Pid: 6680, comm: X Tainted: P C 2.6.35-zen0_desktop_new+ #3
    [16454.490212] Call Trace:
    [16454.490219] [<ffffffff8174272e>] ? schedule+0x53e/0x760
    [16454.490236] [<ffffffffa0108c51>] ? KAS_Thread_WaitForFinish+0x91/0xd0 [fglrx]
    [16454.490239] [<ffffffff8105f1c0>] ? autoremove_wake_function+0x0/0x30
    [16454.490253] [<ffffffffa011f0f7>] ? MCIL_WorkerThread+0x177/0x230 [fglrx]
    [16454.490266] [<ffffffffa0120796>] ? MCIL_GetExecutionLevel+0x66/0x80 [fglrx]
    [16454.490284] [<ffffffffa01c8511>] ? PassiveRing_Cleanup+0x61/0xc0 [fglrx]
    [16454.490287] [<ffffffff8108284b>] ? __free_irq+0x11b/0x1f0
    [16454.490305] [<ffffffffa01c7b60>] ? IRQMGR_FreeResources+0x20/0x60 [fglrx]
    [16454.490321] [<ffffffffa012194c>] ? irqmgr_wrap_shutdown+0x12c/0x180 [fglrx]
    [16454.490333] [<ffffffffa0113c3e>] ? firegl_ioctl+0xe4e/0xef0 [fglrx]
    [16454.490347] [<ffffffffa01da1a2>] ? amdPcsEngine_InitDatabase+0x12/0x20 [fglrx]
    [16454.490358] [<ffffffffa0112d55>] ? firegl_release+0x125/0x1c0 [fglrx]
    [16454.490361] [<ffffffff810d24c6>] ? fput+0x116/0x240
    [16454.490363] [<ffffffff810cf0f9>] ? filp_close+0x59/0x80
    [16454.490366] [<ffffffff8104a2dd>] ? put_files_struct+0xbd/0x140
    [16454.490367] [<ffffffff8104aa5d>] ? do_exit+0x60d/0x7a0
    [16454.490369] [<ffffffff8104ae83>] ? do_group_exit+0x53/0xc0
    [16454.490371] [<ffffffff81056733>] ? get_signal_to_deliver+0x2a3/0x410
    [16454.490374] [<ffffffff810019ca>] ? do_signal+0x8a/0x800
    [16454.490375] [<ffffffff81055adc>] ? do_send_sig_info+0x6c/0x90
    [16454.490378] [<ffffffff810e36dd>] ? dput+0x10d/0x170
    [16454.490379] [<ffffffff810547d2>] ? recalc_sigpending+0x12/0x50
    [16454.490381] [<ffffffff81054894>] ? sigprocmask+0x84/0x100
    [16454.490383] [<ffffffff81056aa3>] ? sys_rt_sigprocmask+0x83/0x120
    [16454.490384] [<ffffffff810e36dd>] ? dput+0x10d/0x170
    [16454.490386] [<ffffffff810547d2>] ? recalc_sigpending+0x12/0x50
    [16454.490387] [<ffffffff810021a9>] ? do_notify_resume+0x49/0x50
    [16454.490389] [<ffffffff8100290b>] ? int_signal+0x12/0x17
    I thought - while I'm on it, why don't you also post your bugs/issues with 10.7 in here for a more clear view for the devs ?

    if they check these forums - that is

    thanks for your cooperation !

  2. #2
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,544

    Default

    Why not just put them in the bug tracker at http://ati.cchtml.com ? That's where the devs look now.

  3. #3
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    642

    Default

    Quote Originally Posted by bridgman View Post
    Why not just put them in the bug tracker at http://ati.cchtml.com ? That's where the devs look now.
    so it's already the kind of official bugtracker for the catalyst driver ?

    nice !

  4. #4
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,544

    Default

    Well, officially it's the unofficial bug tracker, but unofficially...

  5. #5
    Join Date
    Oct 2007
    Posts
    321

    Default

    While that bug tracker is Unofficial, enough AMD devs haunt this tracker that it turns into a half way decent to report critical bugs (Like system lockups).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •