Results 1 to 4 of 4

Thread: How to add new resolution?

  1. #1
    Join Date
    Nov 2010
    Posts
    2

    Default How to add new resolution?

    Iīm using Ubuntu 10.10 32 bits with ATI Mobility Radeon HD 4500 Series on a Dell Studio 1558, and my problem is i canīt set a properly resolution.

    I can set it to 1920x1080, wich in most cases is to high that makes everything so little, and the next properly resolution (same proportions) is 1280x720, wich i find too big sometines, so iīm triying to set an intermediate resolution, in this case 1600x900 wich keeps the proportions of the screen, because the rest of the resolutions doesnīt keep the proportions.

    Iīm using propietary (fglrx) driver, and here is what i have tried:

    - Adding a "Modes 1600x900" section in xorg.conf file, wich looks like this:

    Section "ServerLayout"
    Identifier "amdcccle Layout"
    Screen 0 "amdcccle-Screen[2]-0" 0 0
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "ServerFlags"
    Option "Xinerama" "off"
    EndSection

    Section "Monitor"
    Identifier "0-LVDS"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    Option "PreferredMode" "1920x1080"
    Option "TargetRefresh" "60"
    Option "Position" "0 0"
    Option "Rotate" "normal"
    Option "Disable" "false"
    EndSection

    Section "Monitor"
    Identifier "0-DFP1"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    Option "PreferredMode" "1920x1080"
    Option "TargetRefresh" "60"
    Option "Position" "0 0"
    Option "Rotate" "normal"
    Option "Disable" "false"
    EndSection

    Section "Device"
    Identifier "Default Device"
    Driver "fglrx"
    EndSection

    Section "Device"
    Identifier "amdcccle-Device[2]-0"
    Driver "fglrx"
    Option "Monitor-LVDS" "0-LVDS"
    BusID "PCI:2:0:0"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    DefaultDepth 24
    EndSection

    Section "Screen"
    Identifier "amdcccle-Screen[2]-0"
    Device "amdcccle-Device[2]-0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1600x900"
    EndSubSection
    EndSection
    That makes nothing, because i canīt see the 1600x900 anywhere to try it.

    - I have tried with xrandr, following this tutorial, where i make this:

    plaos@plaos-laptop:~$ xrandr
    Screen 0: minimum 320 x 200, current 1280 x 720, maximum 1920 x 1920
    LVDS connected 1280x720+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
    1920x1080 59.9 +
    1680x1050 59.9 +
    1400x1050 59.9 +
    1280x1024 59.9 +
    1440x900 59.9 +
    1280x960 59.9 +
    1280x800 59.9 +
    1152x864 59.9 +
    1280x768 59.9 +
    1280x720 59.9*+
    1024x768 59.9 +
    1024x600 59.9 +
    800x600 59.9 +
    800x480 59.9 +
    720x480 59.9 +
    640x480 59.9 +
    DFP1 disconnected (normal left inverted right x axis y axis)
    CRT2 disconnected (normal left inverted right x axis y axis)
    plaos@plaos-laptop:~$ cvt 1600 900
    # 1600x900 59.95 Hz (CVT 1.44M9) hsync: 55.99 kHz; pclk: 118.25 MHz
    Modeline "1600x900_60.00" 118.25 1600 1696 1856 2112 900 903 908 934 -hsync +vsync
    plaos@plaos-laptop:~$ xrandr --newmode "1600x900_60.00" 118.25 1600 1696 1856 2112 900 903 908 934 -hsync +vsync
    After this, when i exec xrandr again i get this after CRT2 discon...

    CRT2 disconnected (normal left inverted right x axis y axis)
    1600x900_60.00 (0xe2) 118.2MHz
    h: width 1600 start 1696 end 1856 total 2112 skew 0 clock 56.0KHz
    v: height 900 start 903 end 908 total 934 clock 59.9Hz
    And if i try to add the resolution, i get this error:

    plaos@plaos-laptop:~$ xrandr --addmode LVDS 1600x900_60.00
    X Error of failed request: BadMatch (invalid parameter attributes)
    Major opcode of failed request: 155 (RANDR)
    Minor opcode of failed request: 18 (RRAddOutputMode)
    Serial number of failed request: 27
    Current serial number in output stream: 28
    - I finally tried using aticonfig, where manual section says:

    --resolution=Screen#,W1xH1,W2xH2,W3xH3,...
    Set the modes for the specified screen. You may specify several
    resolutions separated by commas.
    Screens start at 0. You can use 1 for dual-head
    So when i try this, i get the next:

    plaos@plaos-laptop:~$ sudo aticonfig --resolution=0, 1600x900
    [sudo] password for plaos:
    error at set screen resolution : screen0 does not exist
    aticonfig: parsing the command-line failed.
    I am desperated, which metod i should follow, and where i am doing something wrong?

  2. #2
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    No! Do not set the res, change the dpi! I do not use ubuntu, but most likely you will find the gdm.conf to be the file to increase dpi.

  3. #3
    Join Date
    Nov 2010
    Posts
    2

    Default

    Quote Originally Posted by Kano View Post
    No! Do not set the res, change the dpi! I do not use ubuntu, but most likely you will find the gdm.conf to be the file to increase dpi.
    Thanks! I canīt find the way to change it on gdm.conf, but you opened me a new way to investigate, i knew about increasing dpi of the font, but not of de xorg, XD.

    ŋWhere to change it on xorg?

  4. #4
    Join Date
    Oct 2009
    Posts
    2,064

    Default

    I do not use ubuntu, but on Fedora/Gnome, the option is in System --> Preference --> Appearance --> Fonts --> Details. Under fonts, you can also change the font sizes.

    You generally should stick with your display's native resolution. The reason is that outside of the native resolution, things won't line up properly to pixel boundaries, so you'll end up with blurry lines and other general ugliness.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •