Results 1 to 3 of 3

Thread: Help: Mobility 5870 and 2.6.35-r1 Config Question

  1. #1
    Join Date
    Apr 2010
    Posts
    13

    Default Help: Mobility 5870 and 2.6.35-r1 Config Question

    I've been waiting for the 2.6.35 kernel, to try out the in-kernel Radeon driver for my Asus G73Jh, (Mobility Radeon HD 5870), after getting it to work successfully with my Asus N81Vp, (Radeon Mobility HD 4670), some time ago. My problem is that while I can configure and install the 2.6.35-r1 kernel and driver for my Mobility 5870 laptop, and the framebuffer console, X, and finally KDE, boot fine, I can't get the KDE Desktop Effects -> Compositing to work. My question is if that is the state of the driver so far, or could I be configuring something incorrectly? My system config includes;

    Gentoo (~amd64 arch) Xorg-server 1.8.2/KDE 4.4.5 with;
    • x11-libs/libdrm-2.4.21
    • sys-kernel/gentoo-sources-2.6.35-r1
    • media-libs/mesa-7.8.2
    • x11-base/xorg-server-1.8.2

    In case it's needed, here are the relevant Radeon related parts of my;

    kernel config
    dmesg
    lsmod
    Xorg.0.log

    If the answer is that it's simply the current state of the driver, given the above configuration, but I can experiment with overlay versions that may provide the necessary support, please feel free to point me in that direction. Lastly, for those of you that are familiar with Gentoo, I'm just using the /etc/make.conf VIDEO_CARDS="radeon" configuration for the in kernel driver, based on some Gentoo Forum posts that recommended not using the "radeonhd" configuration. If that's incorrect, please feel free to point out the correct one.

    Thanks..

  2. #2
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,411

    Default

    Right now the 2.6.35 kernel has modesetting and the kernel portion of the acceleration code, but the userspace portion of acceleration code is still WIP. That's probably why you can't get compositing working.

    The userspace code is getting pretty close though...

  3. #3
    Join Date
    Apr 2010
    Posts
    13

    Default

    Ok. I appreciate the response. I'll just stay tuned to these forums for news when everything is ready and revisit the configuration then.

    Thanks again..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •