Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: Intel's GLSL2 Branch Is Merged To Mesa Master

  1. #21
    Join Date
    Jan 2008
    Posts
    157

    Default

    Thanks for the reply. I tried that but though it allows me to pass the configure stage, it fails with undefined references at compile time.
    I set something like "TALLOC_CFLAGS='-I/usr/include -l/usr/lib64' TALLOC_LIBS='/usr/lib64/libtalloc.so.2'" before the configure command. I guess I'm not doing this right but couldn't find a proper reference in Google and I'm not a compiler expert at all.

  2. #22
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,806

    Default

    No, I think that's not quite it. Try using it like TALLOC_CFLAGS="-I/usr/include" TALLOC_LIBS="-L/usr/lib64 -ltalloc" or something along the lines.

  3. #23
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,806

    Default

    Note that another option is creating /usr/lib64/pkgconfig/talloc.pl with contents
    Code:
    prefix=/usr
    exec_prefix=/usr
    libdir=/usr/lib64
    includedir=/usr/include
    
    Name: talloc 
    Description: A hierarchical pool based memory system with destructors
    Version: 2.0.1
    Libs: -L${libdir} -ltalloc
    Cflags: -I${includedir} 
    URL: http://talloc.samba.org/
    But that requires maintenance, in theory anyway. Your distro should really just setup a working pkg-config setup.

  4. #24
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,806

    Default

    Code above is from Fedora package. Curse the edit window.

  5. #25
    Join Date
    Jan 2008
    Posts
    157

    Default

    Thanks, the talloc.pc file worked, though not the trick of passing the ENV variables to configure.
    I'll forward that to the Slack team. They do not give a .pc file yet because talloc is distributed within Samba and obviously used there only. I guess they'll have to adjust.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •