Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: Mesa git testing experiences

  1. #21
    Join Date
    Jan 2009
    Posts
    614

    Default

    The git history is a graph, actually a pretty complex graph as everybody makes branches and merges them again. Bisecting that by hand would be crazy and that's why there is git bisect. Just believe that it does the right thing.

  2. #22
    Join Date
    Oct 2008
    Posts
    68

    Default

    So after 3 upgrades of mesa stack, Heroes of Newerth still arent working and no mesa developers are answering bugreports. May someone more experienced can try those git revisions on r600 with heroes of newerth to figure out which one is "bad"?
    f668ea11
    ff26594a
    ecec6df9
    d442a01a
    after upgrade to some of those revisions HoN just stopped working for me. Thanks for help anyone.

  3. #23
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    1. You only filed the bug a couple of days ago, have patience.

    2. There doesn't seem to be a demo of the game available, meaning it's harder to reproduce if you don't already own the game.

    3. Try to add as much information as possible directly, in general, too much information is better than to little. (Add the screenshot you mentioned in the bug report for example)

    4. If it worked before, try bisecting. See if any shaders fail to compile. See if you can figure out which shader(s) is used for the models if that is the problem. (Perhaps one of the HoN developers can clue you in).

    Etc...

  4. #24
    Join Date
    Oct 2008
    Posts
    68

    Default

    Quote Originally Posted by whizse View Post
    1. You only filed the bug a couple of days ago, have patience.

    2. There doesn't seem to be a demo of the game available, meaning it's harder to reproduce if you don't already own the game.

    3. Try to add as much information as possible directly, in general, too much information is better than to little. (Add the screenshot you mentioned in the bug report for example)

    4. If it worked before, try bisecting. See if any shaders fail to compile. See if you can figure out which shader(s) is used for the models if that is the problem. (Perhaps one of the HoN developers can clue you in).

    Etc...
    Im not really into compiling. Anyway - you can download HoN client for free. In menu there are models displayed and moving even without loging in. So all i need is a tester so we could find out a revision which broke it.

  5. #25
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    Great! (This is the kind of stuff a bug report should mention!)

  6. #26
    Join Date
    Oct 2008
    Posts
    68

    Default

    Heroes of Newerth works again.

  7. #27
    Join Date
    Nov 2006
    Posts
    74

    Default

    Works but the performance drop is still there. I guess that's a different issue.

  8. #28
    Join Date
    Oct 2008
    Posts
    68

    Default

    Quote Originally Posted by rob2687 View Post
    Works but the performance drop is still there. I guess that's a different issue.
    I didnt noticed any performance drops on R600.. To be honest, i think its a bit faster than before...

  9. #29
    Join Date
    Nov 2006
    Posts
    74

    Default

    On r500 it went from playable at low settings to slideshow.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •