Quote Originally Posted by Spasswolf View Post
My guess is you're missing CONFIG_COMPAT=y in your .config, which is selected automatically when enabling IA32_EMULATION (at least on an x86_64 system).

In 2.6.36-rc-4-git2 this will break again, because compat_alloc_user_space is renamed to arch_compat_alloc_user_space:
http://www.kernel.org/diff/diffview....-git2.bz2;z=15
I have it enabled:

Quote Originally Posted by cat /usr/src/linux/.config | grep COMPAT
# CONFIG_COMPAT_BRK is not set
CONFIG_BLOCK_COMPAT=y
# CONFIG_COMPAT_VDSO is not set
CONFIG_COMPAT_BINFMT_ELF=y
CONFIG_COMPAT=y
CONFIG_COMPAT_FOR_U64_ALIGNMENT=y
CONFIG_SYSVIPC_COMPAT=y
CONFIG_COMPAT_NETLINK_MESSAGES=y
CONFIG_NF_CONNTRACK_PROC_COMPAT=y
CONFIG_I2C_COMPAT=y
CONFIG_VIDEO_V4L1_COMPAT=y
CONFIG_QUOTACTL_COMPAT=y
so it's the latter

thanks !