Results 1 to 9 of 9

Thread: Kubuntu 10.04, Geforce 4, low resolution.

  1. #1
    Join Date
    Jul 2009
    Location
    Srbija bato
    Posts
    42

    Default Kubuntu 10.04, Geforce 4, low resolution.

    I have installed Kubuntu Lucid on my friend's old desktop with Geforce 4 graphic card. After installing nvidia driver it gives me only 640x480 resolution and lower. How to force nvidia driver to show 1024x768? Probably I need to edit xorg.conf and it will force nvidia driver to use 1024x768, but I don't know how to do it right.

    Please help.

  2. #2

    Default

    output of `xrandr` please?

  3. #3
    Join Date
    Jul 2009
    Location
    Srbija bato
    Posts
    42

    Default

    miljan@miljan-pc:~$ xrandr
    Screen 0: minimum 320 x 240, current 640 x 480, maximum 640 x 480
    default connected 640x480+0+0 0mm x 0mm
    640x480 50.0*
    320x240 51.0

  4. #4
    Join Date
    Aug 2007
    Posts
    6,633

    Default

    Most likely you did not install it correctly. Since lucid ubuntu is basically incompatible with nvidia/ati installers in pure mode. For ati there is a buildpkg option, but for nvidia you have to use prepackaged drivers from a 3rd party when you don't want to break the system and want latest drivers. Did you use jockey to install it?

  5. #5
    Join Date
    Jul 2009
    Location
    Srbija bato
    Posts
    42

    Default

    First thing I did after clean install is to install nvidia proprietary driver from hardrware drivers.

  6. #6
    Join Date
    Aug 2007
    Posts
    6,633

    Default

    Well maybe just keep nouveau, the card is outdated anyway and nouveau has even kms.

  7. #7
    Join Date
    Jul 2009
    Location
    Srbija bato
    Posts
    42

    Default

    Desktop effects are very important, thats why my friend whanted to try Kubuntu. Thats why I have to go with proprietary driver. They work very smooth but resolution is problem. I will try to edit xorg.conf somehow. I google a bit and found few "solutions"

  8. #8

    Default

    Quote Originally Posted by schnelle View Post
    Desktop effects are very important, thats why my friend whanted to try Kubuntu. Thats why I have to go with proprietary driver. They work very smooth but resolution is problem. I will try to edit xorg.conf somehow. I google a bit and found few "solutions"
    You might run the `nvidia-settings` program under sudo

  9. #9
    Join Date
    Jun 2010
    Posts
    219

    Default

    Make sure you have the correct driver for the card. NVIDIA produces a legacy driver for any card 5xxx and lower, and GeForce 4 may have been deprecated. Run the following and send us the output:

    cat /etc/X11/xorg.conf | grep -i "Driver"

    lsmod | grep -i nv

    cat /var/log/Xorg.0.log

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •