Page 6 of 6 FirstFirst ... 456
Results 51 to 57 of 57

Thread: Progress On The ATI R600g Gallium3D Driver

  1. #51
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,674

    Default

    Quote Originally Posted by HokTar View Post
    As a matter of fact it happened on both stock Maverick and Maverick + xorg-edgers, so it is anything but old. KMS has been working nicely for several months.
    That's strange then. Afaik r600c should have FBO's if KMS is working properly. You checked whether glxinfo is missing the extensions?

  2. #52
    Join Date
    Dec 2009
    Posts
    338

    Default

    Quote Originally Posted by nanonyme View Post
    That's strange then. Afaik r600c should have FBO's if KMS is working properly. You checked whether glxinfo is missing the extensions?
    No. I just installed gallium instead.
    Then I figured that vdrift was unplayable (mostly because of the smoke created by the tyres and also fps was pretty low) so I ended up removing the game too.

    BTW, what extensions should I have searched for? Anything with fbo in its name?

  3. #53
    Join Date
    Dec 2008
    Posts
    995

    Default

    Hmm, I can even play vdrift on my HD3200. Which is about the lowest end GPU supported by r600c/g. Performance is virtually the same there between r600c and r600g. It's not as smooth as on my evergreen but it's playable. But aside from the fps, yes vdrift is difficult to play and requires some skill to master and which car you choose matters a lot, because they all have different physics and behave differently.

  4. #54
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,674

    Default

    Here torcs also seems to be incapable of changing resolutions. Framerate is indeed horrible when driving in the midst of opponents. I recommend passing them and driving as first.

  5. #55
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,674

    Default

    ps. As in, game resolution changed, display resolution not. Have I already said how much I hate the short edit window?

  6. #56
    Join Date
    Dec 2009
    Posts
    338

    Default

    Well, I've been using r600g for a day now. Oh, actually I just reverted back to stock Maverick because I got random X crashes when using Gambit (commercial mesh generation software) through ssh -XC. Nothing showed up in the logs. It died nicely i.e. it logged me out without saying a word then I could log back in but obviously all my unsaved work was gone.

    I only found this in syslog:
    [ 6390.539688] radeon 0000:01:00.0: ffff8800c24e1c00 reserve failed for wait

  7. #57
    Join Date
    Apr 2010
    Posts
    5

    Default

    Quote Originally Posted by stev47 View Post
    Same problem here. Have you made any progress tracking down that bug?
    To those interested: I've tracked down the problem and posted a bug-report here:
    https://bugs.freedesktop.org/show_bug.cgi?id=31391

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •