Page 2 of 9 FirstFirst 1234 ... LastLast
Results 11 to 20 of 82

Thread: ATI Catalyst 10.8 For Linux Brings OpenGL ES 2.0

  1. #11
    Join Date
    Sep 2008
    Posts
    332

    Default

    the fullscreen redirecting bug is still present.
    fglrx 10.6 is the only release without this bug.

  2. #12
    Join Date
    Jul 2008
    Posts
    71

    Default

    Quote Originally Posted by bulletxt View Post
    A defualt Linux system without FGLRX = A real stable Linux system .

    A default Linux system with FGLRX = Windows ME .

    And I'm not joking.
    Perhaps, but I recently had very poor experience with open source ATI acceleration on Fedora 13, while having an excellent experience with FGLRX on Ubuntu 10.04. Fedora fixed their driver issues while ATI released FGLRX that would work with the newer Xorg for Fedora 13. I now have a stable desktop with both Fedora and Ubuntu whether I use the open source driver or FGLRX.

    I have also used FGLRX with RHEL5 to good effect, including playing ETQW on it.

    So while I understand that you might be serious, I cannot confirm one bit of your experience. Quite the opposite in fact.

  3. #13
    Join Date
    Aug 2007
    Posts
    6,673

    Default

    Well most likely you do NOT use KDE 4.

  4. #14
    Join Date
    Jun 2010
    Location
    ฿ 16LDJ6Hrd1oN3nCoFL7BypHSEYL84ca1JR
    Posts
    1,052

    Default

    The FUD starts again.

    A defualt Linux system without FGLRX = A real stable Linux system .
    A default Linux system with FGLRX = Windows ME .
    And I'm not joking.
    I assume you are as long as you don't give any examples of this "instability". Yes, catalyst has its error. But with my HD 4670 I had at least no stability issues.

    No point in having optimized 3D driver if the driver doesn't even run the game that will utilize it.
    "The game"? Which?
    (I lost it).

    Xorg 1.8 support?
    I don't know abput your catalyst but my catalyst 10.7 runs with xorg 1.8 since the first day.

    Especially when you want to use iceweasel (firefox) you often see black. Even other windows are often with a black boarder.
    At least that's a REAL problem. For me and many others not using the new 2d acceleration is a working workaround:
    Code:
    aticonfig --set-pcs-str=DDX,ForceXAA,TRUE
    Some people report it's not working but I think that they just didn't disable it. Happened to me too that I reinstalled catalyst with the config files while xorg running and then the setting was still there on reboot.

    When you have got a hd 5 card you will definitely not get oss 3d support with a current distro right now.
    In Archlinux it won't take long time.
    Besides there are very active people maintaining a repo for the latest development releases of the kernel with drm patches for radeon, mesa and the radeon drivers.

    For KDE4, I don't use it, too buggy. From KDE 4.5 I hear no better.
    In fact I wonder why people who are actually suffering KDE (I won't call it use) are complaining about bugs in catalyst.

  5. #15
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,802

    Default

    Quote Originally Posted by ChrisXY View Post
    I don't know abput your catalyst but my catalyst 10.7 runs with xorg 1.8 since the first day.
    Maybe he meant 1.9? (which isn't even released yet)

  6. #16
    Join Date
    Oct 2007
    Posts
    1,322

    Default

    Quote Originally Posted by nanonyme View Post
    Maybe he meant 1.9? (which isn't even released yet)
    I guess you missed the memo: http://www.phoronix.com/scan.php?pag...item&px=ODUzMg

    @those responding to bulletxt: DO NOT FEED THE TROLL (put it on your ignore list).

  7. #17
    Join Date
    Aug 2007
    Posts
    6,673

    Default

    Next problem i also found with 10-7, when i want to play a dvd with kaffeine and i press i to switch deinterlace or not -> X crash. Card used: HD 5670 on with Debian squeeze with KDE 4. It is hard to beleave that a driver could be worse.

  8. #18
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,802

    Default

    Quote Originally Posted by DanL View Post
    Oh, hmm. Interesting. I suppose it has then.

  9. #19
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,802

    Default

    Ahhh. So X server 1.9.0 is released but X.org 7.6 which X server 1.9.x will be part of isn't released yet. Fine.

  10. #20
    Join Date
    Dec 2008
    Posts
    1,002

    Default

    LOL, this is hilarious.

    6% performance drop is no longer observed while running fgl_glxgears and glxgears on specific cards
    Are they going to optimize the Linux part of their drivers now for a useless benchmark that isn't really a benchmark anyway?

    btw. XvBA still broken on Evergreen.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •