Page 3 of 9 FirstFirst 12345 ... LastLast
Results 21 to 30 of 82

Thread: ATI Catalyst 10.8 For Linux Brings OpenGL ES 2.0

  1. #21
    Join Date
    Mar 2009
    Posts
    131

    Default

    Quote Originally Posted by Pfanne View Post
    the fullscreen redirecting bug is still present.
    fglrx 10.6 is the only release without this bug.
    Well that pretty much ensures I won't bother to download this.

  2. #22
    Join Date
    Jul 2008
    Posts
    71

    Default

    Quote Originally Posted by Kano View Post
    Well most likely you do NOT use KDE 4.
    That is true. And given that FGLRX is specifically aimed at supporting the three main commercially supported distros (RHEL, SLES, Ubuntu LTS) and neither of those uses KDE by default, I would not expect AMD to do much testing with KDE, if at all.

  3. #23
    Join Date
    Aug 2007
    Posts
    6,613

    Default

    That's extremely annoying when you create a KDE based distro.

  4. #24
    Join Date
    Dec 2007
    Posts
    140

    Default Use Google Chrome

    I am running Debian Squeeze (as of yesterday) and 10.8 installs and runs just fine.

    I fired up Iceweasel and yes it is borked. However I have been using Chrome and Chromium for the last six months as my preferred browser and it (so far) runs perfectly without resorting to workarounds.

    So, assuming you have no philosophical objections to Chrome it is a neat solution to the problem.

    BTW running Firefox under Ubuntu 10.04 on the same hardware did not exhibit the black panels issue.

  5. #25
    Join Date
    Dec 2007
    Posts
    140

    Default Firefox

    I just downloaded Firefox 3.6 and manually installed it in my home folder and it does not suffer the same issues as Iceweasel. I just have to remember to occasionally check for updates.

  6. #26
    Join Date
    Aug 2007
    Posts
    6,613

    Default

    @grege

    Some features do not work with chrome, like whats the replacement for ctrl+i where you can save any linked media?

    forcing xaa "fixes" mainly the problem, but the driver has to work without override, maybe i add that to my script because without that hack it is unusable with kde4 + squeeze. when you use chrome (without xaa) you will see sometimes black borders around the apps which disappear after moving em. extremely you see it with iceweasel, which is firefox 3.5 basically.

    but why does X crash when you use kaffeine and press i? auto crash feauture or what?

  7. #27
    Join Date
    Oct 2009
    Posts
    343

    Default

    another shit drivers.. screen still goes black on thunderbirtd/firefox
    all other stuff works ok, games/wine/etc BUT I USE MOST THE TIME WEB BROWSER AND MAIL CLIENT!!!! AND ITS BROKEN

    no splash.. [plymouth]...

    system works perfect on opensource, but they are extreamly slow...
    i start to dislike AMD for drivers :<
    everytime before download, I read the release notes.. and.. everytime iam dissapointed..

    10.3 we fixed A B C and D but we broke E F G and H
    10.4 we fixed E F G but we broke I J K
    10.5 we fixed H I but we broke A C F

    AAAARRRGGGG

    thy only you work on

    Disabling the primary display in clone/dual-head mode no longer causes Catalyst
    Control CenterTM not to launch properly after X restart
    Desktop arrangement area no longer appears empty when Catalyst Control CenterTM
    is relaunched after disabling or hot-unplugging the secondary display
    X-server no longer fails when launching fullscreen OpenGL application with
    CrossFireTM enabled and secondary display selected for accelerated display
    Catalyst Control CenterTM will now launch properly under a 2 Gemini ATI RadeonTM
    HD 5900 Series multi-adapter configuration
    "Glxgears/fgl_glxgears" full screen application no longer remain on the desktop after
    they are closed using X button
    6% performance drop is no longer observed while running fgl_glxgears and glxgears
    on specific cards

    i dont care about crossfire, dual screen or glxgears.. when i have fu**** up thunderbird interface.. have no plymouth... resolution dont comeback after crash in wine, firefox sites rendering is slow

    and now what you have broken again

    X-server may fail to start, or unusual behaviour may be observed, after applying
    various HDTV formats of 1080i30/25/p50 standard and optimized modes on DVI/DP
    displays
    System may fail to display error message when improper position values are used in
    "aticonfig --tv-geometry" resulting in invalid "TVHPosAdj" and "TVVPosAdj"
    values in xorg.conf file
    Rotated screen may fail to properly restore after running full-screen OpenGL
    application in dual-head mode; a switch VT will restore screen correctly
    Mouse cursor might be blocked from entering the taskbar area after applying specific
    rotations
    Significant delay may be observed while rotating screen with XRandR
    OpenSuSE 11.3: Corruption may be visible on Firefox while scrolling the window by
    dragging the scrollbar
    Segmentation fault may occur when running "Quake 4" and "Enemy Territory:
    Quake Wars" at 1280x1024 or resolutions higher than current desktop resolution
    SUSE 11.2: With a DP display connected to the adapter, a hot-plugged DFP display
    may fail to light up in clone mode

    i see the same problems over and over and over...

    you need to know whats the priority

    A]system basics funcionality
    B]super duper features eyefinity/stereoscope/[self fan cleaning....dunno what next..]
    C]performance


    just focus on one of this points.. i dont care abour eyefinity right now, or other useless feature if system basics are crapped

    Bridgman, are you from opensource radeon drivers or from closed source[fglrx] ? please.. tell me... WHYYYY!!!

    i always was fan of radeons.. ever.. till radeon 8500... your hardware is awasome... but drivers are pile of..... you know what...

    ps: even oglES 2.0 looks useless on all problems that i have...
    iam usung ubuntu 10.04 and have radeon 4850 whith iam proud of... and cant use it 2 years in 100%

  8. #28
    Join Date
    Aug 2007
    Posts
    437

    Default

    As usuall, FGLRX is still crap! muhahahaha!!!

  9. #29
    Join Date
    Mar 2010
    Posts
    27

    Default

    Quote Originally Posted by FunkyRider View Post
    As usuall, FGLRX is still crap! muhahahaha!!!
    And as usual, your only reason of existence is to point this out to "us"?


    Anyways... I am happy with the added dual head config stuff, as I had some problems with it. Didn't try 10.8 yet, but I will be happily doing it tomorrow.

    The "black screen" issue bothers me too, but... it happens one out of a thousand operations (maybe once or twice per day for me).

  10. #30
    Join Date
    Oct 2009
    Posts
    343

    Default

    for me all the time.. just run thunderbird, and browse emails with arrows on the list.. every 4 arrow click i get blacked windows with email lists.. or other element.. ita random..

    iam frustrated.. iam waiting 2 years to fix this stuff.. but AMD add some crossfire and other useless stuff..

    i also migrate companies from windows to linux, you think its ok to show them broken blacked windows? they are scared, that something might hang in a moment

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •