Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Video reproduction isn't good with ATI Catalyst drivers

  1. #11
    Join Date
    Jun 2009
    Posts
    2,927

    Default

    Make sure that you are running it as root. It MUST work, the file is there.

    Try

    Code:
    sudo  "echo low > /sys/class/drm/card0/device/power_profile"
    with the quotes at exactly these places.

  2. #12
    Join Date
    Jun 2009
    Posts
    2,927

    Default

    You can also use:

    Code:
    sudo "echo dynpm > /sys/class/drm/card0/device/power_method"
    to switch to the dynamic powersaving. It works OK, but it sometimes flickers when changing powermodes. echo "profile" again to switch back to the profile method.

  3. #13
    Join Date
    Oct 2007
    Posts
    321

    Default

    Quote Originally Posted by Digitalone View Post
    I use VLC only.

    I already have 2.6.35 kernel. What does this command do?
    After giving it, I had:
    Code:
    bash: /sys/class/drm/card0/device/power_profile: Permesso negato
    Access denied, also from root.

    However, It seems that power saving isn't supported for my card, so fan speed is high. Here I find the following options:


    From log I should have:
    Code:
           (**) RADEON(0): Option "ClockGating" "on"
           (**) RADEON(0): Option "DynamicPM" "on"
    But I have:
    Code:
    (WW) RADEON(0): Option "DynamicPM" is not used
    (WW) RADEON(0): Option "ClockGating" is not used
    Have you any other ideas, or I have to surrender?

    With this said, this thread belongs in the open source forum.


    anyways, which version of vlc do you use? I don't have any problems with video quality on vlc and linux. However, i'm using the proprietary driver.

  4. #14
    Join Date
    Aug 2010
    Posts
    14

    Default

    Thanks, I've resolved.

    The command was:
    Code:
    sudo bash -c "echo low > /sys/class/drm/card0/device/power_profile"
    With open source driver I had a little of tearing, but I've resolved adding
    Code:
    	Option     "AccelMethod" "EXA"
    	Option     "EXAVSync" "yes"
    in my xorg.conf.

    Thanks again.

  5. #15
    Join Date
    Jul 2010
    Posts
    6

    Talking

    Quote Originally Posted by DarkFoss View Post
    Make sure you select GLX video output(xcb) from the video settings drop down box.
    Open the Catalyst Control Center and under 3D>more settings make sure
    vertical refresh is set to Quality-always on.

    I have little to no tearing using VLC,Mplayer,XBMC,Dragon Player,Fluendo DVD Player that way..can't comment about other player since I don't use'em or have them installed.
    Thanks for this information DarkFoss. This has improved my experience of Catalyst!

  6. #16
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    628

    Default

    Quote Originally Posted by expectATIon View Post
    Thanks for this information DarkFoss. This has improved my experience of Catalyst!
    ++

    haven't tested it yet but thanks for the advice !

  7. #17
    Join Date
    Mar 2007
    Location
    DG, IL, USA
    Posts
    195

    Default

    your both welcome

    As an aside if your using the kde 4.5 desktop you may want to enable
    Desktop effects and under the advanced tab check the dierct rendering box and the use Vsync box too..is seems to cut down on the black screen stuff with the fglrx driver but not eliminate it in Firefox Chromium and Thunderbird.

    There is one more setting under Application Appearence>style>Fine tuning tab.. Graphical effects there are several options to pick from for my desktop @1920x1080.. I use High Display Low CPU The results can be quite dramatic on your overall responsiveness... no idea what setting would be best for a laptop.
    I suggest playing with them and finding whats best for your set-up.
    Those who would give up Essential Liberty to purchase a little Temporary Safety,deserve neither Liberty nor Safety.
    Ben Franklin 1755

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •