Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: AMD to Demo Fusion APUs at IFA Berlin, in September

  1. #11
    Join Date
    Apr 2009
    Posts
    66

    Default

    Not much to add, but I've tried it today with xorg-server 1.8.2 and it seems to crash more than with 1.7.7. Unless I add the "RenderAccel" "off" option I can't even get X to start up with either KDE or E.

    Once in, doing anything 3D at all (glxgears or turning on compositing) results in an immediate hang of X every time. Cursor still moves, but can't light the capslock or do anything.

  2. #12
    Join Date
    Dec 2008
    Posts
    984

    Default Evergreen problems

    I was planning to do a detailed writeup, but I see others have beaten me to it One other thing that I'm noticing is that if I cold boot I see an almost immediate GPU lockup at the GDM login screen. It seems that I have to run fglrx first to set the GPU to a sane state before I can use any of the open source acceleration stuff.

  3. #13
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    OK, that seems like a useful clue. Do you still get hangs eventually when running the open drivers after fglrx ?

    Which GPU are you using ?

    EDIT - I guess we should move this to the HD5000 open source driver thread for now

  4. #14
    Join Date
    Sep 2008
    Posts
    989

    Default

    Quote Originally Posted by bridgman View Post
    There are known GPU hangs when running 2D and 3D together - agd5f and Richard are both looking into those. AFAIK they also happen when using just 2D or just 3D but *much* less frequently. Probably would be a good idea to turn off compositing until the GPU hangs are figured out.

    Not sure if the devs are seeing the same degree of corruption on their systems (at least I don't remember seeing or hearing about it); what are others seeing ?
    I can echo Wingfeather's problems, except on a HD5970, using the latest linux-next kernel (alternately I tried airlied's drm-radeon-testing and drm-fixes) and evergreen_accel. OTOH I am running everything from master, including xserver, libs, and proto. Definitely seeing pointer corruption unless Option "RenderAccel" is set to "off", and random crashes whether compositing is enabled or not. I can also reliably crash X by minimizing a window with metacity or compiz compositing, although with Kwin compositing set to always keep thumbnails, that doesn't happen. Tried a full factorial of the radeon DDX's options, and only RenderAccel off improved things at all. "EXAVSync" "on" causes X to crash on startup.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •