Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: How do I install Catalyst for Ubuntu 10.04 64-bit?

  1. #11
    Join Date
    Aug 2010
    Posts
    7

    Default

    I deleted the config files, ran the command, and restarted but I still got a blank screen. So I booted using "nomodeset" in GRUB2 and got the same error as earlier:

    "(EE) fglrx(0): Please disable switchable-graphics feature and configure the discrete card as the default adapter
    (EE) fglrx (0): GetBiosParamter failed
    (EE) fglrx (0): PreInitAdapter failed
    (EE) fglrx (0): PreInit failed
    (EE) Screen (s) found, but none have a usable configuration. "

    Using the low graphics mode, I was able to restore the default configuration and successfully boot. Compiz doesn't work and Catalyst Control Center doesn't start. Here's the error:

    "Initialization Error

    There was a problem initializing Catalyst Control Center Linux edition. It could be caused by the following.

    No ATI graphics driver is installed, or the ATI driver is not functioning properly.
    Please install the ATI driver appropriate for you ATI hardware, or configure using aticonfig."

    Here is the working xorg.conf file:

    "Section "Device"
    Identifier "Configured Video Device"
    Driver "vesa"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    EndSection"

    and the modified one:

    "Section "ServerLayout"
    Identifier "aticonfig Layout"
    Screen 0 "aticonfig-Screen[0]-0" 0 0
    EndSection

    Section "Module"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]-0"
    Driver "fglrx"
    BusID "PCI:1:0:0"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device "aticonfig-Device[0]-0"
    Monitor "aticonfig-Monitor[0]-0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection"

    Do you think that simply changing the driver in the working config file from "vesa" to "fglrx" will work?

  2. #12
    Join Date
    Sep 2010
    Posts
    3

    Exclamation fglrx: black screen of death

    Quote Originally Posted by Sup3r3g0 View Post
    I deleted the config files, ran the command, and restarted but I still got a blank screen. So I booted using "nomodeset" in GRUB2 and got the same error as earlier:

    "(EE) fglrx(0): Please disable switchable-graphics feature and configure the discrete card as the default adapter
    (EE) fglrx (0): GetBiosParamter failed
    (EE) fglrx (0): PreInitAdapter failed
    (EE) fglrx (0): PreInit failed
    (EE) Screen (s) found, but none have a usable configuration. "

    Using the low graphics mode, I was able to restore the default configuration and successfully boot. Compiz doesn't work and Catalyst Control Center doesn't start. Here's the error:

    "Initialization Error

    There was a problem initializing Catalyst Control Center Linux edition. It could be caused by the following.

    No ATI graphics driver is installed, or the ATI driver is not functioning properly.
    Please install the ATI driver appropriate for you ATI hardware, or configure using aticonfig."

    Here is the working xorg.conf file:

    Code:
    ...
    Do you think that simply changing the driver in the working config file from "vesa" to "fglrx" will work?
    I have a very similar problem: can't get fglrx to work because I always get into a blank screen. I'm unsuccessful trying to install fglrx since Catalyst 10.3, on my new HP Pavilion DV-4 2080BR.

    The problem in my case, and maybe yours, is that the Intel Core CPU (i3/i5/i7) have integrated graphics, and since I bought a notebook model that also have discrete ATI GPU, in a way that I have 2 GPUs at same computer, with the infamous 'switchable' option.

    The bad thing is that Linux kernel is just starting to support switchable graphics, and worst, Xorg totally don't support it.

    Be best (fast) solution would be to disable the switchable thing at BIOS, enabling only the ATI GPU. But to my bad luck, that's not an option to me, because there is no HP notebook with BIOS option about switchable graphics.

    So fglrx detects something that it don't understand, and, so, I get the black screen thing.

    I e-mailed HP asking them for a new BIOS version to disable Intel integrated GPU, so I would get only the ATI GPU detected by my favorite OS.
    HP replied saying something that seems to be wrote by a bad-programed-robot, with all nonsense phrases, just copying and pasting my own words from the initial message.
    So I replied their response asking for someone that understand what BIOS is. Some days later, a guy e-mailed me, he said that HP will not release a new version of BIOS, and if HP does, it will not contain the switch-off integrated graphics feature. dot.

    The good thing is that I still can have hardware accelerated graphics from the i5's GPU. Intel have much better linux driver support than ATI. My KDE works beauty with all those transparency and animations.
    Sad that I paid/waist $500 more on this notebook model just because of the ATI GPU and I can't use it.

    I will have better luck on the next buying, keeping away from HP and ATI. Maybe a Dell with Ubuntu.

  3. #13
    Join Date
    Sep 2007
    Posts
    993

    Default

    Typical ATI. You might want to follow this thread in the Ubuntu forums in case there's any updates on the problem:

    http://ubuntuforums.org/showthread.php?t=1504816

  4. #14
    Join Date
    Mar 2007
    Location
    DG, IL, USA
    Posts
    195

    Default

    Quote Originally Posted by Panix View Post
    Typical ATI. You might want to follow this thread in the Ubuntu forums in case there's any updates on the problem:

    http://ubuntuforums.org/showthread.php?t=1504816
    Typical Panix response blaming ATI for something thats clearly HP's fault.
    One that they seems disinterested in fixing at that.
    Those who would give up Essential Liberty to purchase a little Temporary Safety,deserve neither Liberty nor Safety.
    Ben Franklin 1755

  5. #15
    Join Date
    Sep 2007
    Posts
    993

    Default

    If I'm wrong, fine. I just assumed it worked in Windows.

    http://www.phoronix.com/scan.php?pag...item&px=Nzk0OQ

    Is this useful to the problem?:

    http://linux-hybrid-graphics.blogspo...nd-atiati.html

  6. #16
    Join Date
    Sep 2010
    Posts
    3

    Default

    Quote Originally Posted by Panix View Post
    Typical ATI. You might want to follow this thread in the Ubuntu forums in case there's any updates on the problem:

    http://ubuntuforums.org/showthread.php?t=1504816
    Thanks, Panix

  7. #17
    Join Date
    Sep 2010
    Posts
    3

    Default

    Quote Originally Posted by Panix View Post
    Too much advanced for me =/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •