Page 18 of 18 FirstFirst ... 8161718
Results 171 to 174 of 174

Thread: Open-Source GPU Drivers Causing Headaches In KDE 4.5

  1. #171
    Join Date
    Mar 2010
    Posts
    158

    Default

    Quote Originally Posted by tball View Post
    Now I have installed ubuntu-desktop also, and the 2d performance is a world to difference.

    The 2d performance in gnome is much much more fluid, than it is in kde.

    Does anyone have a clue why that can be? The 2d performance without compositing is also better in gnome, than it is in kde.
    Apart from Kwin disabling compositing, absolutely no problem with maverick KDE using the as-delivered open source drivers here. One solution is to use compiz for KDE rather than Kwin.

    Apparently the Kwin developer does not do extensive hardware checking, and the driver he was using for his R700 ATI card on his distribution didn't work, so he has disabled Kwin compositing for everyone using the open source R600c driver.

    Another work-around for Kubuntu maverick:

    Code:
    Workaround - not a fix
    Using the force - don't worry, be happy settings
    
    Editing the ~/kde/share/config/kwinrc.
    
    Before:
    Code:
    
    ...
    DisableChecks=false
    ...
    OpenGLIsUnsafe=true
    
    
    After:
    Code:
    
    ...
    DisableChecks=true
    ...
    OpenGLIsUnsafe=false
    ...
    
    
    Konsole:
    Code:
    
    LIBGL_ALWAYS_INDIRECT=1 kwin --replace
    
    
    The desktop effects are working...

  2. #172
    Join Date
    Jan 2009
    Posts
    515

    Default

    Quote Originally Posted by hal2k1 View Post
    Apart from Kwin disabling compositing, absolutely no problem with maverick KDE using the as-delivered open source drivers here. One solution is to use compiz for KDE rather than Kwin.

    Apparently the Kwin developer does not do extensive hardware checking, and the driver he was using for his R700 ATI card on his distribution didn't work, so he has disabled Kwin compositing for everyone using the open source R600c driver.

    Another work-around for Kubuntu maverick:

    Code:
    Workaround - not a fix
    Using the force - don't worry, be happy settings
    
    Editing the ~/kde/share/config/kwinrc.
    
    Before:
    Code:
    
    ...
    DisableChecks=false
    ...
    OpenGLIsUnsafe=true
    
    
    After:
    Code:
    
    ...
    DisableChecks=true
    ...
    OpenGLIsUnsafe=false
    ...
    
    
    Konsole:
    Code:
    
    LIBGL_ALWAYS_INDIRECT=1 kwin --replace
    
    
    The desktop effects are working...
    Thx for your reply. Well my compositing works in kde, but I just think they are slower than compiz. But thx for the guide changing the default compositor to compiz.

  3. #173
    Join Date
    Jan 2008
    Location
    Have a good day.
    Posts
    678

    Default

    I tried kde 4.5.1 yesterday and everything works with radeon gallium, including blur. But compositing is slow, especially when scrolling documents. On the other hand, Compiz is almost as fast as no compositing, i.e. really fast. The problem is that Compiz is a neat tech demo, but not so good a window manager, definitely not comparable to kwin. Also, there's some kind of simplicity and good taste in kwin's effects that Compiz lacks. I guess KDE people need to work on the performance side of things...

  4. #174
    Join Date
    Jun 2009
    Posts
    2,937

    Default

    I got bitten by this last night, and it is worse than I expected. It's not just the blur plugin that's affected, and my drivers got blacklisted (for unknown reasons!) and I could not re-enable OpenGL compositing, while getting no error messages.

    After deleting KWin config files and reconfiguring, everything worked. Including Blur. However, each change of settings crashes KWin, which is a known issue.

    Looks like drivers get blacklisted way too quickly, and it is an annoyance. I do wish better communication between the KWin team and the Mesa developers in the future. Mistakes were made, it can't continue like this.

    After setting it up properly, though, KDE 4.5.1 simply rocks. I've never used such a slick, enjoyable and user-friendly desktop anywhere, including Macintosh.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •