Results 1 to 2 of 2

Thread: AMD/ATI fglrx 10-8 and kernel 2.6.36

  1. #1
    Join Date
    Sep 2010
    Posts
    2

    Default AMD/ATI fglrx 10-8 and kernel 2.6.36

    Hello,

    I'm pretty new to this forum so please don't blame if the thread is maybe at the wrong place.


    I have the following goal: just update my system to kernel 2.6.36-rc3 and go on using the GUI.

    so far so good, I'd done the following steps
    - download kernel
    - extract, build and install

    - installed fglrx-modules-dkms, which tried to build fglrx.ko for all kernels
    - cause the build failed on most of them I started to modify the source just to compile under 2.6.36
    therefore I figured out that just a small identifier in the src/include/linux/fs.h has changed (the file_operations.ioctl changed to file_operations.unlocked_ioctl)
    so I renamed it in fglrx code and everythings fine, build with
    dkms build -m fglrx -v 10-8 -k 2.6.36-rc3
    dkms install ...
    just ok

    but while starting X the screen just stays black/blank
    last entry in Xorg.0.log is
    "ukiOpenByBusid: ukiOpenMinor return 12" (if necessary I'll attech the full log)


    It would be great to know if anyone else just had the same problem
    and even greater if maybe one can provide a solution :-)


    What I tried so far:
    use some another fglrx version, namely 10-4, 10-7

    What I plan to trie:
    test with another kernel maybe 2.6.34, 2.6.35
    whats still working is fglrx-10-8 with 2.6.33.2



    As mentioned above, it would be wonderfull to get some reply :-)
    and please don't blame me for some mistakes

    bye
    Apfelkuchen

  2. #2
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    607

    Default

    you certainly didn't use the search-function did you ?

    http://phoronix.com/forums/showthread.php?t=25485

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •