Page 2 of 16 FirstFirst 123412 ... LastLast
Results 11 to 20 of 155

Thread: ATI R600 Gallium3D Driver Continues Advancing

  1. #11
    Join Date
    Dec 2009
    Posts
    338

    Default

    I'm glad that r600g finally took off. It also seems to run my test system just fine, meaning that compiz effects seem to work fine. However, the blitting performance (aka glxgears) is about 1/4 of the classic driver's.

  2. #12
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    629

    Default

    Quote Originally Posted by HokTar View Post
    I'm glad that r600g finally took off. It also seems to run my test system just fine, meaning that compiz effects seem to work fine. However, the blitting performance (aka glxgears) is about 1/4 of the classic driver's.
    talking about the gallium and classic r600 driver:

    - are there any graphical corruptions when using compiz(-fusion) ?
    - how stable is it
    - most importantly (for me as a desktop and work user): how fast does the fan spin when using the opensource driver compared to the proprietary/closed driver (where it's constantly running at around 22-24%) ?

    the proprietary driver has greatly improved in the last few months but it still causes me trouble - so if I knew that the open drivers work (somewhat) fine that I could use googleearth, compiz, etc. then I finally could switch

    many thanks in advance

  3. #13
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    629

    Default

    I also play videos via smplayer, totem, vlc - any problems with those ?

  4. #14
    Join Date
    Oct 2008
    Location
    Poland
    Posts
    182

    Default

    Quote Originally Posted by kernelOfTruth View Post
    - most importantly (for me as a desktop and work user): how fast does the fan spin when using the opensource driver compared to the proprietary/closed driver (where it's constantly running at around 22-24%) ?
    Nothing to do with 3D (Mesa) code.

    Quote Originally Posted by kernelOfTruth View Post
    I also play videos via smplayer, totem, vlc - any problems with those ?
    Nothing to do with 3D (Mesa) code.

  5. #15
    Join Date
    Dec 2009
    Posts
    338

    Default

    Quote Originally Posted by kernelOfTruth View Post
    I also play videos via smplayer, totem, vlc - any problems with those ?
    I have not noticed any graphical problems with compiz and it did never crash. However, some animations were slow e.g. beam up and burn. The rest was as fast as with the classic - no perceptive speed difference.

    I have not used it extensively, but I have not yet encountered any stability problems.

    Power management works for me if I use the profile based version. With the low profile my machine is noticeably cooler, but I have a notebook plus I run Einstein@home, so my fan speed is always maximal. Dynpm won't change my settings, i.e. everything remains maxed out.

    I tested a simple xvid file with SMPlayer, xv (for radeon) worked fine - no flickering or artifacts.

    I hope it helps.

  6. #16
    Join Date
    Jun 2009
    Posts
    2,927

    Default

    kernelOfTruth: Which card?

    Quote Originally Posted by Zajec
    Nothing to do with 3D (Mesa) code.
    Unless he uses gl output.

  7. #17
    Join Date
    Oct 2008
    Location
    Poland
    Posts
    182

    Default

    Quote Originally Posted by pingufunkybeat View Post
    Unless he uses gl output.
    Ahh, right, sorry. I assumed everyone with ATI use Xv

  8. #18
    Join Date
    Nov 2008
    Posts
    764

    Default

    kernelOfTruth: I'm using evergreen, YMMV for r600/r700 cards:

    * a week ago, r600g somewhat worked. Given the emount of commits during the last week, these results are outdated though.
    * fan speed is louder than fglrx/windows for me, even when forcing profile to "low". I don't know if that's a lack of power saving features or different fan control algorithms. (If you know a way to read clocks on fglrx, let me know)
    * for videos, use xv, not opengl. mesa shouldn't be involved in that.
    * stability: seemed good on r600c, not so good on r600g last week. But evergreen-code is just out of beta, r600/r700 should be better. Still, r600g is in heavy development and stability can change with each revision.

  9. #19
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    629

    Default

    @all:

    thanks so far !

    @pingufunkybeat:

    5850 HD

    maybe I mixed some things up: the r600 does support the evergreen, too, right ?

    or would that be a different driver ?

    @HokTar:

    nice ! so it sounds like it's already in a pretty production-usable state
    the effects I need are: zoom, negative and magic lamp those hopefully won't be that slow

    @HokTar, Zajec:

    in that case I would use the xv-driver instead of gl for video - thanks !

    @rohcQaH:

    so I'll give it some more weeks and then it'll hopefully will provide some more functionality and I could start to use it



    perhaps it's too early but did anyone try suspend (specifically: suspend-to-ram) yet ?

  10. #20
    Join Date
    Jun 2009
    Posts
    2,927

    Default

    Quote Originally Posted by Zajec View Post
    Ahh, right, sorry. I assumed everyone with ATI use Xv
    Xv generally works better (faster), and I use it. But it flickers when you move or resize it under a compositor. Gl output does not.

    For some reason, VLC seems to prefer GL output too, and picks it automatically.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •