Results 1 to 5 of 5

Thread: Getting my Sapphire X1600Pro HDMI to work

  1. #1
    Join Date
    Feb 2007
    Posts
    11

    Default Getting my Sapphire X1600Pro HDMI to work

    Hi All

    I am having no end of problems getting the fglrx drivers working properly with XVideo support on my X1600Pro HDMI. First off, here are the important bits of hardware:

    - Sapphire X1600Pro HDMI
    - ASUS M2NPV-VM Motherboard
    - AMD X2 3800+

    I am running Gentoo amd64, with kernel 2.6.19 (I need to use this instead of .18 for some other hardware), and Xorg 7.1.1. I've tried all the driver versions in portage that compile against 2.6.19. All drivers end up with DRI enabled (but seemingly low FPS in glxgears - ~250fps).

    - 8.28.8-r1: xvinfo reports there are no adapters available. Playback in mythtv is horribly slow, and glxgears runs at ~250fps
    - 8.30.3-r1: xvinfo shows that xv is ready. When I try to use mythtv for playback, X crashes immediately.
    - 8.32.5: Same results as 8.30.3
    - 8.33.6-r2: X refuses to load. The machine does not lock up, but I cannot kill X no matter what (kill -9 has no effect).

    I feel like I must have some sort of weird hardware or software combination, with all these drivers failing so horribly. Is the glxgears 250fps low for this card (I don't know what a reasonable value is)?

    Anyone have any idea where to start looking for answers?

    TIA
    Dave

  2. #2

    Default

    With x86_64 Linux, there is currently a bug with X-Video (though it should be resolved soon).

  3. #3
    Join Date
    Feb 2007
    Posts
    11

    Default

    Blast!

    How soon is soon? Next driver iteration? I'm new to the ATI world, so am unsure of their usual driver release schedule....

  4. #4

    Default

    The new driver should be out later this month (they are monthly).

  5. #5
    Join Date
    May 2007
    Posts
    1

    Default

    i got to this thread googling, i have an m2npv with an x1900xtx, 64x2 5000+ and 3gb;
    it seem i have the exact problems you had with the same version of the drivers and i don't have a clue to do to get the drivers workinin neither what distribution to install; that's why i was searching for any user with a similar hardware config.
    I remember that i had time ago the x1900 working in 3d acceleration with a gentoo64 but i don't remember the enviroment (especially the driver version);
    by reading this thread i feel that same older drivers can work but i have to try, actually i switched to opensuse 10.2 and tried same other distributions before but i was never able to got the fglrx driver working.

    by reading on this thread i finally realized that i always tried too recent drivers , more than the last you got working even if the various issues;

    for the crash while playing there are same workarounds and it's a;ready know that a bug has glxgears report wrongs results...

    now,i have samething other to try.

    Edit: no working drivers after 8.32.5 ....
    Last edited by fk0fk0; 05-10-2007 at 05:10 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •