Results 1 to 9 of 9

Thread: Problems with RS690

  1. #1
    Join Date
    Nov 2008
    Location
    Managua, Nicaragua
    Posts
    83

    Default Problems with RS690

    Hello all,

    I'm using the radeon driver from git. Performance is really bad, as if I was using the vesa driver. Moving windows, resizing, scrolling, all are very slow.

    It makes little difference having kms enabled or disabled.

    Also, HDMI audio does not work correctly. With VLC there's no sound at all, xine crashes after enabling HDMI audio, and mplayer plays in fast forward if HDMI audio is selected.

    Running Archlinux with KDE 4.5.2 and xorg 1.9.

    The computer is a Gateway T1628 with X1270 graphics.

  2. #2
    Join Date
    Mar 2010
    Posts
    19

    Default

    Please post your /var/log/Xorg.0.log and dmesg | grep drm

  3. #3
    Join Date
    Nov 2008
    Location
    Managua, Nicaragua
    Posts
    83

    Default

    Quote Originally Posted by kfgz View Post
    Please post your /var/log/Xorg.0.log and dmesg | grep drm
    Here's the Xorg.0.log: http://pastebin.com/qMMywr3j

    And here's the dmesg output:

    Code:
    [drm] Initialized drm 1.1.0 20060810
    [drm] radeon defaulting to kernel modesetting.
    [drm] radeon kernel modesetting enabled.
    [drm] initializing kernel modesetting (RS690 0x1002:0x791F).
    [drm] register mmio base: 0xCFDF0000
    [drm] register mmio size: 65536
    [drm] radeon: irq initialized.
    [drm] Detected VRAM RAM=384M, BAR=256M
    [drm] RAM width 128bits DDR
    [drm] radeon: 384M of VRAM memory ready
    [drm] radeon: 512M of GTT memory ready.
    [drm] GART: num cpu pages 131072, num gpu pages 131072
    [drm] radeon: 1 quad pipes, 1 z pipes initialized.
    [drm] Loading RS690/RS740 Microcode
    [drm] radeon: ring at 0x0000000060000000
    [drm] ring test succeeded in 1 usecs
    [drm] radeon: ib pool ready.
    [drm] ib test succeeded in 0 usecs
    [drm] Default TV standard: NTSC
    [drm] Radeon Display Connectors
    [drm] Connector 0:
    [drm]   VGA
    [drm]   DDC: 0x7e50 0x7e40 0x7e54 0x7e44 0x7e58 0x7e48 0x7e5c 0x7e4c
    [drm]   Encoders:
    [drm]     CRT1: INTERNAL_KLDSCP_DAC1
    [drm] Connector 1:
    [drm]   LVDS
    [drm]   DDC: 0x7e40 0x7e50 0x7e44 0x7e54 0x7e48 0x7e58 0x7e4c 0x7e5c
    [drm]   Encoders:
    [drm]     LCD1: INTERNAL_LVTM1
    [drm] Connector 2:
    [drm]   HDMI-A
    [drm]   HPD2
    [drm]   DDC: 0x7e40 0x7e60 0x7e44 0x7e64 0x7e48 0x7e68 0x7e4c 0x7e6c
    [drm]   Encoders:
    [drm]     DFP2: INTERNAL_DDI
    [drm] fb mappable at 0xB0040000
    [drm] vram apper at 0xB0000000
    [drm] size 4096000
    [drm] fb depth is 24
    [drm]    pitch is 5120
    fb0: radeondrmfb frame buffer device
    drm: registered panic notifier
    [drm] Initialized radeon 2.5.0 20080528 for 0000:01:05.0 on minor 0

  4. #4
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    Looks like you might have EXAVsync enabled (message in your xorg log) - if I'm thinking of the right option it will definitly slow down your normal 2D operations. Can you check in your xorg.conf to see if you have that option enabled, and turn it off if so ?

  5. #5
    Join Date
    Nov 2008
    Location
    Managua, Nicaragua
    Posts
    83

    Default

    Quote Originally Posted by bridgman View Post
    Looks like you might have EXAVsync enabled (message in your xorg log) - if I'm thinking of the right option it will definitly slow down your normal 2D operations. Can you check in your xorg.conf to see if you have that option enabled, and turn it off if so ?
    EXAVsync was enabled, but disabling it makes no perceptible difference.

  6. #6
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    That seems odd. My recollection was that EXAVsync used to make a significant difference in 2D performance, which was why Alex disabled it by default.

    Can you check your xorg log to make sure it is really off ?

  7. #7
    Join Date
    Nov 2008
    Location
    Managua, Nicaragua
    Posts
    83

    Default

    Quote Originally Posted by bridgman View Post
    That seems odd. My recollection was that EXAVsync used to make a significant difference in 2D performance, which was why Alex disabled it by default.

    Can you check your xorg log to make sure it is really off ?
    It's really off:

    Code:
    [ 15810.826] (**) RADEON(0): Option "EXAVSync" "off"
    Maybe something is broken in the driver for this chip? Any other options to turn on/off to increase performance?

  8. #8
    Join Date
    Nov 2008
    Location
    Managua, Nicaragua
    Posts
    83

    Default

    I did some testing, here's the result:

    KMS on, EXAVSync on, Desktop Efects off:
    Very bad performance

    KMS on, EXAVSync off, Desktop Efects off:
    Very bad performance

    KMS on, EXAVSync off, Desktop Efects on:
    Decent performance, visual artifacts

    KMS off, EXAVSync on, Desktop Efects off:
    Very bad performance

    KMS off, EXAVSync off, Desktop Efects off:
    Decent performance, screen tearing

    KMS off, EXAVSync off, Desktop Efects on:
    Crash after enabling desktop effects.

    I usually have Desktop Effects off, but enabling then seems to help when using KMS, but cause visual artifacts.

    So it seems that KMS off, EXAVSync off, Desktop Efects off is my best choice ATM.

  9. #9
    Join Date
    Nov 2008
    Location
    Managua, Nicaragua
    Posts
    83

    Default

    I've been using the experimental "radeon" repository for Arch, and there's been a lot of progress. 2D performance is now very good with KMS, there are no artifacts and no slow scrolling.

    3D is also very good, especially with Gallium, as it seems to have better support. Some games (Supertux, SMC, some Popcap games under wine) had lots of artifacts and/or were painfully slow with or without KMS. With Gallium performance is acceptable and there are very few artifacts on some.

    The best news is on the power front. The consumption on idle is now around 18W... it was around 30W before!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •