I have been trying to get to the bottom of this for a week or so now, and I just cant get it sorted.

If I run the open source driver gnome-shell works fine, but the one game I play fails in wine with graphical corruption.

if I run the fglrx 10.10 driver (either installed via Hardware Drivers, or the ATI installer) the game I play works fine, but gnome-shell locks the system (from the ubuntu repository)

If I build gnome-shell from source it does work but I suffer from a serious graphical glitch in that its way to bright and very laggy.

(Built from source with fglrx)

(Built from source with open source driver)

if I use the ubuntu repo's gnome-shell it just locks, but i dont have the graphical issue. It sould be noted its not a hard-lock, it feels like its still running but I cant interact with it, I can CTRL+ALT+F2 kill X and then re-login etc, so its not a hard lock.

fglrx Xorg.0.log


fglrx Glxinfo


open source Xorg.0.log


open source Glxinfo


Any thoughts or info that may help me get to the bottom of this would be great.

On a side note, with Debian I couldnt even get gnome-shell to launch with the fglrx driver installed, I switched to Ubuntu in the hope that it would work, but found myself in this situation.