Update:

After some digging found this response to the profile support.

Level 4.1 is supported; see the output of vdpinfo (a utility mentioned elsewhere).

Nothing in our VDPAU implementation actually validates the level; anything high profile should decode visually correctly, it's just a matter of performance.
Looking at some results here:

http://www.nvnews.net/vbulletin/show...aximum+profile

Show that the 240 at least should have no problem with 5.0 support.