Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 50

Thread: [Ask] Nvidia features on linux

  1. #31
    Join Date
    Aug 2007
    Posts
    6,634

    Default

    Ok, i could not test any other driver between 260.19.12 (13th oct) and 260.19.21 (5th nov). This issue seems to be fixed in a short test. If you like you can try it with 1 gb ram (you can restrict ram via option) and 128 mb vram. It still works, but vlc will most likely never work on atom for full hd vc1 (thats what i tested). Definitely too high system load. So i can use mplayer for content where i do not need subtitles and xbmc whre i need em. It's a bit sad because vlc has got even a parser for the bluray structure, you do not need to play the m2ts you can directly play the mountpoint of the bluray (you can do funny things with vbox and play original bluray with that when you export em...). when vlc is used in that way then the time shown is correct (xbmc has a got approximation, mplayer/vlc not). also you can select the audio/subs with the name not the id. Really bad that the best player for it is too slow with atom cpu.

  2. #32
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,584

    Default

    Quote Originally Posted by Kano View Post
    It's a bit sad because vlc has got even a parser for the bluray structure, you do not need to play the m2ts you can directly play the mountpoint of the bluray
    I believe xbmc also has this capability now if it is compiled with libbluray.

  3. #33
    Join Date
    Oct 2010
    Posts
    36

    Default

    Alright guys, so i bought gt 430.
    vdpau is awesome. H.264 L4.1 works great on linux.

    i just wondering, why the CPU usage still high ? Like about 50% and more.
    i use mplayer with ffmpeg multithreading.

  4. #34
    Join Date
    Aug 2007
    Posts
    6,634

    Default

    You dont use vdpau correctly. Put
    Code:
    vc=ffh264vdpau,ffmpeg12vdpau,ffvc1vdpau,ffwmv3vdpau,ffodivxvdpau,
    in your .mplayer/config.

  5. #35
    Join Date
    Oct 2010
    Posts
    36

    Default

    You're right. now it works.
    But, if i play 1080p movie with 15mbps bitrate, the CPU usage still hit about 50%. Although i use ffmpeg-mt, the load seems doesn't spread among the threads.
    I encounter this message too :
    [h264_vdpau @ 0x8a4b8c0]Cannot parallelize deblocking type 1, decoding such frames in sequential order

  6. #36
    Join Date
    Aug 2007
    Posts
    6,634

    Default

    There must be something wrong. Do you really use

    vo=vdpau

    normally that's default, but you can add it too. Btw. i would use the unpatched mplayer, works best with vdpau - especially more easy to play 3gp with audio without messing around with ffmpeg-mt options.

  7. #37
    Join Date
    Oct 2010
    Posts
    36

    Default

    got this error also
    [vdpau] Error when calling vdp_presentation_queue_block_until_surface_idle: A catch-all error, used when no other error code applies.

    I am gonna try unpatched mplayer version now.

  8. #38
    Join Date
    Oct 2010
    Posts
    36

    Default

    I tried unpatched version. Still, sometimes the CPU goes fluctuated over 10% according to the video load.
    Seems like multithreading ffmpeg doesn't work with vdpau.

  9. #39
    Join Date
    Aug 2007
    Posts
    6,634

    Default

    That's normal especially when you cpu is clocking down dynamically. But 50% load would be too much. As the gpu decodes you don't need multithreading anyway.

  10. #40
    Join Date
    Oct 2010
    Posts
    36

    Default

    Quote Originally Posted by Kano View Post
    That's normal especially when you cpu is clocking down dynamically. But 50% load would be too much. As the gpu decodes you don't need multithreading anyway.
    Yeah, i wonder why.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •