Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31

Thread: request: patch for catalyst (10.10+) to get 2.6.37-rc* working

  1. #11
    Join Date
    Nov 2010
    Location
    Ajka, Hungary
    Posts
    6

    Default

    I applied all the patches listed previously and I could install the driver with compat_ioctl and unlocked_ioctl as well without any errors:
    Code:
    Új csomag kiválasztása: fglrx.
    (Adatbázis olvasása ... Most 198785 fájl és könyvtár telepített.)
    Kicsomagolás: fglrx innen: fglrx_8.783-0ubuntu1_amd64.deb ...
    Új csomag kiválasztása: fglrx-amdcccle.
    Kicsomagolás: fglrx-amdcccle innen: fglrx-amdcccle_8.783-0ubuntu1_amd64.deb ...
    Új csomag kiválasztása: fglrx-dev.
    Kicsomagolás: fglrx-dev innen: fglrx-dev_8.783-0ubuntu1_amd64.deb ...
    Új csomag kiválasztása: fglrx-modaliases.
    Kicsomagolás: fglrx-modaliases innen: fglrx-modaliases_8.783-0ubuntu1_amd64.deb ...
    Beállítás: fglrx (2:8.783-0ubuntu1) ...
    Loading new fglrx-8.783 DKMS files...
    First Installation: checking all kernels...
    Building only for 2.6.37-020637rc1-generic
    Building for architecture amd64
    Building initial module for 2.6.37-020637rc1-generic
    Done.
    
    fglrx.ko:
    Running module version sanity check.
     - Original module
       - No original module exists within this kernel
     - Installation
       - Installing to /lib/modules/2.6.37-020637rc1-generic/kernel/drivers/char/drm/
    
    depmod....
    
    DKMS: install Completed.
    update-initramfs: deferring update (trigger activated)
    Beállítás: fglrx-modaliases (2:8.783-0ubuntu1) ...
    man-db triggereinek feldolgozása…
    ureadahead triggereinek feldolgozása…
    python-gmenu triggereinek feldolgozása…
    Rebuilding /usr/share/applications/desktop.hu_HU.utf8.cache...
    Beállítás: fglrx-amdcccle (2:8.783-0ubuntu1) ...
    Beállítás: fglrx-dev (2:8.783-0ubuntu1) ...
    initramfs-tools triggereinek feldolgozása…
    update-initramfs: Generating /boot/initrd.img-2.6.37-020637rc1-generic
    Warning: No support for locale: hu_HU.utf8
    libc-bin triggereinek feldolgozása…
    ldconfig deferred processing now taking place
    python-support triggereinek feldolgozása…
    But after that aticonfig isn't working, so I can't generate the Xorg.conf.
    Code:
    argab@argab-linux ~/Letöltések $ aticonfig
    aticonfig: a parancs nem található
    argab@argab-linux ~/Letöltések $
    "a parancs nem található" means "command not found"

    I also tried within /usr/lib/fglrx/bin, but I got this:
    Code:
    argab@argab-linux /usr/lib/fglrx/bin $ ./aticonfig --initial
    Unable to open /etc/ati/control, please reinstall the driver.
    ./aticonfig: No supported adapters detected

  2. #12
    Join Date
    Aug 2009
    Posts
    150

    Default

    aticonfig can't write to the file /etc/X11/xorg.conf as a normal user. Use sudo to run the command as root.
    Code:
    sudo ./aticonfig --initial

  3. #13
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    607

    Default

    Quote Originally Posted by Silverthorn View Post
    aticonfig can't write to the file /etc/X11/xorg.conf as a normal user. Use sudo to run the command as root.
    Code:
    sudo ./aticonfig --initial
    aticonfig might write it into your home directory but I don't know if that's enough for it to work with ubuntu ...


    it worked for me, too - so it definitely runs with 2.6.37

  4. #14
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    607

    Default

    Quote Originally Posted by kernelOfTruth View Post
    aticonfig might write it into your home directory but I don't know if that's enough for it to work with ubuntu ...


    it worked for me, too - so it definitely runs with 2.6.37
    #'!$§$! minute limit

    I meant it compiled fine for me and now I'm posting from my system running it underneath

  5. #15
    Join Date
    Nov 2010
    Location
    Ajka, Hungary
    Posts
    6

    Default

    Quote Originally Posted by Silverthorn View Post
    aticonfig can't write to the file /etc/X11/xorg.conf as a normal user. Use sudo to run the command as root.
    Code:
    sudo ./aticonfig --initial
    I know that, but it doesn't make any difference:
    Code:
    argab@argab-linux /usr/lib/fglrx/bin $ sudo ./aticonfig --initial -f
    Unable to open /etc/ati/control, please reinstall the driver.
    ./aticonfig: No supported adapters detected

  6. #16
    Join Date
    Aug 2009
    Posts
    150

    Default

    Try to remove the driver and start over. Make sure at least /etc/ati is completely removed.

  7. #17
    Join Date
    Nov 2010
    Location
    Ajka, Hungary
    Posts
    6

    Default

    Quote Originally Posted by Silverthorn View Post
    Try to remove the driver and start over. Make sure at least /etc/ati is completely removed.
    Already tried to start over, but got the same result. Although everything seems okay during the install, something is definitely wrong.
    The /usr/share/ati should contain much more than this:
    Code:
    argab@argab-linux /usr/share/ati $ ls
    amdcccle
    And I don't even have /etc/ati at all (I don't know whether it should be there in maverick or not):
    Code:
    argab@argab-linux /usr/share/ati $ cd /etc/a
    acpi/         apm/          apparmor.d/   apt/          
    alternatives/ apparmor/     apport/       avahi/

  8. #18
    Join Date
    Aug 2009
    Posts
    150

    Default

    The content of /usr/share/ati is similar to what I have with fglrx 10.4.

    The ati folder in /etc should exist though. It should have been created by the installer.

    Code:
    ls /etc/ati/
    amdpcsdb          atiogl.xml         control                logo.xbm.example
    amdpcsdb.default  authatieventsd.sh  logo_mask.xbm.example  signature

  9. #19
    Join Date
    Nov 2010
    Posts
    17

    Default

    I managed to install the kernel module.
    I used .deb packets from Ubuntu Maverick repositories (packets to other distros can be generated by running the fglrx installer with parameter --buildpkg).

    I tried to install the generated packages (apt-get install fglrx fglrx-amdcccle), which failed. So I opened /var/lib/dkms/fglrx/8.780/source/firegl_public.c and applied manually the three patches from this thread. Then I configured the packages with dpkg, did 'aticonfig --initial -f', and restarted the comp.

    When Xorg started, the screen went all black, and remained so, however there wasn't a Kernel panic or Xorg segfault. It was possible to shut down the computer using the power button.

  10. #20
    Join Date
    Nov 2010
    Posts
    17

    Default

    So probably Your patches are not enough.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •