Results 1 to 5 of 5

Thread: Forcing a resolution when no TV is connected

  1. #1
    Join Date
    Aug 2010
    Posts
    58

    Default Forcing a resolution when no TV is connected

    Hello,

    I am trying to configure the xorg.conf so I can force a resolution when the HTPC server is booted without any output connected to it (TV off).
    I am trying to force the TV (HDMI1) to be 1280x720 but I get this error "(WW) intel(0): Unable to find connected outputs - setting 1024x768 initial framebuffer"

    Kernel: 2.6.35-22
    Linux Intel drivers: 2.12.0

    Here is my Xorg.conf:
    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "TV"
    EndSection

    Section "Device"
    Identifier "Intel HD Graphics"
    Driver "intel"
    BusID "PCI:0:2:0"

    Option "monitor-VGA1" "none"
    Option "monitor-DP1" "none"
    Option "monitor-HDMI1" "none"
    Option "monitor-HDMI2" "TSB-TV"

    Option "ModeDebug" "true"
    EndSection

    Section "Monitor"
    Identifier "TSB-TV"
    VendorName "Toshiba"
    ModelName "42WLG66"
    HorizSync 15.0 - 46.0
    VertRefresh 49.0 - 122.0
    # Modeline "1920x1080i" 74.25 1920 2448 2492 2640 1080 1084 1094 1125 interlace +hsync +vsync
    # Modeline "1368x768_60.00" 85.86 1368 1440 1584 1800 768 769 772 795 -HSync +Vsync
    Modeline "1280x720_50.0" 74.25 1280 1720 1760 1980 720 725 730 750 +hsync +vsync
    # Option "PreferredMode" "1280x720_50"
    EndSection

    Section "Monitor"
    Identifier "none"
    Option "Ignore" "true"
    EndSection

    Section "Screen"
    Identifier "TV"
    Device "Intel HD Graphics"
    Monitor "TSB-TV"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1280x720_50.0"
    EndSubSection
    EndSection
    Here is my Xorg.log:
    Code:
    xabix@xabix-desktop:~$ cat /var/log/Xorg.0.log 
    [    35.878] 
    X.Org X Server 1.9.0
    Release Date: 2010-08-20
    [    35.878] X Protocol Version 11, Revision 0
    [    35.878] Build Operating System: Linux 2.6.24-27-server x86_64 Ubuntu
    [    35.878] Current Operating System: Linux xabix-desktop 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:32:27 UTC 2010 x86_64
    [    35.878] Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.35-22-generic root=UUID=0785fb3c-6674-41e4-a48e-73c3a8c7ed25 ro vga=791 quiet splash
    [    35.878] Build Date: 16 September 2010  06:18:41PM
    [    35.878] xorg-server 2:1.9.0-0ubuntu7 (For technical support please see http://www.ubuntu.com/support) 
    [    35.878] Current version of pixman: 0.18.4
    [    35.878]    Before reporting problems, check http://wiki.x.org
            to make sure that you have the latest version.
    [    35.878] Markers: (--) probed, (**) from config file, (==) default setting,
            (++) from command line, (!!) notice, (II) informational,
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [    35.878] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Oct 11 22:02:21 2010
    [    35.879] (==) Using config file: "/etc/X11/xorg.conf"
    [    35.879] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [    35.879] (==) ServerLayout "Default Layout"
    [    35.879] (**) |-->Screen "TV" (0)
    [    35.879] (**) |   |-->Monitor "TSB-TV"
    [    35.879] (**) |   |-->Device "Intel HD Graphics"
    [    35.879] (==) Automatically adding devices
    [    35.879] (==) Automatically enabling devices
    [    35.880] (==) FontPath set to:
            /usr/share/fonts/X11/misc,
            /usr/share/fonts/X11/cyrillic,
            /usr/share/fonts/X11/100dpi/:unscaled,
            /usr/share/fonts/X11/75dpi/:unscaled,
            /usr/share/fonts/X11/Type1,
            /usr/share/fonts/X11/100dpi,
            /usr/share/fonts/X11/75dpi,
            /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
            built-ins
    [    35.880] (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
    [    35.880] (II) The server relies on udev to provide the list of input devices.
            If no devices become available, reconfigure udev or disable AutoAddDevices.
    [    35.880] (II) Loader magic: 0x7d0200
    [    35.880] (II) Module ABI versions:
    [    35.880]    X.Org ANSI C Emulation: 0.4
    [    35.880]    X.Org Video Driver: 8.0
    [    35.880]    X.Org XInput driver : 11.0
    [    35.880]    X.Org Server Extension : 4.0
    [    35.880] (--) PCI:*(0:0:2:0) 8086:0042:1458:d000 rev 18, Mem @ 0xfb400000/4194304, 0xe0000000/268435456, I/O @ 0x0000ff00/8
    [    35.881] (--) PCI: (0:4:0:0) 14f1:8852:d470:9022 rev 2, Mem @ 0xfb800000/2097152
    [    35.881] (II) Open ACPI successful (/var/run/acpid.socket)
    [    35.881] (II) LoadModule: "extmod"
    [    35.881] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
    [    35.881] (II) Module extmod: vendor="X.Org Foundation"
    [    35.882]    compiled for 1.9.0, module version = 1.0.0
    [    35.882]    Module class: X.Org Server Extension
    [    35.882]    ABI class: X.Org Server Extension, version 4.0
    [    35.882] (II) Loading extension MIT-SCREEN-SAVER
    [    35.882] (II) Loading extension XFree86-VidModeExtension
    [    35.882] (II) Loading extension XFree86-DGA
    [    35.882] (II) Loading extension DPMS
    [    35.882] (II) Loading extension XVideo
    [    35.882] (II) Loading extension XVideo-MotionCompensation
    [    35.882] (II) Loading extension X-Resource
    [    35.882] (II) LoadModule: "dbe"
    [    35.882] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
    [    35.882] (II) Module dbe: vendor="X.Org Foundation"
    [    35.882]    compiled for 1.9.0, module version = 1.0.0
    [    35.882]    Module class: X.Org Server Extension
    [    35.882]    ABI class: X.Org Server Extension, version 4.0
    [    35.882] (II) Loading extension DOUBLE-BUFFER
    [    35.882] (II) LoadModule: "glx"
    [    35.882] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    [    35.882] (II) Module glx: vendor="X.Org Foundation"
    [    35.882]    compiled for 1.9.0, module version = 1.0.0
    [    35.882]    ABI class: X.Org Server Extension, version 4.0
    [    35.882] (==) AIGLX enabled
    [    35.882] (II) Loading extension GLX
    [    35.882] (II) LoadModule: "record"
    [    35.882] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
    [    35.882] (II) Module record: vendor="X.Org Foundation"
    [    35.882]    compiled for 1.9.0, module version = 1.13.0
    [    35.882]    Module class: X.Org Server Extension
    [    35.882]    ABI class: X.Org Server Extension, version 4.0
    [    35.882] (II) Loading extension RECORD
    [    35.882] (II) LoadModule: "dri"
    [    35.883] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
    [    35.883] (II) Module dri: vendor="X.Org Foundation"
    [    35.883]    compiled for 1.9.0, module version = 1.0.0
    [    35.883]    ABI class: X.Org Server Extension, version 4.0
    [    35.883] (II) Loading extension XFree86-DRI
    [    35.883] (II) LoadModule: "dri2"
    [    35.883] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
    [    35.883] (II) Module dri2: vendor="X.Org Foundation"
    [    35.883]    compiled for 1.9.0, module version = 1.2.0
    [    35.883]    ABI class: X.Org Server Extension, version 4.0
    [    35.883] (II) Loading extension DRI2
    [    35.883] (II) LoadModule: "intel"
    [    35.883] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
    [    35.883] (II) Module intel: vendor="X.Org Foundation"
    [    35.883]    compiled for 1.9.0, module version = 2.12.0
    [    35.883]    Module class: X.Org Video Driver
    [    35.883]    ABI class: X.Org Video Driver, version 8.0
    [    35.883] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
            i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
            E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
            965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
            4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
            Sandybridge, Sandybridge, Sandybridge, Sandybridge, Sandybridge,
            Sandybridge, Sandybridge
    [    35.884] (++) using VT number 7
    
    [    35.886] drmOpenDevice: node name is /dev/dri/card0
    [    35.886] drmOpenDevice: open result is 9, (OK)
    [    35.888] drmOpenByBusid: Searching for BusID pci:0000:00:02.0
    [    35.888] drmOpenDevice: node name is /dev/dri/card0
    [    35.888] drmOpenDevice: open result is 9, (OK)
    [    35.888] drmOpenByBusid: drmOpenMinor returns 9
    [    35.888] drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
    [    35.888] (**) intel(0): Depth 24, (--) framebuffer bpp 32
    [    35.888] (==) intel(0): RGB weight 888
    [    35.888] (==) intel(0): Default visual is TrueColor
    [    35.888] (II) intel(0): Integrated Graphics Chipset: Intel(R) Clarkdale
    [    35.888] (--) intel(0): Chipset: "Clarkdale"
    [    35.888] (==) intel(0): video overlay key set to 0x101fe
    [    35.905] (II) intel(0): Output VGA1 using monitor section none
    [    35.905] (**) intel(0): Option "Ignore" "true"
    [    35.915] (II) intel(0): Output HDMI1 using monitor section none
    [    35.920] (II) intel(0): Output DP1 using monitor section none
    [    35.929] (II) intel(0): Output HDMI2 using monitor section TSB-TV
    [    35.938] (II) intel(0): Output HDMI3 has no monitor section
    [    35.943] (II) intel(0): Output DP2 has no monitor section
    [    35.948] (II) intel(0): Output DP3 has no monitor section
    [    35.948] (**) intel(0): Option "ModeDebug" "true"
    [    35.957] (II) intel(0): EDID for output HDMI2
    [    35.966] (II) intel(0): EDID for output HDMI3
    [    35.971] (II) intel(0): EDID for output DP2
    [    35.977] (II) intel(0): EDID for output DP3
    [    35.977] (II) intel(0): Output HDMI2 disconnected
    [    35.977] (II) intel(0): Output HDMI3 disconnected
    [    35.977] (II) intel(0): Output DP2 disconnected
    [    35.977] (II) intel(0): Output DP3 disconnected
    [    35.977] (WW) intel(0): No outputs definitely connected, trying again...
    [    35.977] (II) intel(0): Output HDMI2 disconnected
    [    35.977] (II) intel(0): Output HDMI3 disconnected
    [    35.977] (II) intel(0): Output DP2 disconnected
    [    35.977] (II) intel(0): Output DP3 disconnected
    [    35.977] (WW) intel(0): Unable to find connected outputs - setting 1024x768 initial framebuffer
    [    35.977] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
    [    35.977] (II) intel(0): Kernel page flipping support detected, but forcibly disabled.
    [    35.977] (==) intel(0): DPI set to (96, 96)
    [    35.977] (II) Loading sub module "fb"
    [    35.977] (II) LoadModule: "fb"
    [    35.977] (II) Loading /usr/lib/xorg/modules/libfb.so
    [    35.977] (II) Module fb: vendor="X.Org Foundation"
    [    35.977]    compiled for 1.9.0, module version = 1.0.0
    [    35.977]    ABI class: X.Org ANSI C Emulation, version 0.4
    [    35.977] (==) Depth 24 pixmap format is 32 bpp
    [    35.977] (II) intel(0): [DRI2] Setup complete
    [    35.977] (II) intel(0): [DRI2]   DRI driver: i965
    [    35.977] (**) intel(0): Tiling enabled
    [    35.977] (**) intel(0): SwapBuffers wait enabled
    [    35.977] (==) intel(0): VideoRam: 262144 KB
    [    35.977] (II) intel(0): Allocated new frame buffer 1024x768 stride 4096, tiled
    [    35.982] (II) UXA(0): Driver registered support for the following operations:
    [    35.982] (II)         solid
    [    35.982] (II)         copy
    [    35.982] (II)         composite (RENDER acceleration)
    [    35.982] (II)         put_image
    [    35.982] (II)         get_image
    [    35.982] (==) intel(0): Backing store disabled
    [    35.982] (==) intel(0): Silken mouse enabled
    [    35.982] (II) intel(0): Initializing HW Cursor
    [    35.982] (EE) intel(0): Couldn't create pixmap for fbcon
    [    35.982] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
    [    35.983] (==) intel(0): DPMS enabled
    [    35.983] (==) intel(0): Intel XvMC decoder enabled
    [    35.983] (II) intel(0): Set up textured video
    [    35.983] (II) intel(0): [XvMC] xvmc_vld driver initialized.
    [    35.983] (II) intel(0): direct rendering: DRI2 Enabled
    [    35.983] (--) RandR disabled
    [    35.983] (II) Initializing built-in extension Generic Event Extension
    [    35.983] (II) Initializing built-in extension SHAPE
    [    35.983] (II) Initializing built-in extension MIT-SHM
    [    35.983] (II) Initializing built-in extension XInputExtension
    [    35.983] (II) Initializing built-in extension XTEST
    [    35.983] (II) Initializing built-in extension BIG-REQUESTS
    [    35.983] (II) Initializing built-in extension SYNC
    [    35.983] (II) Initializing built-in extension XKEYBOARD
    [    35.983] (II) Initializing built-in extension XC-MISC
    [    35.983] (II) Initializing built-in extension SECURITY
    [    35.983] (II) Initializing built-in extension XINERAMA
    [    35.983] (II) Initializing built-in extension XFIXES
    [    35.983] (II) Initializing built-in extension RENDER
    [    35.983] (II) Initializing built-in extension RANDR
    [    35.983] (II) Initializing built-in extension COMPOSITE
    [    35.983] (II) Initializing built-in extension DAMAGE
    [    35.983] (II) Initializing built-in extension GESTURE
    [    35.989] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
    [    35.989] (II) AIGLX: enabled GLX_INTEL_swap_event
    [    35.989] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
    [    35.989] (II) AIGLX: enabled GLX_SGI_make_current_read
    [    35.989] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
    [    35.989] (II) AIGLX: Loaded and initialized /usr/lib/dri/i965_dri.so
    [    35.989] (II) GLX: Initialized DRI2 GL provider for screen 0
    [    36.003] (II) XKB: reuse xkmfile /var/lib/xkb/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm
    [    36.008] (II) config/udev: Adding input device Power Button (/dev/input/event1)
    [    36.008] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [    36.008] (II) LoadModule: "evdev"
    [    36.008] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
    [    36.009] (II) Module evdev: vendor="X.Org Foundation"
    [    36.009]    compiled for 1.9.0, module version = 2.3.2
    [    36.009]    Module class: X.Org XInput Driver
    [    36.009]    ABI class: X.Org XInput driver, version 11.0
    [    36.009] (**) Power Button: always reports core events
    [    36.009] (**) Power Button: Device: "/dev/input/event1"
    [    36.030] (II) Power Button: Found keys
    [    36.030] (II) Power Button: Configuring as keyboard
    [    36.030] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
    [    36.030] (**) Option "xkb_rules" "evdev"
    [    36.030] (**) Option "xkb_model" "evdev"
    [    36.030] (**) Option "xkb_layout" "fr"
    [    36.032] (II) XKB: reuse xkmfile /var/lib/xkb/server-1773A72ADF3912178EB836318CC241E672AD6AB1.xkm
    [    36.033] (II) config/udev: Adding input device Power Button (/dev/input/event0)
    [    36.033] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [    36.033] (**) Power Button: always reports core events
    [    36.033] (**) Power Button: Device: "/dev/input/event0"
    [    36.051] (II) Power Button: Found keys
    [    36.051] (II) Power Button: Configuring as keyboard
    [    36.051] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
    [    36.051] (**) Option "xkb_rules" "evdev"
    [    36.051] (**) Option "xkb_model" "evdev"
    [    36.051] (**) Option "xkb_layout" "fr"
    [    36.054] (II) config/udev: Adding input device Dell Dell USB Keyboard (/dev/input/event2)
    [    36.054] (**) Dell Dell USB Keyboard: Applying InputClass "evdev keyboard catchall"
    [    36.054] (**) Dell Dell USB Keyboard: always reports core events
    [    36.054] (**) Dell Dell USB Keyboard: Device: "/dev/input/event2"
    [    36.092] (II) Dell Dell USB Keyboard: Found keys
    [    36.092] (II) Dell Dell USB Keyboard: Configuring as keyboard
    [    36.092] (II) XINPUT: Adding extended input device "Dell Dell USB Keyboard" (type: KEYBOARD)
    [    36.092] (**) Option "xkb_rules" "evdev"
    [    36.092] (**) Option "xkb_model" "evdev"
    [    36.092] (**) Option "xkb_layout" "fr"
    [    36.092] (II) config/udev: Adding input device iMON Remote (15c2:0038) (/dev/input/event3)
    [    36.092] (**) iMON Remote (15c2:0038): Applying InputClass "evdev pointer catchall"
    [    36.092] (**) iMON Remote (15c2:0038): Applying InputClass "evdev keyboard catchall"
    [    36.092] (**) iMON Remote (15c2:0038): always reports core events
    [    36.092] (**) iMON Remote (15c2:0038): Device: "/dev/input/event3"
    [    36.120] (II) iMON Remote (15c2:0038): Found 3 mouse buttons
    [    36.120] (II) iMON Remote (15c2:0038): Found scroll wheel(s)
    [    36.120] (II) iMON Remote (15c2:0038): Found relative axes
    [    36.120] (II) iMON Remote (15c2:0038): Found x and y relative axes
    [    36.120] (II) iMON Remote (15c2:0038): Found keys
    [    36.120] (II) iMON Remote (15c2:0038): Configuring as mouse
    [    36.120] (II) iMON Remote (15c2:0038): Configuring as keyboard
    [    36.120] (**) iMON Remote (15c2:0038): YAxisMapping: buttons 4 and 5
    [    36.120] (**) iMON Remote (15c2:0038): EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    [    36.120] (II) XINPUT: Adding extended input device "iMON Remote (15c2:0038)" (type: KEYBOARD)
    [    36.120] (**) Option "xkb_rules" "evdev"
    [    36.120] (**) Option "xkb_model" "evdev"
    [    36.120] (**) Option "xkb_layout" "fr"
    [    36.120] (II) iMON Remote (15c2:0038): initialized for relative axes.
    [    36.121] (II) config/udev: Adding input device iMON Remote (15c2:0038) (/dev/input/mouse0)
    [    36.121] (II) No input driver/identifier specified (ignoring)
    [    36.122] (II) config/udev: Adding input device IR-receiver inside an USB DVB receiver (/dev/input/event4)
    [    36.122] (**) IR-receiver inside an USB DVB receiver: Applying InputClass "evdev keyboard catchall"
    [    36.122] (**) IR-receiver inside an USB DVB receiver: always reports core events
    [    36.122] (**) IR-receiver inside an USB DVB receiver: Device: "/dev/input/event4"
    [    36.160] (II) IR-receiver inside an USB DVB receiver: Found keys
    [    36.160] (II) IR-receiver inside an USB DVB receiver: Configuring as keyboard
    [    36.160] (II) XINPUT: Adding extended input device "IR-receiver inside an USB DVB receiver" (type: KEYBOARD)
    [    36.160] (**) Option "xkb_rules" "evdev"
    [    36.160] (**) Option "xkb_model" "evdev"
    [    36.160] (**) Option "xkb_layout" "fr"
    [    36.471] (II) intel(0): EDID for output HDMI2
    [    36.480] (II) intel(0): EDID for output HDMI3
    [    36.485] (II) intel(0): EDID for output DP2
    [    36.490] (II) intel(0): EDID for output DP3
    [    36.501] (II) intel(0): EDID for output HDMI2
    [    36.510] (II) intel(0): EDID for output HDMI3
    [    36.515] (II) intel(0): EDID for output DP2
    [    36.520] (II) intel(0): EDID for output DP3
    [    36.530] (II) intel(0): EDID for output HDMI2
    [    36.539] (II) intel(0): EDID for output HDMI3
    [    36.544] (II) intel(0): EDID for output DP2
    [    36.549] (II) intel(0): EDID for output DP3
    [    42.073] (II) intel(0): EDID for output HDMI2
    [    42.082] (II) intel(0): EDID for output HDMI3
    [    42.087] (II) intel(0): EDID for output DP2
    [    42.092] (II) intel(0): EDID for output DP3
    [   164.354] (II) intel(0): EDID for output HDMI2
    [   164.363] (II) intel(0): EDID for output HDMI3
    [   164.368] (II) intel(0): EDID for output DP2
    [   164.373] (II) intel(0): EDID for output DP3
    Through VNC, xrandr confirms that my resolution is 1024x768:
    Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
    HDMI2 disconnected (normal left inverted right x axis y axis)
    HDMI3 disconnected (normal left inverted right x axis y axis)
    DP2 disconnected (normal left inverted right x axis y axis)
    DP3 disconnected (normal left inverted right x axis y axis)
    Any idea? I have googled, search on intel linux website and forums but didn't find the missing entry in my xorg.conf.

    Thanks
    XabiX

  2. #2
    Join Date
    Feb 2009
    Posts
    7

  3. #3
    Join Date
    Aug 2010
    Posts
    58

    Default

    Quote Originally Posted by marriouss View Post
    I tried this but it doesn't work:

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "TV"
    EndSection

    Section "Device"
    Identifier "Intel HD Graphics"
    Driver "intel"
    BusID "PCI:0:2:0"
    Option "monitor-VGA1" "none"
    Option "monitor-DP1" "none"
    Option "monitor-HDMI1" "none"
    Option "monitor-HDMI2" "SNY-TV"
    Option "ModeDebug" "true"
    EndSection

    Section "Monitor"
    Identifier "SNY-TV"
    VendorName "Sony"
    ModelName "46EX500"
    Modeline "1920x1080" 148.50 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
    Option "PreferredMode" "1920x1080"
    EndSection

    Section "Monitor"
    Identifier "none"
    Option "Ignore" "true"
    EndSection

    Section "Screen"
    Identifier "TV"
    Device "Intel HD Graphics"
    Monitor "SNY-TV"
    Option "ConnectedMonitor" "SNY-TV"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1920x1080"
    EndSubSection
    EndSection
    the output:
    [ 7.616] (WW) intel(0): No outputs definitely connected, trying again...
    [ 7.616] (WW) intel(0): Unable to find connected outputs - setting 1024x768 initial framebuffer
    [ 7.622] (WW) intel(0): Option "PreferredMode" is not used
    [ 7.622] (WW) intel(0): Option "ConnectedMonitor" is not used
    Any other idea?

    Thanks
    XabiX

  4. #4
    Join Date
    Aug 2010
    Posts
    58

    Default

    It's working with:
    Option "enable" "true"
    Modeline "1920x1080" 148.50 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync

    In Monitor section

    Thanks

  5. #5
    Join Date
    Aug 2010
    Posts
    58

    Default [SOLVED] Forcing a resolution when no TV is connected

    FYI my xorg.conf:

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "TV"
    EndSection

    Section "Device"
    Identifier "Intel HD Graphics"
    Driver "intel"
    BusID "PCI:0:2:0"
    Option "monitor-VGA1" "none"
    Option "monitor-DP1" "none"
    Option "monitor-HDMI1" "none"
    Option "monitor-HDMI2" "SNY-TV"
    Option "ModeDebug" "true"
    EndSection

    Section "Monitor"
    Identifier "SNY-TV"
    VendorName "Sony"
    ModelName "46EX500"
    Option "enable" "true"
    Modeline "1920x1080" 148.50 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
    EndSection

    Section "Monitor"
    Identifier "none"
    Option "Ignore" "true"
    EndSection

    Section "Screen"
    Identifier "TV"
    Device "Intel HD Graphics"
    Monitor "SNY-TV"
    Option "ConnectedMonitor" "SNY-TV"
    SubSection "Display"
    Depth 24
    Modes "1920x1080"
    EndSubSection
    EndSection

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •