Results 1 to 5 of 5

Thread: Xserver segfaults with catalyst

  1. #1
    Join Date
    Nov 2010
    Posts
    2

    Default Xserver segfaults with catalyst

    Hello everyone,
    I have a strange problem on my Dell Studio 1558 notebook which unfortunately has an ATI graphics card. I'm using ArchLinux 64 Bit.
    The problem is that Xserver won't start when I use the catalyst driver. It will just segfault...
    I searched almost the complete web. Well, this problem occurs quite often, it seems. But none of the solutions work for me.
    People write that it helps to use "aticonfig --initial" or "aticonfig --initial --force" to create the xorg.conf for fglrx.
    After doing this the Xserver will still segfault.
    Another solution was to put the BUS Id into the config file. It was already there and is correct. So there is no way for me to fix that problem.
    Until today I could always use catalyst 10.5 on Xserver 1.7. Every version starting from 10.6 would crash. Today I wanted to try the latest catalyst driver again but no luck. When I installed the 10.5 package i saved on my disk it could not be installed because of a dependency kernel26<2.6.36
    I modified the PKGBUILD to convince the package to build but no success, there was a message on the terminal that "linux/autoconf.h" was not found.
    But I don't want 10.5 to work, I want the current drivers to work.
    Xorg.0.log after a segfault
    Xorg.conf
    I would be very happy if someone could help me to get the catalyst driver working. The open source drivers work but they have a rather bad power management

  2. #2
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by McFlow View Post
    Hello everyone,
    I have a strange problem on my Dell Studio 1558 notebook which unfortunately has an ATI graphics card. I'm using ArchLinux 64 Bit.
    The problem is that Xserver won't start when I use the catalyst driver. It will just segfault...
    I searched almost the complete web. Well, this problem occurs quite often, it seems. But none of the solutions work for me.
    People write that it helps to use "aticonfig --initial" or "aticonfig --initial --force" to create the xorg.conf for fglrx.
    After doing this the Xserver will still segfault.
    Another solution was to put the BUS Id into the config file. It was already there and is correct. So there is no way for me to fix that problem.
    Until today I could always use catalyst 10.5 on Xserver 1.7. Every version starting from 10.6 would crash. Today I wanted to try the latest catalyst driver again but no luck. When I installed the 10.5 package i saved on my disk it could not be installed because of a dependency kernel26<2.6.36
    I modified the PKGBUILD to convince the package to build but no success, there was a message on the terminal that "linux/autoconf.h" was not found.
    But I don't want 10.5 to work, I want the current drivers to work.
    Xorg.0.log after a segfault
    Xorg.conf
    I would be very happy if someone could help me to get the catalyst driver working. The open source drivers work but they have a rather bad power management
    do you ever install the driver without build packages first ?

    in this forum some people had problems on packages and the direct install works.

  3. #3
    Join Date
    Feb 2009
    Location
    Finland
    Posts
    46

    Default

    Are u using the catalyst repository? If not I can just highly recommend u to use it, it's (almost) totally pain free.
    Here a link to the wiki with more infos:
    https://wiki.archlinux.org/index.php...s_repositories

    I'm running Arch64 with stock kernel26 and the recent catalyst driver from the repo, works without any problem! My machine is a Thinkpad T500 with a Mobility Radeon HD 3650.
    Here my installed packages:
    [core]
    kernel26 2.6.35.8-1
    [extra]
    xorg-server 1.9.2-1
    [catalyst]
    catalyst 10.11-1
    catalyst-utils 10.11-1
    lib32-catalyst-utils 10.11-1
    xvba-video 0.7.6-1

    U enable the repo by adding the following to lines to your "/etc/pacman.conf":
    [catalyst]
    Server = http://catalyst.apocalypsus.net/repo/catalyst/x86_64

    Before u install the catalyst packages u should remove all the old/ self-compiled ones. In your case I would also remove "/etc/X11/xorg.conf" and the whole folder "/etc/ati/".

    After installing the new catalyst just run "aticonfig --initial" and everything should work.

    Cheers,
    Armin

    P.S.: It's of advantage to do the removing/ installing of the catalyst packages in runlevel 3, i.e. no x-server running.
    You get to runlevel 3 with "sudo init 3", afterwards reboot.

  4. #4
    Join Date
    Feb 2009
    Location
    Finland
    Posts
    46

    Default

    OK, by reading your post and the Xorg.log a bit more carefully I realized u are running xorg-server 1.7.5.1. It seams like u install the catalyst driver somewhat by hand, since you obviously use the right modules ("compiled for 1.7.5.1") and the PKGBUILD from AUR use different ones ("compiled for 1.9.2").

    How do u install the catalyst driver?

    I think u should give the stock xorg-server (1.9) and the catalyst from the repo (or via PKGBUILD from AUR, which is actually the same) a try. Be careful, the PKGBUILD and the repo both need xorg-server 1.9!

    Anyhow, in my opinion, there is anyhow no reason to run a different xorg-server.

    I also saw u are using kernel 2.6.34. I don't know why u are using such a intermediate kernel version (kernel26=2.6.35.8 or kernel26-lts=2.6.32.26), but as mentioned before a stock kernel26 and xorg-server works fine here.

  5. #5
    Join Date
    Nov 2010
    Posts
    2

    Default

    Thanks for your reply Armin!

    I have no idea why there are old version information in the logs.
    Pacman says:
    core/kernel26: 2.6.36.1-3
    extra/xorg-server: 1.9.2-2

    Maybe I took an old log...
    As the approach without building a package first had no success, I gave another try to using all recent packages.
    Now installed packages are:
    catalyst/catalyst 10.11-2
    catalyst/catalyst-utils 10.11-1
    catalyst/lib32-catalyst-utils 10.11-1
    catalyst/xvba-video 0.7.6-1
    core/kernel26 2.6.36.1-3
    extra/xorg-server 1.9.2-2

    The differneces to my previous tries were:
    I chose runlevel 3 (before I just killed xserver), i completely removed everything related to ATI (before I missed /etc/ati

    It works now. Thank you very much!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •