Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Post your working kernel .config & xorg.conf for git drm-radeon-testing & xorg

  1. #11
    Join Date
    Jul 2008
    Location
    Berlin, Germany
    Posts
    790

    Default

    Your kernel firmware configuration seems different from http://wiki.x.org/wiki/radeonBuildHo...BAC8-Evergreen
    Try to copy it verbatim into your kernel config. Or at least make sure that they are actually equivalent.

  2. #12
    Join Date
    Oct 2009
    Posts
    68

    Smile

    Quote Originally Posted by charlie View Post
    Post a link to your working kernel .config & xorg.conf (no checklist of what I need to type"y" to) for git drm-radeon-testing & git xorg.
    http://blacktower.cjb.net/secret/ker....6.37-rc4-git1
    http://blacktower.cjb.net/secret/xorg.conf

    I build the evil binary blob firmware into the kernel,

    CONFIG_EXTRA_FIRMWARE="radeon/R600_rlc.bin radeon/RS780_pfp.bin radeon/RS780_me.bin"

    so make sure you have these evil binary blobs in your /lib/firmware. I could scp those too there but you generally want to grab such blobs from a more safe source than some random long-haried hippie on the internets.

    you can put the blobs in initrd or whatever instead, I just push'it into the kernel and it's there and it works.

  3. #13
    Join Date
    Nov 2008
    Posts
    55

    Default

    Thanks guys. I'll try your configs and suggestions out. I know there is one option in my kernel config that is causing opengl to segfault (I only fixed the segfault by reverting to an older config). It will probably take at least 10 recompiles to determine which new kernel feature mesa needs or causes interference.

  4. #14
    Join Date
    Nov 2008
    Posts
    55

    Default

    For others out there troubleshooting opengl is required for flash content to display fullscreen.

    I have not determined the exact kernel requirement to get rid of this message yet (displays after running glxgears):

    IRQ's not enabled, falling back to busy waits: 2 0

  5. #15
    Join Date
    Nov 2008
    Posts
    55

    Default

    Kernel modesetting works now by changing (kernel .config):

    (R600_rlc.bin RV670_me.bin RV670_pfp.bin) External firmware blobs to build into the kernel binary

    (firmware/radeon) Firmware blobs root directory
    to:

    (radeon/R600_rlc.bin radeon/RV670_me.bin radeon/RV670_pfp.bin) External firmware blobs to build into the kernel binary

    (/lib/firmware) Firmware blobs root directory
    Modesetting enabled also makes those "IRQ's not enabled, falling back to busy waits: 2 0" messages disappear.

    Also Kwin would not allow me to use opengl desktop rendering until I deleted the ~/.kde and ~/.kde4 directories or create a new user.

    Everything appears to be working. I will continue to recompile the kernels to find out what options are really required for drm-radeon-testing and what caused the initial segfaults.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •