Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 46

Thread: kwin discontinued ?

  1. #21
    Join Date
    Jun 2009
    Posts
    2,929

    Default

    Quote Originally Posted by bridgman View Post
    So is the idea that forcing indirect rendering was an "indirect" way of hiding GL 2-level functionality from kwin and forcing it to use the older code paths ?
    That's how I understood it, yes. But don't take this as a fact, as I'm wrong about 75% of the time

  2. #22
    Join Date
    Dec 2007
    Posts
    2,372

    Default

    Quote Originally Posted by ntt2010 View Post
    I think the ATI open source r300/r600 driver developers have focused on 3D games like openarena, but haven't paid attention to other non-3D opengl applications. Not just kwin suffers horrible performance. On my AMD 760G integrated chipset, XBMC also suffers greatly. The XBMC built-in software video renderer is much (twice) faster than its advanced shader (GLS ) or basic shader (ARB?) video renderers. It's pretty frustrating.
    If you are having problems with a certain app, please file bugs. We can't fix bugs we don't know about. Open source development is a two way street. A lot of application developers write their apps against 1 or 2 closed source drivers and never test the open drivers. GL is a huge API and it's hard to fully test all of it; just because something works one way on one driver, doesn't mean it will on all drivers. We'll do our best to fix any bugs that get reported.

  3. #23
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,795

    Default

    Quote Originally Posted by pedepy View Post
    have they pulled the plug on kwin ? i mean, are developers not actively working on it anymore?
    Yes. KWin has been deprecated and KDE will ship without a window manager in the future.

  4. #24
    Join Date
    Oct 2010
    Posts
    25

    Default

    Quote Originally Posted by agd5f View Post
    If you are having problems with a certain app, please file bugs. We can't fix bugs we don't know about. Open source development is a two way street. A lot of application developers write their apps against 1 or 2 closed source drivers and never test the open drivers. GL is a huge API and it's hard to fully test all of it; just because something works one way on one driver, doesn't mean it will on all drivers. We'll do our best to fix any bugs that get reported.
    Thanks. I'll try to do just that.

    BTW, I don't know if I compare apple and orange with respect to software vs GLSL video renderers in XBMC. My CPU speed is a 2.5GHz AMD Athlon 64 while my AMD 760G graphic card speed is set to only 200Mhz in the BIOS.

    If I use fglrx, XBMC GLSL video renderer plays movies at full speed (24fps) but if I use r600g, XBMC GLSL video renderer plays at 15-20fps. My TV is at 1080p.

  5. #25
    Join Date
    Dec 2007
    Posts
    2,372

    Default

    Quote Originally Posted by ntt2010 View Post
    If I use fglrx, XBMC GLSL video renderer plays movies at full speed (24fps) but if I use r600g, XBMC GLSL video renderer plays at 15-20fps. My TV is at 1080p.
    We are working to improve the performance of the open source driver, but at the moment we can't match fglrx.

  6. #26
    Join Date
    Jan 2008
    Location
    Have a good day.
    Posts
    678

    Default

    Quote Originally Posted by pingufunkybeat View Post
    In any case, KWin is not the fastest compositing 3d manager out there. People who really need top performance should continue to use Compiz with KDE, like they do with Gnome. It works just fine. For me, KWin works just fine (but I'm not experiencing the problems the OP is, the last KWin issue was about a month ago for me).
    Not the best of worlds, is it? And what sort of twisted language is that? It's not like there are Professional Composite Desktop users who really need top performance. Everybody deserves a smooth desktop experience in 2010. Then, Compiz integration in KDE is less than perfect, and Compiz itself is not half the window manager KWin is. For once, the KDE team could fix their damn stuff instead of complaining about whatever or bringing the next bling thing that'll break your desktop in unexpected colourful ways.

    KWin works perfect here too--only because I don't activate desktop effects.

  7. #27
    Join Date
    Jun 2009
    Posts
    2,929

    Default

    The KWin people happily accept performance patches

  8. #28
    Join Date
    Jan 2008
    Location
    Have a good day.
    Posts
    678

    Default

    Quote Originally Posted by pingufunkybeat View Post
    The KWin people happily accept performance patches
    Ehhh...I'm not absolutely sure about that. Have you looked at the bug report mentioned in this thread? (https://bugs.freedesktop.org/show_bug.cgi?id=31499) Right, that's not a patch, but this Stellard guy gave some pointers towards solving the problem. Some sort of response from Kwin's people would be nice. But hey, everybody knows the drivers are broken and it's all somebody else fault : P

  9. #29
    Join Date
    Oct 2007
    Posts
    94

    Default

    Quote Originally Posted by agd5f View Post
    Why do you say that? r300g is still seeing regular updates and improvements. It would also help if the kwin developers actually tested their code on non-nvidia hardware and filed bugs for problems rather than just blaming the drivers, but I digress...

    you're not "disgressing", that's exactly the topic of the thread i started


    brigdman: i am running r300g; says so in glxinfo.

    RealNC: I knew it !!!1


    since this thread as gotten all over the place, i suppose i may just ask this here without creating a new one: i'm trying to run a game that's asking for "s3tc" software compression. the mesa page says to use a 3rd party library, but the link to the source for the lib is dead. then i found out you could "enable" s3tc using driconf, but i think that's only for r300c. it doesnt look like it's working in r300g anyway; i have all options set to enable s3tc, and the game is still complaining that it can't find the extention.

  10. #30
    Join Date
    Oct 2007
    Location
    Under the bridge
    Posts
    2,146

    Default

    Quote Originally Posted by pedepy View Post
    since this thread as gotten all over the place, i suppose i may just ask this here without creating a new one: i'm trying to run a game that's asking for "s3tc" software compression. the mesa page says to use a 3rd party library, but the link to the source for the lib is dead. then i found out you could "enable" s3tc using driconf, but i think that's only for r300c. it doesnt look like it's working in r300g anyway; i have all options set to enable s3tc, and the game is still complaining that it can't find the extention.
    Welcome to the wonderful world of software patents. S3 is the company behind this mess.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •