Page 5 of 5 FirstFirst ... 345
Results 41 to 46 of 46

Thread: kwin discontinued ?

  1. #41
    Join Date
    Oct 2007
    Posts
    94

    Default

    well alright i found some shady website that had the source for the lib, compiled it, move it to /usr/lib and now the game runs.

    linux is crafty

  2. #42
    Join Date
    Jan 2009
    Posts
    621

    Default

    Quote Originally Posted by pingufunkybeat View Post
    Older versions of KWin (<4.5) used to force indirect rendering. I forgot the main reason, but it might have to do with driver issues.
    Indirect rendering does not resolve any driver issues. It actually adds new issues, removes features*, and makes everything slower. If this is KDE developers' policy, then everything is starting to make sense now.

    * You can "remove" features simply by not using them.

    Quote Originally Posted by pingufunkybeat View Post
    s3tc *should* work with r300g if you install libtxc-dxtn, but only in 32 bits, and it's a shady legal situation.
    It works on a 64-bit CPU with 64-bit apps too. For it to work with 32-bit apps as well (i.e. the most closed-source games), you have to compile libdrm + Mesa libs and drivers + libtxc-dxtn with the appropriate compile flags to get the 32-bit versions of everything.

  3. #43
    Join Date
    Jun 2009
    Posts
    2,927

    Default

    Open drivers have a history of crashing when direct rendering is used, though. Open Arena had the same problem, as did many other games, back in the early days of r600c. We used to run the games using indirect rendering as a workaround.

    I agree that documenting the issue and fixing the bugs is the right way to approach this, btw.

  4. #44
    Join Date
    Oct 2009
    Location
    Netherlands
    Posts
    41

    Exclamation KWin performance pitfalls

    I have found that many times when KWin performs badly, it's either because of the chosen window decorator, or a misbehaving plasmoid.

    Both are active inside KWin's compositor render loop and some are just not well written.

    Try to create a new user on your system, and start with default window decorations and no plasmoids, then tell us if it helped

  5. #45
    Join Date
    Jan 2008
    Posts
    155

    Default

    As far as I know, KWin runs by default some checks at the start of KDE and disable OpenGL rendering, thus use software rendering, if these checks fails. However, they added an option to the disable these checks, as sometimes, the checks failed but overall, the driver could very well do OpenGL compositing.
    What you could try :

    - Go into the System Settings, and go into where Desktop Effects are set up (in 4.5.X, it's in Desktop Effects). In the last tab, check the Disable Self-Test option or whatever it's called in english (I use french so don't know the exact translation).
    - Enable the effects.
    - In the Effects tab, unselect the Blur effect (it doesn't work anyway with ATI right now, neither with r300g nor with r600g, at least on my systems).

    I sometimes have to fumble a bit with these settings (Enabling the effects fail with Blur but you cannot uncheck Blur before you tried at least once to enable the effects).
    But with this, I don't have any special lag with Kwin and it works nicely, though I don't play games, so I cannot see exactly how much they're slowed down.

  6. #46
    Join Date
    Jul 2009
    Location
    Srbija bato
    Posts
    42

    Default

    On ATI card with both radeon and fglrx driver, I have huge performance gain when I disable blur and oxygen animations (alt+f2 and type oxygen-settings and uncheck "enable animations" in widget style and window decorations).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •