Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Catalyst with Intel IGP

  1. #11
    Join Date
    Oct 2010
    Posts
    257

    Default

    Just a question: Are you using Ubuntu like maximn? If so, it'd be better to recompile the kernel disabling the hybrid graphics support explicitly. I tried to find a solution for you there, but it seems there are some problems when using the acpi_call module (I think it needs to be compiled from source to work in Ubuntu kernels, don't know really) to disable your integrated graphics...

    I can't really help you very much with this, sorry...

    Cheers

  2. #12
    Join Date
    Dec 2010
    Posts
    4

    Default

    Quote Originally Posted by evolution View Post
    Just a question: Are you using Ubuntu like maximn? If so, it'd be better to recompile the kernel disabling the hybrid graphics support explicitly. I tried to find a solution for you there, but it seems there are some problems when using the acpi_call module (I think it needs to be compiled from source to work in Ubuntu kernels, don't know really) to disable your integrated graphics...

    I can't really help you very much with this, sorry...

    Cheers
    I am using just the standard Ubuntu release 10.10 (kernel 2.6.35-23-generic). I should then disable hybrid graphics support and recompile the kernel right?

  3. #13
    Join Date
    Dec 2010
    Posts
    4

    Default

    I am using the standard Ubuntu 10.10 with kernel 2.6.35-23-generic. I suppose I have to recompile the kernel disabling the hybrid graphics support right? Would you please point me in the right direction for doing so?

    Cheers

  4. #14
    Join Date
    Dec 2010
    Posts
    8

    Default

    Quote Originally Posted by nazcaspider View Post
    I am using the standard Ubuntu 10.10 with kernel 2.6.35-23-generic. I suppose I have to recompile the kernel disabling the hybrid graphics support right? Would you please point me in the right direction for doing so?

    Cheers
    I am using standard kernel too. BTW I had no success in disabling: the results are the same which you described.

  5. #15
    Join Date
    Oct 2010
    Posts
    257

    Default

    Yes, it is... You need to disable the hybrid graphics support on your kernels, and then recompile them... It might be the best solution you've ATM.

    Cheers

  6. #16
    Join Date
    Oct 2010
    Posts
    257

    Default

    I don't know how to compile a kernel in Ubuntu (I use Arch), but I found a useful link there:

    Ubuntu 10.10 kernel compilation

    Before compiling the kernel (while you're in the "make menuconfig" procedure to configure the kernel), go to Device "Drivers -> Graphics support", and then disable the option which says "Laptop Hybrid Graphics - GPU switching support", by pressing the "N" key in your keyboard.

    Then you just need to compile your kernel like it's told in the tutorial I've sent you...

    Cheers

    p.s.: If I were you, I'd also use lsmod and lspci to strip the kernel for your hardware...

  7. #17
    Join Date
    Dec 2010
    Posts
    8

    Default

    I recompiled the kernel with the disabled hybrid card support, but the fgrlx still complains against the IGP. Did you tried yourself the fglrx with Intel IGP?

    Quote Originally Posted by evolution View Post
    Yes, it is... You need to disable the hybrid graphics support on your kernels, and then recompile them... It might be the best solution you've ATM.

    Cheers

  8. #18
    Join Date
    Oct 2010
    Posts
    257

    Thumbs down My mistake...

    Quote Originally Posted by maximn View Post
    I recompiled the kernel with the disabled hybrid card support, but the fgrlx still complains against the IGP. Did you tried yourself the fglrx with Intel IGP?
    Well, in the past (before 2.6.35) you could disable it (I've done it in some of my friends' computers, but most of them were easier, because I could do it on BIOS), as you can see in some of the posts there (me + Armin). But ATM, it seems you're out of luck with newer kernels + fglrx.
    I've searched in google some results and... Currently you can only have Intel + ATI hybrid graphics if you use both OS drivers... And hybrid graphics support enabled. (in another words, my FAIL and Linux FAIL ).

    I'm sorry for my mistake... I can't help you anymore from there...

    Cheers

  9. #19
    Join Date
    Oct 2010
    Posts
    257

    Default

    Quote Originally Posted by evolution View Post
    Well, in the past (before 2.6.35) you could disable it (I've done it in some of my friends' computers, but most of them were easier, because I could do it on BIOS), as you can see in some of the posts there (me + Armin). But ATM, it seems you're out of luck with newer kernels + fglrx.
    I've searched in google some results and... Currently you can only have Intel + ATI hybrid graphics if you use both OS drivers... And hybrid graphics support enabled. (in another words, my FAIL and Linux FAIL ).

    I'm sorry for my mistake... I can't help you anymore from there...

    Cheers
    About my last post, if you want a last try before quitting, please post here (or in pastebin) your outputs of dmesg, Xorg.log.0, lspci and lsmod... but I can't guarantee I can help you this time... (I've already tried everything I could do for you )
    Else, you'll have to stick ATM with Ubuntu + Intel...

    Cheers

  10. #20
    Join Date
    Dec 2010
    Posts
    4

    Default

    Quote Originally Posted by maximn View Post
    I recompiled the kernel with the disabled hybrid card support, but the fgrlx still complains against the IGP. Did you tried yourself the fglrx with Intel IGP?
    Same here :/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •