Not content with rewriting my /etc/hosts file so that my PCs FQDN is set to 127.0.0.1, it is also now setting the hostname to "localhost.localdomain". (This is with a wired eth0 port, for a PC that belongs to a local network connected to the Internet via a router.)

Does anyone know how to configure NetworkManager so that it stops messing around with settings that are none of its business, please? Short of uninstalling the **** thing, of course, although that is starting to sound like a very good idea.

Thanks,
Chris