Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: Connection to tv - Video not fluid - ATI Radeon X1650 (RV535)

  1. #11
    Join Date
    Dec 2007
    Posts
    2,328

    Default

    Is there a reason why you disabled kms?

  2. #12
    Join Date
    Jan 2009
    Posts
    25

    Default

    Good point.

    As I explained, I have no /etc/X11/xorg.conf file, but I didn't remember that, in the past (perhaps 2 o 3 years ago), I added some options to the grub config in order to make the boot process in text mode (instead of in graphical mode). I remember that I added the options due to a problem when playing videos, and it was fixed by booting in text mode.

    I don't remember too much, but it sounds to me that the x-server was started twice: Once for the boot process, and once for the graphical login. I did read in some forum that, by adding some options to the kernel and by booting in text mode, the x-server would be started only once, so the problem would disappear. And the problem disappeared.

    The kernel options in grub config are:

    kernel /vmlinuz-2.6.34.7-63.fc13.i686.PAE ro root=UUID=612800e0-bb0c-4ced-b859-868f6c8c31c1 rhgb quiet nomodeset SYSFONT=latarcyrheb-sun16 LANG=es_ES.UTF-8 KEYTABLE=es

    I've just removed the "nomodeset" option and tried again with the tv. Now the booting is graphical, but the video is still not fluid. Here is the xorg log (tv connected, monitor disconnected):

    http://pastebin.com/1AXN32W6

    Do you see anything more?
    I'm going to bed now, tomorrow I'll come back. Downloading fedora 14 tonight (it will take ~3 days with my slow connection...).

  3. #13
    Join Date
    Dec 2007
    Posts
    2,328

    Default

    Everything looks fine. I suspect the HD videos may just be more than your CPU can handle. At the moment, the driver only handles rendering (color space conversion and scaling) on the GPU. Decode (mc, idct, etc.) is still done on the CPU. You might try the multi-threaded ffmpeg if you have a multi-core CPU.

  4. #14
    Join Date
    Jan 2009
    Posts
    25

    Default

    The problem happens even with low resolution videos and low cpu usage.
    For example, for:

    mplayer 'Matrix I.avi'
    VIDEO: [XVID] 640x256 12bpp 25.000 fps 1104.8 kbps (134.9 kbyte/s)

    the CPU keeps at 20-30% of usage in full screen. But, just at minute 2 (2:00), the camera walks vertically on an hotel, and I can see crearly that the walking is not fluid. This happens both with monitor or with tv.

    Perhaps the problem is what bridgman said, that fedora 13 has not good support for my card?

  5. #15
    Join Date
    Dec 2007
    Posts
    2,328

    Default

    Probably bicubic filtering, depending on what version of the driver you are using. Try disabling it:
    xvattr -a XV_BICUBIC -v 0

  6. #16
    Join Date
    Jan 2009
    Posts
    25

    Default

    Worked!
    Video is more fluid now (both with monitor or with tv), but still not totally fluid. Any more suggestion?

    If it helps you, these are the default values of "xvattr" after login:

    http://pastebin.com/WXw8bC5f

  7. #17
    Join Date
    Oct 2009
    Posts
    2,064

    Default

    You didn't do anything silly, like enabling desktop effects, did you?

  8. #18
    Join Date
    Jan 2009
    Posts
    25

    Default

    Right, desktop effects are disabled.
    I think there are no things that could affect video.

  9. #19
    Join Date
    Jan 2009
    Posts
    25

    Default

    Downloading Fedora 14... 75%
    Popcorn this weekend, I hope.

  10. #20
    Join Date
    Jan 2009
    Posts
    25

    Default

    No luck :-(
    Upgraded to fedora 14, video still not fluid.
    Tested with and without "xvattr -a XV_BICUBIC -v 0" command.
    Xorg log:
    http://pastebin.com/F3qytjpR

    Any ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •