Results 1 to 8 of 8

Thread: r600g scandal

  1. #1
    Join Date
    Oct 2009
    Posts
    71

    Angry r600g scandal

    sdlmame[32491]: segfault at 60 ip 00007f041f8c2339 sp 00007fff6b375400 error 4 in r600g_dri.so[7f041f723000+b21000]

    NO SDLMAME FOR ME.

    vdrift also hangs at "Start Race". Also no vdrift for me.

    TOTAL SCANDAL.

  2. #2
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,776

    Default

    Call the New York Times.

  3. #3
    Join Date
    Oct 2009
    Posts
    71

    Default

    Quote Originally Posted by RealNC View Post
    Call the New York Times.
    I did and they initially listened so I started reading them this backtrace:
    $ gdb sdlmame
    (..)
    (gdb) run -video opengl -rompath /public/net/godzilla/games/MAME/roms/ mslug2
    Starting program: /usr/games/bin/sdlmame -video opengl -rompath /public/net/godzilla/games/MAME/roms/ mslug2
    [Thread debugging using libthread_db enabled]
    Warning: unknown option in INI: useallheads
    Warning: unknown option in INI: useallheads
    [New Thread 0x7ffff427e710 (LWP 29182)]
    [New Thread 0x7ffff04e9710 (LWP 29183)]
    WARNING: Couldn't find/open TrueType font Liberation Sans, using MAME default

    Program received signal SIGSEGV, Segmentation fault.
    0x00007ffff2188339 in r600_set_vertex_buffers () from /usr/lib64/dri/r600_dri.so
    (gdb) bt
    #0 0x00007ffff2188339 in r600_set_vertex_buffers () from /usr/lib64/dri/r600_dri.so
    #1 0x00007ffff223959c in st_draw_vbo () from /usr/lib64/dri/r600_dri.so
    #2 0x00007ffff22362a3 in vbo_draw_arrays () from /usr/lib64/dri/r600_dri.so
    #3 0x0000000000ff96f9 in drawogl_window_draw(_sdl_window_info*, unsigned int, int) ()
    #4 0x0000000000ff1cc6 in draw_video_contents_wt(void*, int) ()
    #5 0x0000000000ff2fc6 in sdlwindow_video_window_update(running_machine*, _sdl_window_info*) ()
    #6 0x0000000000fd39ac in sdl_osd_interface::update(bool) ()
    #7 0x00000000016206c4 in video_manager::frame_update(bool) ()
    #8 0x00000000015ebd47 in display_loading_rom_message(_romload_private*, char const*) ()
    #9 0x00000000015ecf9f in process_rom_entries(_romload_private*, char const*, rom_entry const*) ()
    #10 0x00000000015edf17 in rom_init(running_machine*) ()
    #11 0x0000000001597b02 in running_machine::start() ()
    #12 0x000000000159803b in running_machine::run(bool) ()
    #13 0x00000000015963d0 in mame_execute(osd_interface&, _core_options*) ()
    #14 0x000000000154fbe5 in cli_execute(int, char**, osd_interface&, _options_entry const*) ()
    #15 0x0000000000fd03bf in main ()
    (gdb) quit
    They listened for a few seconds but then they apparently got overwhelmed by the immensity of this information and hung up. Don't say I didn't try.

  4. #4
    Join Date
    Jan 2007
    Posts
    459

    Default

    that is indeed scandalous , they didnt even tell you to use a real Mame (slightly older than 0.140 but good it seems) and run it on and AROS LiveCD, the shame

    http://aros-exec.org/modules/newbb/v...forumpost51234

    http://aros.sourceforge.net/

  5. #5
    Join Date
    May 2007
    Posts
    352

    Default

    So did you open a bug report? Or check to see if one already exists?

  6. #6
    Join Date
    Oct 2009
    Posts
    71

    Default

    Quote Originally Posted by adamk View Post
    So did you open a bug report? Or check to see if one already exists?
    I did, but Chris files a report 40 minutes before me at https://bugs.freedesktop.org/show_bug.cgi?id=32455. Mr. Deucher had to use his already-to-little time to mark mine as duplicate.

    I even got a patch from Jerome Glisse to try, it didn't make sdlmame work with vbo but atleast he tried.

    sdlmame will run with gl_vbo 0 in sdlmame/mame.ini, this disables vertex buffers. This does not solve that they don't work, but it makes sdlmame not use them and the games can be played.

    vdrift runs on my box now with or without said patch, it didn't the other day, not sure if it's because of new kernel (2.6.37-rc5-git6) or new mesa or why but it works and that's great.

  7. #7
    Join Date
    Jan 2008
    Posts
    297

    Default

    So, what was your purpose in this thread? Just to bitch?

    I mean, what are you upset about? Someone closed your bug as a duplicate? I can't see how it'd be anything else, since Jerome was working on the problem and just committed a patch which he thinks fixes it.

    Try to be less sensational in future bitchings.

  8. #8
    Join Date
    Oct 2009
    Posts
    71

    Thumbs up

    Quote Originally Posted by mattst88 View Post
    So, what was your purpose in this thread? Just to bitch?
    Yes. It really does help (me) when things don't work.

    Quote Originally Posted by mattst88 View Post
    I mean, what are you upset about? Someone closed your bug as a duplicate?
    That was my fault for posting a duplicate in the first place.

    Quote Originally Posted by mattst88 View Post
    I can't see how it'd be anything else, since Jerome was working on the problem and just committed a patch which he thinks fixes it.
    I am very glad and thankfull that mr. Glisse is all over this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •