Results 1 to 6 of 6

Thread: Catalyst ignores xorg.conf

  1. #1
    Join Date
    Dec 2010
    Posts
    3

    Default Catalyst ignores xorg.conf

    I'm using Catalyst 8.78 (installed by synaptic) + Ubuntu 10.10.
    I've also made the same tests on this configurations:
    Catalyst 10.12 (from ATI.com) + Ubuntu 10.10
    Catalyst 10.12 (from ATI.com) + Ubuntu 9.10
    Video card: ATI HD4770
    Display: Samsung SyncMaster 795MB (CRT)
    Xrandr version: 1.3.3


    The problem:
    My CRT has 1600x1200 max resolution. Open-source drivers automatically set up xrandr to use this resolution (and works perfect), but fglrx can't surpass 1280x1024.


    The tested solution:
    I've tested adding a 1600x1200 mode using both CVT and GTF commands. Results: both could make the display work at 1600x1200 but there is a huge amount of black borders (about 15% of the screen).

    So, I got an underscan problem. I've tried scaling the screen using catalyst control center, but since the amount of borders is too high, CCC could reduce them just a little. Well, maybe the borders are there because the VGA is sending wrong horizontal sync and vertical refresh rates to the monitor.


    Xorg.conf - adjusting Horizsync and Vrefresh:
    3 tests were made:

    1) Got this values from an old xorg.conf when I had a nvidia card (but same monitor):
    Code:
       Horizsync 28 - 33
       Vrefresh  43 - 72
    2) Got this values from monitor manual (I did supose that vertical refresh and vertical sync are the same because I couldn't find the first one on the manual):
    Code:
       Horizsync 30 - 85
       Vrefresh  50 - 160
    Manual link: http://www.samsung.com/us/support/su...mdl_name=795MB

    3) Just used the default "aticonfig --initial" generated xorg.conf file (monitor info should be automatically get by fglrx).


    Results: all were the same! I mean, all the xorg.conf resulted in the same ammount of border at the same position! Is like fglrx is completely ignoring xorg.conf!!

    Another relevant result that makes me believe in this is that adding a line in xorg.conf like this:
    Code:
    Modes       "1600x1200" "1280x1024" "1024x768"
    or this

    Code:
    ModeLine    "1600x1200_60" 175.50 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
    Makes absolutely NO difference. I mean, when I do start X, there will be no 1600x1200 option available on xrandr until I add them manually using the "xrandr --newmode" and then "xrandr --addmode" commands!

    What's the secret? I don't mind installing another version of Catalyst if there's a trick for a specific version or even installing another version of Ubuntu.

  2. #2
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,766

    Default

    As you wrote in the title of this post yourself: Catalyst ignores xorg.conf. There's nothing you can do about it. What you want to configure, configure it in the Catalyst Control Center.

  3. #3
    Join Date
    Feb 2010
    Posts
    519

    Default

    Quote Originally Posted by RealNC View Post
    As you wrote in the title of this post yourself: Catalyst ignores xorg.conf. There's nothing you can do about it. What you want to configure, configure it in the Catalyst Control Center.
    Actually it's only half the truth: aticonfig ignores changes to xorg.conf unless you specify the file.

    Here's what's at the bottom of the help file when one runs aticonfig without options:
    Examples:
    1. Setting up fglrx for the first time.
    Single head : aticonfig --initial --input=/etc/X11/xorg.conf
    Dual head : aticonfig --initial=dual-head --screen-layout=above
    This command will generate a dual head configuration
    file with the second screen located above the first
    screen.
    Multi head : aticonfig --initial --heads=4 --adapter=1
    This command will generate 4 adjacent X Screens
    on adapter 1. Use with -f to reduce previously configured heads.
    @OP, run the above (bold row) as root without X running.

  4. #4
    Join Date
    Mar 2010
    Posts
    12

    Default

    Fglrx doesn't look at xorg.conf, but at it's own internal DB when starting X. In this DB it keeps all the relevant option from your xorg.conf the last time aticonfig read it. So if you make changes to xorg.conf run:
    sudo aticonfig --input=/etc/X11/xorg.conf
    This should update it's DB.

  5. #5
    Join Date
    Dec 2010
    Posts
    3

    Default

    Quote Originally Posted by koenvdd View Post
    Fglrx doesn't look at xorg.conf, but at it's own internal DB when starting X. In this DB it keeps all the relevant option from your xorg.conf the last time aticonfig read it. So if you make changes to xorg.conf run:
    sudo aticonfig --input=/etc/X11/xorg.conf
    This should update it's DB.
    Oh, this is new info for me. Let me find some free time to make new tests. I may post results later.

  6. #6
    Join Date
    Aug 2007
    Posts
    6,598

    Default

    I had issues with modeline entries in xorg.conf too with my crt, fglrx just ignores em. I never managed to use 1152x864 @ 100 Hz with fglrx. No problem with nvidia. I do not worry about this anymore since i replaced my crt by a huge tft, but do not expect that modelines would work... I guess fglrx is the best reason to get rid of a crt

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •