Results 1 to 7 of 7

Thread: Temporary fix regarding FPS fluctuations in openSUSE 11.3 since fglrx 10.10

Hybrid View

  1. #1
    Join Date
    Feb 2010
    Posts
    519

    Default Temporary fix regarding FPS fluctuations in openSUSE 11.3 since fglrx 10.10

    Gotta investigate this further, but this is what seems to work so far:

    When booting, manually add
    Code:
    noapic pci=nomsi
    to the default GRUB entry.

    2 days in a row that this trick results in flawless performance.

    Why not add it to the GRUB menu once and for all and be done with it, you may ask? Because I remember trying it and that it only worked after the first reboot, never on cold starts.

    So I'm gonna monitor how interrupts are flipped around during the coming week and report on my findings.

  2. #2
    Join Date
    Feb 2010
    Posts
    519

    Default

    That didn't last long...
    New theory:
    When experiencing FPS fluctuations, reboot and change kernel boot options.
    Back in a few days...

  3. #3
    Join Date
    Oct 2010
    Posts
    257

    Default

    Quote Originally Posted by PsynoKhi0 View Post
    Gotta investigate this further, but this is what seems to work so far:

    When booting, manually add
    Code:
    noapic pci=nomsi
    to the default GRUB entry.

    2 days in a row that this trick results in flawless performance.

    Why not add it to the GRUB menu once and for all and be done with it, you may ask? Because I remember trying it and that it only worked after the first reboot, never on cold starts.

    So I'm gonna monitor how interrupts are flipped around during the coming week and report on my findings.
    Did you also tried it with Catalyst 10.11 / 10.12?

    That might be more likely to be a kernel-like problem (some backported patch or similar) than a driver one, but there also are some motherboard configurations that don't like to have fglrx + MSI enabled...

    Personally, the only kernel-line option I put in grub for loading fglrx with no problems is passing the option "nomodeset", editing the file /boot/grub/menu.lst.

    Cheers and Merry Xmas!

  4. #4
    Join Date
    Feb 2010
    Posts
    519

    Default

    Quote Originally Posted by evolution View Post
    Did you also tried it with Catalyst 10.11 / 10.12?
    Yes, using 10.12 right now, but these slowdowns have been plaguing me since 10.10, hence the title.

    Quote Originally Posted by evolution View Post
    That might be more likely to be a kernel-like problem (some backported patch or similar) than a driver one,
    Probably, though I had idea where to start from, so I gave those options a shot.

    Quote Originally Posted by evolution View Post
    Personally, the only kernel-line option I put in grub for loading fglrx with no problems is passing the option "nomodeset", editing the file /boot/grub/menu.lst.
    Never been a issue here, and I've tried that too

    Quote Originally Posted by evolution View Post
    Cheers and Merry Xmas!
    Thanks, you too!

  5. #5
    Join Date
    Sep 2008
    Posts
    989

    Default

    `noapic' will very adversely affect your CPU performance if you have a multicore processor. AFAIK, absence of an APIC essentially limits you to a single core. MSI is a very useful performance improvement commonly used for on-board network cards, and they can also help for other PCI/PCI-Express cards.

    Disabling these things shouldn't be necessary; you might want to hand-roll your own kernel and tweak the interrupt frequency and the preemption model.

  6. #6
    Join Date
    Feb 2010
    Posts
    519

    Default

    Quote Originally Posted by allquixotic View Post
    `noapic' will very adversely affect your CPU performance if you have a multicore processor. AFAIK, absence of an APIC essentially limits you to a single core. MSI is a very useful performance improvement commonly used for on-board network cards, and they can also help for other PCI/PCI-Express cards.
    The "noapic" was a desperate move.
    Thanks for the info about MSI, I merely went after recommendationsfound on this forum.

    Quote Originally Posted by allquixotic View Post
    Disabling these things shouldn't be necessary; you might want to hand-roll your own kernel and tweak the interrupt frequency and the preemption model.
    I'll look into that, thanks for the heads-up! Sounds like a hassle for a stable release though The openSUSE kernel guys might be interested.

  7. #7

    Default

    Set all your cpu cores to max performance before starting any game.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •