Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Mesa 7.10, Mesa 7.9.1 Released To The Wild

  1. #1
    Join Date
    Jan 2007
    Posts
    14,788

    Default Mesa 7.10, Mesa 7.9.1 Released To The Wild

    Phoronix: Mesa 7.10, Mesa 7.9.1 Released To The Wild

    Mesa 7.10 has been released!..

    http://www.phoronix.com/vr.php?view=ODk5Nw

  2. #2
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,791

    Default

    Did someone get r600g to work with KDE 4.6? (With enabled desktop effects.) Here, only r600c works. r600g just results in a frozen picture. Everything keeps working; I can operate KDE blindly, but the screen just won't update and displays the image that was seen right just before compositing was enabled. KDE 4.5 worked fine.

    This is with an HD4870.

  3. #3
    Join Date
    Jan 2009
    Posts
    624

    Default

    Is there anything interesting in dmesg?

  4. #4
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,791

    Default

    Nope. Everything seems normal, including dmesg and Xorg.0.log.

    Forgot to mention that I tried both kernel 2.6.36 as well as .37. And Mesa git master, libdrm git master and xf86-video-ati Git master.

  5. #5
    Join Date
    Oct 2010
    Posts
    145

    Default

    I've got sauerbraten not working anymore with r300g saying:

    init: sdl
    init: net
    init: game
    init: video: mode
    X Error of failed request: BadValue (integer parameter out of range for operation)
    Major opcode of failed request: 129 (XFree86-VidModeExtension)
    Minor opcode of failed request: 10 (XF86VidModeSwitchToMode)
    Value in failed request: 0x156
    Serial number of failed request: 125
    Current serial number in output stream: 127
    xorg.1.log:

    [ 12.618] (EE) open /dev/fb0: No such file or directory
    [ 12.618] (EE) No devices detected.
    [ 12.618]
    Fatal server error:
    [ 12.618] no screens found
    [ 12.618]
    All graphics stack and drm from xorg edgers, running on top of kernel 2.6.33 in ubuntu 10.04. Whats wrong?

  6. #6
    Join Date
    Oct 2010
    Posts
    145

    Default

    PS: only sauerbraten doesn't work and it makes me think framebuffer object support is not working properly, cause its the only game that needs it on my system. The game should fall back to software rendering if it doesn't find the extension, but in this case I think it finds it but crashes.

  7. #7
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,458

    Default

    That doesn't look like FBO, more like a mode switch / modesetting issue. AFAIK the /dev/fb0 message refers to the kernel framebuffer driver, not framebuffer objects.

  8. #8
    Join Date
    Jan 2009
    Posts
    624

    Default

    Quote Originally Posted by glxextxexlg View Post
    I've got sauerbraten not working anymore with r300g saying:



    xorg.1.log:



    All graphics stack and drm from xorg edgers, running on top of kernel 2.6.33 in ubuntu 10.04. Whats wrong?
    Please file a new bug at https://bugs.freedesktop.org/

  9. #9
    Join Date
    Dec 2008
    Posts
    315

    Default

    Quote Originally Posted by marek View Post
    Is there anything interesting in dmesg?
    Dmesg has been cleared to pop up and annoy you. Are you interested? Yes No.

  10. #10
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,584

    Default

    Quote Originally Posted by Hephasteus View Post
    Dmesg has been cleared to pop up and annoy you. Are you interested? Yes No.
    Lol, reminds me of the Starship Troopers movie with their "tv ads" in it "Would you like to find out more? Yes/No".

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •