Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Strange problem with radeon driver in Kubuntu

  1. #1
    Join Date
    Jul 2009
    Location
    Srbija bato
    Posts
    42

    Default Strange problem with radeon driver in Kubuntu

    Finally I was tired of random freezes in fullscreen flash (youtube and games) and in Hedgewars, so I removed fglrx and now I am using radeon driver. But now I have strange problem.

    When display of laptop is switched off, Clementine player stops playing music. When I move mouse, display turns on, and Clementine continues to play music and I can see that Skype is disconnected and then it reconnects.

    I installed Kubuntu Natty few days ago on my test partition. So, it is a clean install, with stock packages, and the problem described above persist.

    With fglrx I have no such problems so I think radeon driver is to blame.

    What do you think? Any suggestions?

    *MSI laptop, AMD Athlon X2, Mobility Radeon HD 2400.

  2. #2
    Join Date
    Nov 2008
    Posts
    77

    Default

    Most likely you are not actually "turning of the display" but suspending the entire laptop. Fglrx has compatibility problems with suspend in some configurations, so it is possible suspension was disabled when using fglrx, but are now available.

    If you are using KDE and "turning of the display" by shutting the lid, please check your powersaving settings in Systemsettings - Advanced - Power Management - Edit Profiles.
    For each profile there is a setting what the computer will do when the lid is closed. If it is set to "Suspend in memory" instead of "Turn of the display", that is the problem...

  3. #3
    Join Date
    Jul 2009
    Location
    Srbija bato
    Posts
    42

    Default

    I am turning off display for sure. Here is a snapshot of my power profile (I removed battery so there is only one power profile):
    http://www.dodaj.rs/f/1B/Js/4ww8pPeC/snapshot6.png

    And the same problem occurs in clean install of Natty, for which fglrx is not yet available.

  4. #4
    Join Date
    Nov 2008
    Posts
    77

    Default

    Quote Originally Posted by schnelle View Post
    I am turning off display for sure. Here is a snapshot of my power profile (I removed battery so there is only one power profile):
    http://www.dodaj.rs/f/1B/Js/4ww8pPeC/snapshot6.png
    Well, given the symptoms I'm still fairly certain your laptop get suspended, the question is only what triggers it...

    You can fool your system to think that suspend and hibernate is unsupported by editing /usr/lib/pm-utils/pm-functions and replacing these functions:
    Code:
    check_suspend() { [ -n "$SUSPEND_MODULE" ]; }
    check_hibernate() {  [ -n "$HIBERNATE_MODULE" ]; }
    check_suspend_hybrid() {  [ -n "$SUSPEND_HYBRID_MODULE" ]; }
    with these:
    Code:
    check_suspend() { false; }
    check_hibernate() {  false; }
    check_suspend_hybrid() { false; }
    and restart the computer.

    Also, do you get the same symptoms if you use the command line to turn of the display?
    Code:
    xset dpms force off

  5. #5
    Join Date
    Jul 2009
    Location
    Srbija bato
    Posts
    42

    Default

    Quote Originally Posted by Jonno View Post

    Also, do you get the same symptoms if you use the command line to turn of the display?
    Code:
    xset dpms force off
    Yes, I get the same symptopms.

    I will try with editing pm-functions and will report back.

    Thank you for helping me. I really don't want to go back to fglrx.

  6. #6
    Join Date
    Jul 2009
    Location
    Srbija bato
    Posts
    42

    Default

    Editing pm-functions didn't solve the problem.

  7. #7
    Join Date
    Jul 2009
    Location
    Srbija bato
    Posts
    42

    Default

    I installed fglrx again, and problems described above disappeared.

    But now I see tearing everywhere, scrolling in chromium is not as smooth as with radeon driver etc...

  8. #8
    Join Date
    Nov 2008
    Posts
    77

    Default

    Quote Originally Posted by schnelle View Post
    Quote Originally Posted by Jonno View Post
    Also, do you get the same symptoms if you use the command line to turn of the display?
    Code:
    xset dpms force off
    Yes, I get the same symptopms.
    To my knowledge there is no userspace callbacks for dpms off, and the only kernelspace callback I'm aware of is the powersaving one.

    What is the output of this?
    Code:
    tail /sys/class/graphics/fb*/device/power_*
    If power_method is profile and power_profile is auto, high or mid, the profile will be set to low on dpms off. If that is the case, see what happens when you set it to low manually:
    Code:
    echo low | sudo tee /sys/class/graphics/fb*/device/power_profile
    And does setting power_method to profile and power_profile to default (eg disable gpu powersavings) solve the problem?
    Code:
    echo profile | sudo tee /sys/class/graphics/fb*/device/power_method
    echo low | sudo tee /sys/class/graphics/fb*/device/power_profile
    If this doesn't help, I'm afraid I'm out of ideas.

  9. #9
    Join Date
    Jul 2009
    Location
    Srbija bato
    Posts
    42

    Default

    I tested power saving options and these are my findings.

    When system starts, power_method is profile and power_profile is default.

    When I change power_profile to low, problem is not solved but it occurs after few hours rather than after few minutes. The same happens if I choose high/mid profile or go back to default profile.

    So I am almost 100% sure that this problem occurs because of power management in 2.6.35 kernel (default maverick kernel). In Kubuntu Karmic and Lucid I didn't have this problem but back then radeon pm didn't existed yet. Btw now I am using 2.6.38 kernel and latest ati (radeon) driver.

    I tried to disable radeon pm by adding to grub "radeon.pm=0" but this doesn't work.

    So for now I will use screensaver rather than turning off display. I am not going back to fglrx torture, that's for sure

    Thank you very much for the help Jonno, but it seems that problem of mine is not solvable at the moment.

  10. #10
    Join Date
    Dec 2007
    Posts
    2,371

    Default

    The default profile is equivalent to disabling pm. The default profile leaves the card at it's default boot up power state.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •