Page 1 of 8 123 ... LastLast
Results 1 to 10 of 75

Thread: ATI-fglrx 8.29.6 and FC6

Hybrid View

  1. #1
    Join Date
    Oct 2006
    Location
    Sweden
    Posts
    13

    Default ATI-fglrx 8.29.6 and FC6

    Hi!

    Having trouble building the ati-fglrx drivers for FC6 with kernel 2.6.18-1.2759 also hade the same problem with the 2747 version of the kernel.

    To begin with when i do
    sh ./ati-driver-installer-8.29.6.run --buildpkg Fedora/FC6

    this comes upp

    Generating package: Fedora/FC6
    install: cannot stat `fireglcontrolpanel': No such file or directory
    Package build failed!

    Ok so it's something wrong with the control panel or whatever realy don't care but then it starts to build the driver and then crashes. I Have been googleing around for three days now and havent found any solution.

    Her is what console spits out.

    Creating directory fglrx-install
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.29.6............................................ .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................
    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Fedora/FC6
    install: cannot stat `fireglcontrolpanel': No such file or directory
    Package build failed!
    Package build utility output:
    Building target platforms: i386
    Building for target i386
    Executing(%prep): /bin/sh -e /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/rpm-tmp.24966
    + umask 022
    + cd /tmp/ATI-fglrx-8.29.6-1-13479-root/BUILD
    + LANG=C
    + export LANG
    + unset DISPLAY
    + cd /tmp/ATI-fglrx-8.29.6-1-13479-root/BUILD
    + cd ATI-fglrx-8.29.6
    ++ /usr/bin/id -u
    + '[' 0 = 0 ']'
    + /bin/chown -Rhf root .
    ++ /usr/bin/id -u
    + '[' 0 = 0 ']'
    + /bin/chgrp -Rhf root .
    + /bin/chmod -Rf a+rX,u+w,g-w,o-w .
    + exit 0
    Executing(%build): /bin/sh -e /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/rpm-tmp.24966
    + umask 022
    + cd /tmp/ATI-fglrx-8.29.6-1-13479-root/BUILD
    + cd ATI-fglrx-8.29.6
    + LANG=C
    + export LANG
    + unset DISPLAY
    + exit 0
    Executing(%install): /bin/sh -e /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/rpm-tmp.24966
    + umask 022
    + cd /tmp/ATI-fglrx-8.29.6-1-13479-root/BUILD
    + cd ATI-fglrx-8.29.6
    + LANG=C
    + export LANG
    + unset DISPLAY
    + rm -rf /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root
    + '[' -d /etc/ld.so.conf.d ']'
    + mkdir -p /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/etc/ld.so.conf.d
    + pushd /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/etc/ld.so.conf.d
    /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/etc/ld.so.conf.d /tmp/ATI-fglrx-8.29.6-1-13479-root/BUILD/ATI-fglrx-8.29.6
    + cat
    + popd
    /tmp/ATI-fglrx-8.29.6-1-13479-root/BUILD/ATI-fglrx-8.29.6
    + mkdir -p /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/usr/share/applications
    + pushd /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/usr/share/applications
    /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/usr/share/applications /tmp/ATI-fglrx-8.29.6-1-13479-root/BUILD/ATI-fglrx-8.29.6
    + cat
    + popd
    /tmp/ATI-fglrx-8.29.6-1-13479-root/BUILD/ATI-fglrx-8.29.6
    + cp -pR /tmp/ATI-fglrx-8.29.6-1-13479-root/BUILD/ATI-fglrx-8.29.6/etc /tmp/ATI-fglrx-8.29.6-1-13479-root/BUILD/ATI-fglrx-8.29.6/lib /tmp/ATI-fglrx-8.29.6-1-13479-root/BUILD/ATI-fglrx-8.29.6/usr /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root
    + find /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/usr/share/doc -type f -perm 0555 -exec chmod 0644 '{}' ';'
    + find /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root -type f -perm 0555 -exec chmod 0755 '{}' ';'
    + export AS_USER=y
    + AS_USER=y
    + pushd /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod
    /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod /tmp/ATI-fglrx-8.29.6-1-13479-root/BUILD/ATI-fglrx-8.29.6
    + bash make.sh verbose
    ATI module generator V 2.0
    ==========================
    initializing...
    OsRelease=2.6.18-1.2759.fc6
    major=2
    minor=6
    patch=18
    extra=-1.2759.fc6
    SMP=1
    smp=-SMP
    iii=
    AGP=1
    CC=gcc
    cc_version=
    cleaning...
    patching 'highmem.h'...
    assuming new VMA API since we do have kernel 2.6.x...
    Assuming default VMAP API
    doing Makefile based build for kernel 2.6.x and higher
    make -C /lib/modules/2.6.18-1.2759.fc6/build SUBDIRS=/tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod/2.6.x modules
    make[1]: Entering directory `/usr/src/kernels/2.6.18-1.2759.fc6-i686'
    CC [M] /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
    /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:92:26: error: linux/config.h: No such file or directory
    /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:459: warning: initialization from incompatible pointer type
    /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'firegl_stub_open':
    /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:582: warning: assignment discards qualifiers from pointer target type
    /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_smp_call_function':
    /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3896: warning: passing argument 1 of 'smp_call_function' from incompatible pointer type
    make[2]: *** [/tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
    make[1]: *** [_module_/tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod/2.6.x] Error 2
    make[1]: Leaving directory `/usr/src/kernels/2.6.18-1.2759.fc6-i686'
    make: *** [kmod_build] Error 2
    build failed with return value 2
    error: Bad exit status from /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/rpm-tmp.24966 (%install)


    RPM build errors:
    Bad exit status from /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/rpm-tmp.24966 (%install)
    Removing temporary directory: fglrx-install

    I also tried to build generic packages but with the same resulte.

    Can someone pleas help me or if ther ar any others out there that are getting the same error.

    ps. I have tried runing the ati-driver-***.run as root and non root doesent make any difference, my video card is as FireGLV3100 and this driver has worked with this card on other dist but not with a kernel 2.6.18.ds

    Cheers

  2. #2

    Default

    Quote Originally Posted by Patrik Lavén View Post
    Hi!

    Having trouble building the ati-fglrx drivers for FC6 with kernel 2.6.18-1.2759 also hade the same problem with the 2747 version of the kernel.

    To begin with when i do
    sh ./ati-driver-installer-8.29.6.run --buildpkg Fedora/FC6

    this comes upp

    Generating package: Fedora/FC6
    install: cannot stat `fireglcontrolpanel': No such file or directory
    Package build failed!

    Ok so it's something wrong with the control panel or whatever realy don't care but then it starts to build the driver and then crashes. I Have been googleing around for three days now and havent found any solution.

    Her is what console spits out.

    Creating directory fglrx-install
    Verifying archive integrity... All good.

    <OUTPUT>
    RPM build errors:
    Bad exit status from /tmp/ATI-fglrx-8.29.6-1-13479-root/tmp/rpm-tmp.24966 (%install)
    Removing temporary directory: fglrx-install
    I also tried to build generic packages but with the same resulte.

    Can someone pleas help me or if ther ar any others out there that are getting the same error.

    ps. I have tried runing the ati-driver-***.run as root and non root doesent make any difference, my video card is as FireGLV3100 and this driver has worked with this card on other dist but not with a kernel 2.6.18.ds

    Cheers
    Patrik,

    Welcome to the forums.

    It looks like the problem is coming from firegl_public. The 8.29.6 drivers should support the Linux 2.6.18 kernel (in 8.28.8 there was a 2.6.18 patch found in some distribution-specific packaging scripts). I (and others) have had no problems running the drivers with FC6 after making the UTS_RELEASE modification, but I haven't updated to Rawhide in a few days for the newest kernel. I'll give the kernel version you mentioned a whirl and see if I can make it work out.

  3. #3

    Default

    Patrik,

    I managed to work out the problem with the drivers and Fedora Core 6 with the newest 2.6.18 kernels. Rather than waiting for the next fglrx drivers to have these changes merged, I can probably write-up a how-to guide or patch if you are interested.
    Last edited by Michael; 10-14-2006 at 07:11 PM.

  4. #4
    Join Date
    Oct 2006
    Location
    Sweden
    Posts
    13

    Default

    Michael,

    I'd realy appreciate a how-to or a patch, what ever is more convenient for you.
    Thanks for the quick replies.

  5. #5

    Default

    http://www.phoronix.com/redblog/?p=blog&i=NTUwMA

    Wrote that up quickly. Let me know if it helps.

  6. #6
    Join Date
    Oct 2006
    Location
    Sweden
    Posts
    13

    Default

    Hi again,

    Now I get the exact same problem as in this post.

    http://www.phoronix.net/forums/showthread.php?t=233

    But I found that the kmod-fglrx-8.29.6 for kernel 2.6.18-1.2784 i586 and
    i686 hade poped up in my repos probably from freshrpms and
    xorg-x11-drv-fglrx 8.29.6 from livna. So I will give that a try

    After installing the drivers from the repos i got this problem when i do cat /var/log/Xorg.0.log | grep fglrx

    (EE) AIGLX error: dlopen of /usr/lib/dri/fglrx_dri.so failed
    (/usr/lib/dri/fglrx_dri.so: cannot open shared object file: No such file
    or directory)

    Ok then I did ln -s ../xorg/modules/dri/fglrx_dri.so fglrx_dri.so and now Xorg.0.log givs this error instead.

    (EE) AIGLX error: dlopen of /usr/lib/dri/fglrx_dri.so failed
    (/usr/lib/dri/fglrx_dri.so: undefined symbol: __glXFindDRIScreen)

    And typing fglrxinfo givs me
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

    When I installed the drivers from the repos they pulled in libstdc++-compat i think as a dependency and now I have the ati controlpanel in my menu and it works correctly but offcourse displays mesa as OpenGL Vendor.

    This problem might deepend on that I don't have the agpgart module loaded, and modprobe agpgart says FATAL: Module agpgart not found.

    I'l bee trying to digg some more and report back if I come up with any solution.

    Cheers,

  7. #7

    Default

    When fglrxinfo was reporting Mesa, did you have Option "Composite" "Disable" in your Extensions section in your xorg.conf? If not, make a "Extensions" section and then throw that option in there, restart X, and see if it works. I've had that issue with FC6 before.

  8. #8
    Join Date
    Oct 2006
    Location
    Sweden
    Posts
    13

    Default

    Yes I have Option Composite Disable in xorg.conf.

    So I don't realy know where the problem lies but I would guess that it has something to do with this error from the Xorg.0.log

    (EE) AIGLX error: dlopen of /usr/lib/dri/fglrx_dri.so failed
    (/usr/lib/dri/fglrx_dri.so: undefined symbol: __glXFindDRIScreen)

    Havent hade the time to examen it, I think I have bumped in to something similar before with other distros so I will have to look around a bit and se if someone else have had the same problem.

    Does anyone know why I can't load the agpgart module, has it been replaced by something else in kernel 2.6.18? Even thoug I shouldent need the agpgart module I have read in other forums that it might bee needed anyway to get the fglrx module to behave correctly.

  9. #9

    Default

    Patrik,

    I have written some updated FC scripts for the fglrx 8.29.6 drivers. This mainly patches the code so it no longer requires linux/config.h, but there are also a few other modifications. If you're still running into problems, it may be worth trying out.

    The script can be found @ http://www.phoronix.com/redblog/down...6-generator.sh

    Throw it in the same directory as ati-driver-installer-8.29.6.run and then run the script and wait for the RPMs. If the 8.29.6 driver isn't found in the directory it will attempt to download that first from ATI.

    I've tried the script on FC6 Rawhide under a fresh install and its worked flawlessly. After I carry out some additional tests I'll write something on the blog about it with more details.

  10. #10
    Join Date
    Oct 2006
    Location
    Sweden
    Posts
    13

    Default

    Hi,

    Whene I remove the kmod-fglrx drivers from the repos and then run the script you provided it exits with this error

    RPM build errors:
    File not found: /tmp/ATI-fglrx-8.29.6-1-4556-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/usr/bin/fireglcontrolpanel
    Removing temporary directory: fglrx-install

    Also in the begining of the installation the ATI installer reports this error:

    install: cannot stat `fireglcontrolpanel': No such file or directory

    it is the same error that is reported in this thread http://www.phoronix.net/forums/showthread.php?t=233

    I have all the QT stuff installed except from the qt-tools package wich I can't find in the repos. I might try to make a fresh install and see if I will have better luck, but doubt it.

    Is there a way to just build the kmod and not the fireglcontrolpanel wich seams to be the major problem for me to get the drivers to build.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •