Page 7 of 8 FirstFirst ... 5678 LastLast
Results 61 to 70 of 75

Thread: ATI-fglrx 8.29.6 and FC6

  1. #61
    Join Date
    Nov 2006
    Posts
    2

    Default

    Quote Originally Posted by Michael View Post
    Did you grab the 8.30.3 drivers? If not, grab them, they are newer and have the new scripts integrated.
    I tried the 8.30.3 drivers too, and this is what I get:

    [root@mckinney src]# ati-driver-installer-8.30.3.run --buildpkg Fedora/FC6
    Creating directory fglrx-install
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.30.3............................................ .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. ..........................................
    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Fedora/FC6
    Please install an appropriate Linux kernel module build package.
    Probably kernel-devel in this case.
    If you've compiled a custom kernel, make sure /usr/src/linux exists
    and the source tree matches the currently running kernel.
    Removing temporary directory: fglrx-install

  2. #62
    Join Date
    Nov 2006
    Posts
    5

    Default

    hey yall,
    i have an hp laptop with a radeon xpress 200M, i have FC6 and used yum to get the newest driver... when i type in the grep command to scan the xorg file i get the message(II) fglrx(0): Direct rendering disabled. bellow is my xorg.conf file... please tell me what im doign wrong.


    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Synaptics" "CorePointer"
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    Load "dri"
    Load "glx"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Synaptics"
    Driver "synaptics"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "auto-dev"
    Option "Emulate3Buttons" "yes"
    EndSection

    Section "Monitor"

    ### Comment all HorizSync and VertSync values to use DDC:
    Identifier "Monitor0"
    ModelName "LCD Panel 1024x768"
    HorizSync 31.5 - 48.5
    VertRefresh 40.0 - 70.0
    Option "dpms"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "radeon"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "on"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

  3. #63

    Default

    It doesn't look like from your configuration that Composite was disabled. Try disabling Composite and it should work (see here). Though it is important to note that the Xpress 200 series is notorious with Linux.

  4. #64
    Join Date
    Nov 2006
    Posts
    5

    Default

    hmm ok Michael, well i tried it and allthough it did something i also lost my ability to view everythign else... like blank screen. however no error messages or windows or well anything... i dont know if you have heard of this problem before...

  5. #65
    Join Date
    Nov 2006
    Posts
    5

    Default

    also i see you have a build for a xorg.conf file in the link you sent me... do you think that copying that may fix my issues? i know probably not but its worth asking.

  6. #66

    Default

    The blank screen I believe is one of the common problems with the Xpress 200.

  7. #67
    Join Date
    Oct 2006
    Posts
    6

    Default None really

    Quote Originally Posted by pi_rho View Post
    also i see you have a build for a xorg.conf file in the link you sent me... do you think that copying that may fix my issues? i know probably not but its worth asking.
    Please if you are having a blank screen try the Option "BusType" "PCI" in the driver section of the xorg.conf file. It worked for me . Check to see if you ssh into the machine and see what was going on. Mine had the cpu spiked at 100%.(x11) I currently have XGL working in fc6 using the 8.26 drivers.

  8. #68
    Join Date
    Nov 2006
    Posts
    5

    Default

    ok tried the BusType PCI code and that didnt have any affect... i did try to Secure shell and nothing seemed out of the ordinary just the fact that when i attempted to see if open gl worked it gave me the same old "direct rendering disabled"... could someone with FC6 running openGL and has a xpress 200M post an example xorg.conf file. Thanks

  9. #69
    Join Date
    Nov 2006
    Posts
    5

    Default

    question, did you mean the Driver section or the Device section when talking about BusTpe PCI command line. I just want to clarify to make sure i got this correct

  10. #70

    Default

    Device for BusType.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •