Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Can't enable Gallium3D on R700 (4650)

  1. #1
    Join Date
    Dec 2010
    Location
    Skopje, MK
    Posts
    48

    Default Can't enable Gallium3D on R700 (4650)

    Hi,

    I can't enable Gallium3D on my system. System Specs:

    Distro: Ubuntu 10.10 (Linux Mint 10)

    Kernel: 2.6.37-020637-generic

    xorg-edgers PPA added, Mesa 7.11-git, xf86-video-ati 6.13.99

    When I add Option "ForceGallium" "True" in xorg.conf, Xorg log says Option "ForceGallium" not used.

    Another question: How can I install 2.6.38? Latest kernel build in kernel ppa is 2.6.37-999

    Any help will be appreciated.

  2. #2
    Join Date
    Jul 2008
    Posts
    26

    Default

    Hello,

    you should build mesa with --enable-gallium-r600 to activate gallium driver, and you don't need to use that option in xorg.conf.

  3. #3
    Join Date
    Dec 2010
    Location
    Skopje, MK
    Posts
    48

    Default

    Quote Originally Posted by lucx View Post
    Hello,

    you should build mesa with --enable-gallium-r600 to activate gallium driver, and you don't need to use that option in xorg.conf.
    Thanks. Turns out that the newest mesa/radeon in xorg-edgers lost that option. However, I installed the packages from xorg-edgers/radeon and gallium was enabled by default.

  4. #4
    Join Date
    Mar 2010
    Posts
    5

    Default

    I have the xorg-edgers/ppa and xorg-edgers/radeon ppas. I think gallium is enabled but I'm not sure. What I do know is that programs don't run as well with gallium as they did last month. Am I doing something wrong?

  5. #5
    Join Date
    Dec 2010
    Location
    Skopje, MK
    Posts
    48

    Default

    Quote Originally Posted by JDShu View Post
    I have the xorg-edgers/ppa and xorg-edgers/radeon ppas. I think gallium is enabled but I'm not sure. What I do know is that programs don't run as well with gallium as they did last month. Am I doing something wrong?
    Remove /ppa and leave just /radeon. Or better yet, remove both of them, then add /radeon and you should have gallium on by default. Tried that yesterday evening, it was working fine. Tried it with Penumbra Overture, huge performance gain.

  6. #6
    Join Date
    Mar 2010
    Posts
    5

    Default

    Thank you! Works perfectly now

    Exciting times ahead for radeon oss drivers.

  7. #7
    Join Date
    Jul 2008
    Posts
    26

    Default

    Hello,

    to be shure that you have gallium driver build do an:

    glxinfo | grep "OpenGL"

    and you should not have something like this :


    glxinfo |grep "OpenGL"
    OpenGL vendor string: Tungsten Graphics, Inc
    OpenGL renderer string: Mesa DRI Mobile IntelĀ® GM45 Express Chipset GEM 20100330 DEVELOPMENT x86/MMX/SSE2
    OpenGL version string: 2.1 Mesa 7.11-devel
    OpenGL shading language version string: 1.20
    OpenGL extensions:


    this is just classic mesa, with galluim you will see something with "OpenGL version Gallium 0.4"

  8. #8
    Join Date
    May 2009
    Location
    Exodus hair
    Posts
    76

    Default

    What about us that are on Natty?

  9. #9
    Join Date
    May 2009
    Location
    Exodus hair
    Posts
    76

    Default

    Quote Originally Posted by zika View Post
    What about us that are on Natty?
    Sacrificed midory and epiphany, re-installed xserver-xorg-input-{all,synpatics} and, voila, 1.9.99.901...
    Thank You xorg-edgers...

  10. #10
    Join Date
    May 2009
    Location
    Exodus hair
    Posts
    76

    Default

    When we can expect to see Gallium for Natty?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •