Results 1 to 4 of 4

Thread: Configuring Smplayer For VDPAU

  1. #1
    Join Date
    Nov 2010
    Posts
    7

    Default Configuring Smplayer For VDPAU

    I use the Smplayer GUI for mplayer and I was wondering what video settings were best when using the VDPAU ouput driver.


    I've tried thousands of settings, but I still get SLOWER performance with VDPAU, than XVideo.

    I tried using 4 CPU threads or no threads (since I read that they could conflict)

    I tried "draw video with slices," "double buffering."

    But everything produced the same, slower results.



    Whenever I use VDPAU to play a video with fast motion and multiple special effects, the video skips for a half-second, during intensive scenes.


    My NVIDIA Driver Specifications:
    - Binary NVIDIA driver version 260.19.06
    - Installed all VDPAU decencies
    - Switched audio output from "pulse" to "alsa"

    My System Specifications:
    - Kubuntu 10.10
    - Smplayer 0.6.9 (SVN r3447)
    - Mplayer 1.0 rc4

    My Hardware Specifications
    - Geforce GTX 460
    - Intel Core 2 Quad 2.4 GHZ
    - 8 GB RAM
    - Hard Disk ---- Western Digital Caviar Green 2 TB

  2. #2
    Join Date
    Nov 2010
    Posts
    7

    Default

    I made some typos above (4 video threads!?) but after 1 minute the forum software blocked me from fixing my mistakes.

    Sorry for any confusion.

  3. #3
    Join Date
    Aug 2007
    Posts
    6,675

    Default

    Do you really use vc override like

    -vc ffh264vdpau,ffmpeg12vdpau,ffvc1vdpau,ffwmv3vdpau,

    together with

    -vo vdpau

    ?

  4. #4
    Join Date
    Nov 2010
    Posts
    7

    Default

    Aha! I think I found the mistake!

    When I ran your commands with the command-line version of mplayer, there was NO LAG during the entire video.

    The major difference between your settings and mine was...you didn't include the option for ASS subtitle-formatting.


    I tested my theory with Smplayer, and by turning off ASS formatted-subtitles I noticed the same smooth performance.


    ======


    The issue appears to be, that VDPAU is trying to smooth the subtitle fonts AND the video at the same time, and gets overwhelmed during complex video decoding.

    Is it possible to block VDPAU from smoothing subtitles? Or is such an option not available?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •