Results 1 to 2 of 2

Thread: No direct rendering with Catalyst 10.12 on Maverick (Radeon HD 4200)

Hybrid View

  1. #1
    Join Date
    Jan 2011
    Posts
    1

    Default No direct rendering with Catalyst 10.12 on Maverick (Radeon HD 4200)

    Hello,

    I installed fglrx according to ATI doc on Maverick distrib. Graphic Card is a Radeon HD 4200 embedded on the GA-MA785-UDH3 MOBO. Everything runs fine (Compiz, fgl_glxgears at 750FPS). However: glxinfo returns "direct rendering: no". Debugging info:

    libGL: OpenDriver: trying /usr/lib/fglrx/dri/tls/swrast_dri.so
    libGL: OpenDriver: trying /usr/lib/fglrx/dri/swrast_dri.so
    libGL error: dlopen /usr/lib/fglrx/dri/swrast_dri.so failed (/usr/lib/fglrx/dri/swrast_dri.so: cannot open shared object file: No such file or directory)
    libGL: OpenDriver: trying /usr/lib32/fglrx/dri/tls/swrast_dri.so
    libGL: OpenDriver: trying /usr/lib32/fglrx/dri/swrast_dri.so
    libGL error: dlopen /usr/lib32/fglrx/dri/swrast_dri.so failed (/usr/lib32/fglrx/dri/swrast_dri.so: cannot open shared object file: No such file or directory)
    libGL error: unable to load driver: swrast_dri.so
    libGL error: reverting to indirect rendering

    Tested all I founded over the net.

    Any ideas ?

    Best,

    Nicolas

  2. #2
    Join Date
    Feb 2010
    Posts
    20

    Default

    Hi Nicolas

    Just install the driver from this ppa which has the latest catalyst drivers for your distribution.Its just around 40 Mb compared to the one from the site which is a monstrous 100 mb and also provides a proper way of installing any software on your system.

    https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

    In case it doesnt work after installation , type in a terminal

    sudo aticonfig --f

    And it should be working fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •