Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: no boot on latest kernel drm-radeon-testing/add NI pci ids

  1. #1
    Join Date
    Nov 2008
    Posts
    57

    Default no boot on latest kernel drm-radeon-testing/add NI pci ids

    The latest drm-radeon-testing kernel does not boot but hangs at a black screen. I'm at commit "add NI pci ids". There has been no change in my kernel .config since drm-radeon-testing rc3.

  2. #2
    Join Date
    Dec 2007
    Posts
    2,328

    Default

    What hardware are you using? If you are using 6xx, 7xx, or evergreen hw you may need this patch:
    http://git.kernel.org/?p=linux/kerne...fa3eee4520f5e5

  3. #3
    Join Date
    Mar 2008
    Location
    Istanbul
    Posts
    134

    Default

    Same here but using 2.6.38-rc1...
    I thought that patch already included to rc1.
    I also tried to run my 6850 with KMS drm-testing before
    at this topic with same result.

    Anyway I tried again with changed bios compliance modes set to DISABLED or GEN1 but it doesn't helps.

    I am not using KMS booting but fglrx. I get into shell via "3" as boot parameter at grub.
    When I try to load radeon kernel with KMS computer became BSOD... CTRL+ALT+DEL doesn't working yet. But modprobing okey if I made modeset=0.

    Does it any way to debug this easy? I couldn't print dmesg lines here due lockup

  4. #4
    Join Date
    Dec 2007
    Posts
    2,328

    Default

    The best bet would be to bisect and see what commit is causing the problem for you. It would also be easier to track this if you opened a bug report:
    https://bugs.freedesktop.org
    Select "DRI", then, "DRM/Radeon"

  5. #5
    Join Date
    Mar 2008
    Location
    Istanbul
    Posts
    134

    Default

    I open a bug report.

    Also don't know if it work (try each git commit one by one) since NI doesn't supported before. Might be understand which commit triggers that behavior but I am not experienced on git well. Might be try later, if it's not fixed on other release candidates.

  6. #6
    Join Date
    Nov 2008
    Posts
    57

    Default

    To revert 1 commit at a time:
    Code:
    git reset --hard HEAD~1
    It may take a while to find the commit. I'll try the patch. I'm using an HD3850/RV670 card.

  7. #7
    Join Date
    Dec 2007
    Posts
    2,328

    Default

    Quote Originally Posted by charlie View Post
    To revert 1 commit at a time:
    Code:
    git reset --hard HEAD~1
    It may take a while to find the commit. I'll try the patch. I'm using an HD3850/RV670 card.
    Use git bisect. It's much easier.

  8. #8
    Join Date
    Nov 2008
    Posts
    57

    Default

    This is the commit that causes boot to fail: http://git.kernel.org/?p=linux/kerne...45f2fbb4faacf9 (drm/radeon: use system_wq instead of dev_priv->wq)

    Commit "vga_switcheroo: fix build with non switcheroo enabled path" builds fine.

  9. #9
    Join Date
    Nov 2008
    Posts
    57

  10. #10
    Join Date
    Dec 2007
    Posts
    2,328

    Default

    Quote Originally Posted by charlie View Post
    This is the commit that causes boot to fail: http://git.kernel.org/?p=linux/kerne...45f2fbb4faacf9 (drm/radeon: use system_wq instead of dev_priv->wq)
    I don't really see how that would cause an issue, but Tejun may have some ideas. Please file a bug:
    https://bugzilla.kernel.org/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •